Norns 200424 updating issue

just tried to run the update via UPDATE on norns.

norns complained and said it ran out of memory and needed 400 (of some sort of memory space denomination…sorry i don’t remember).

i deleted some audio files and tried to re-run the install.

now norns says it’s Up To Date…but it displays 200328 on the main screen.

i tried a RESTART and also a SLEEP but it keeps saying that it’s Up To Date.

maybe try deleting ~/version.txt

1 Like

I am having an issue after updating, no scripts will run - all are giving me the following error :

/home/we/norns/lua/core/clock.lua:179: attempt to call a nil value (field 'clock_link_set_quantum')

going to try updating the scripts, and run the update again and see if that helps…

ok yea, checking it after a long and busy week… this update is perhaps not quite ready in a couple of aspects

… which is why it has not yet actually been announced, and in fact has a big ol’ red Pre-release tag :slight_smile:

1 Like

i apologize— was working on the new release (for sunday) and mistakenly believed that marking the github attribute “prerelease” meant it wouldn’t show up when norns tries to scrape for new versions (i swear this worked before, but obviously not, or something changed, eh).

i’ve removed the files.

try deleting version.txt and re-run the update to revert to 200328


Ok thanks for the update. I saw NEW clock system and got over excited!

like @Eastwood
i also got all giddy about the new clock thingamajig.

i’ll wait on updating for now.

different issue now…and i’m posting this just as an FYI…

norns #1 updated to 200424 tonight.

i opened maiden to add some new scripts…
both of the BASE and COMMUNITY listings are gone.
i hit the little recycle button and it pops up the REFRESHING CATALOG banner…but then it just sits there and does nothing.

i hit the “X” and tried several more times but it just did the same thing.

i tried connecting to norns #2 which is still on 200328 and the library works correctly.

i just rebooted norns #1 from SLEEP and that worked!

all fixed now.