Norns / Ableton Link / Router Problems

Been trying to get my Norns to use Ableton Link for tempo, and after a couple hours of hair pulling I pretty much confirmed it must be my router. Now for an abundance of details…

I’m running Reason on a Macbook Pro on the same wifi network as a Norns Shield, and neither the Norns nor Reason seemed to find each other and match each other’s tempos (even after adjust tempos on both platforms). So I wrote a little Node.js app using the Ableton-Link package, and confirmed I can change tempos between Reason and the Node app no problem on the same laptop. Alas when I tried running the on another laptop on the wifi network I ran into the same issue. Finally realized I could just cut out the router and use the Norns as a hotspot and bingo – everything works as expected. Reason, Norns, and Node are all playing nice with each other.

It’s a stock Verizon Fios G1000 router, and it just seems odd that googling this problem doesn’t immediately return any results of people running into this problem before. Did my best to confirm that the Router is not blocking port 20808, so it might be a Multicast issue? Hoping somebody might have some insight to something I’m overlooking or stroke of genius.


Have you tried doing it over Ethernet? Seems archaic but it seems like even using wifi could introduce noticeable delay times depending on several factors. Same reason I don’t use Bluetooth for MIDI.