Norns and crow connection issue

hello!

I’m having some issues with norns and crow connection, since I updated my norns to the last update, I think… not entirely sure if the issue is from the update.
I did a search on the forum for similar problems but could not find any.

factory norns is on 210114 and crow is on 2.0.0.

I use crow, most of the time with live and max and all is ok using it with the computer. with norns I’m experiencing difficulties connecting it to crow. most of the time I cannot get a connecting going no matter what I start first.

in maiden if I use the crow.connected() it always returns false
and when I connect crow to norns I sometimes get this info in maiden:

ttyACM found, but not a crow
dev_list_add: error allocating device data

and this:

norns.crow.add / 2 / crow: telephone line
norns.crow.remove 2

the strange thing is, this happens with norns using the original power supply and battery (that is not that good anymore). if I plug my norns to my modular power supply, that has a 5v 2A USB port, I get true when I type crow.connected() in maiden right away. I tried this with other USB charges with no luck, same result as using the norns charger or battery.

can anyone help or have any info? thanks!

EDIT: if helps, here is a pic of the modular power supply

hey @sno , sorry to hear about the trouble! can you please post the specs of the other USB power supplies you’re using that aren’t working (you mentioned some non-stock ones that caused the same trouble as your now-dead stock supply)? it’s odd that the modular supply would give signs of life.

fwiw, this is the replacement power supply for a stock norns, which (despite the product page header text) supplies 5.25V and 2A.

also, might be worth reflashing crow with the latest firmware: Release Version 2.1.1 · monome/crow · GitHub

hey @dan_derks, thanks for your reply!

the other ones I’ve tried were regular 5V 2A USB chargers.

I don’t think I need a new power supply, because this also happens while I’m using the battery, and it shouldn’t, right?
might this be happening because my battery is not as good as new? sometimes it goes from 100% to 0% in like 5 minutes, with nothing special going on (no grid connected). it also jumps from 0% to 100% when I connect the power supply. so the norns battery is not behaving normally.

didn’t know about a new crow update, I’ll try it out and report back.

yes, this is what I cannot understand! why does everything work properly with the modular power supply… not that properly cause I get those ground noises, but properly with norns and crow connections.

1 Like

oh, yeah, this is definitely service-qualifying. we should pick this up via email: help@monome.org

1 Like

email sent and thanks for your help @dan_derks !

just closing the loop for future travelers:

through email, we uncovered that the USB hub was repeatedly kicking the crow off and bringing it back on, resulting in streams of this being printed to maiden:

>>>>>> norns.crow.add / 28 / crow: telephone line
>>>>>> norns.crow.remove 28
>>>>>> norns.crow.add / 29 / crow: telephone line
>>>>>> norns.crow.remove 29
>>>>>> norns.crow.add / 30 / crow: telephone line
>>>>>> norns.crow.remove 30
>>>>>> norns.crow.add / 31 / crow: telephone line
>>>>>> norns.crow.remove 31
>>>>>> norns.crow.add / 32 / crow: telephone line
>>>>>> norns.crow.remove 32
>>>>>> norns.crow.add / 33 / crow: telephone line
>>>>>> norns.crow.remove 33
>>>>>> norns.crow.add / 34 / crow: telephone line
>>>>>> norns.crow.remove 34
etc...

since the battery was also acting funky, we worked with @sno to replace the board.

this decision came after:

  • reflashing crow firmware
  • confirming crow’s connection was stable with other computers (in this case, using the Max for Live devices)
  • trying additional cables to connect crow
  • testing every USB port on norns
  • testing from battery power as well as wall power
1 Like