Norns: CM3+ installation

anyone know when the CM3+ 32gb will be available again? (or even better, does anyone have an extra to sell?) really wanting to expand norns space…

1 Like

I think I saw on mouser (or another similar) new stock coming in August.

(edit: Although I just saw a few available on Yahoo Japan, but not sure of the logistics of dealing with that site from overseas).

1 Like

@speakerdamage @mutedial I found mine via eBay.

1 Like

I have a CM3+ coming (well, two, a 32gb and an 8gb one by accident) :slightly_smiling_face:

What are people doing with the original CM from Norns? Are there any other useful music tools that use the RPi CM/CM+ module? The only ones I know use the pi 3 model b+ (e.g. pisound).

if people have leftover un-purposed CM3’s i’d happily take them back for future repairs!

9 Likes

Success!! That was (relatively) painless. I wrote up a step-by-step guide (below) to upgrading Norns with the CM3+.

But major issues were (tldr): If you have problems connecting with rpiboot try it a few times and/or switch cables, and the image listed in the Github here didn’t work for me I had to use norns190405.tgz [I’m a little confused about pull requests and wikis in terms of fixing that)

But besides those things it really wasn’t difficult. I love Norns, thanks everyone who’s been making these awesome libraries. :two_hearts:

Upgrading Your Norns with a CM3+

Note: I did this on a Macbook Air running Mojave 10.14.4

  1. Install new CM3+ module. Edit: back up your stuff before you remove the original CM Taking off the knobs was very easy. I used a set of flat tweezers to carefully undo the lugs, 2 out of 3 were easy, 1 was a little stiff. Unscrew everything, open up the Norns and pop out the CM card, put in CM3+ card, making sure it’s seated correctly (it’ll click into place). I screwed in the PCB at this point, but did not screw in the cover. Put switch on bottom to Disk Also I stood Norns upright, as some mentioned the reset button being accidentally pressed and causing problems

  2. Get Norns image: Note: the instructions here mention “replace url with newest image” and norns181008.img.zip as that image. This didn’t work for me. Instead: wget https://monome.nyc3.digitaloceanspaces.com/norns190405.tgz and then tar xzf norns190405.tgz which will create an image file (norns190405.img).

  3. On command line (in Terminal, etc), install rpiboot using steps here.

  4. Do not plug any cables in yet. Run sudo ./rpiboot (Note: when when you run sudo ./rpiboot you should be in the usbboot directory).

  5. Now connect USB cable into power of Norns, and then into computer. If it hangs at Waiting for BCM2835/6/7, see instructions here. I had to switch USB cables and it then worked fine

  6. rpiboot will output a bunch of stuff (see here). (On my Mac I had a popup that said “The disk you inserted was not readable by this computer” with options Initialize | Ignore | Eject. I clicked Ignore.

  7. Use balenaEtcher (super easy!). The CM3+ (“compute module”) should appear in the middle. Select the Norns image from the directory. Click Flash. This should take about 9-10mins, then another 7-8mins for a second step (“validate”).

  8. Flip switch to run. Then turn on Norns. Make sure wifi nub is inserted in Norns. Put in wifi password, turn on wifi, click update to update Norns to latest (norns190422), and then hit Reset. (At some point add in all the neat libraries).

  9. Expand disk space. With Norns hooked up to computer, in Terminal ssh into Norns following instructions here. screen /dev/tty.usb [TAB] [RETURN] (where [TAB] and [RETURN] are button presses, don’t type them; I usually hit return a few more times to get to login screen). User name is we, password is sleep.

  10. Then type sudo raspi-config and hit return. You’ll see a menu of options pop up. Scroll down to “Advanced” and hit return. Next screen select “expand filesystem”. Hit return and a bunch of stuff happens. Then reboot Norns (SLEEP) and turn back on. If you ssh back into Norns and type df -h you will see the newly expanded space!

  11. At some point between step 8 and here put bottom plate on and put in screws, retighten lugs, put on knobs, etc.

  12. Have hours of inspirational fun.

Most of the above is collated from the very useful information spread around on this thread and in the github, so I just collated it and wrote it down as I went (I might be forgetting people but thanks @ngwese, @tehn, @mlogger).

34 Likes

Thank you so much for this!!

1 Like

If you don’t mind me asking what search criteria did you use and did you buy from a shop on there? I’ve searched active and completed/sold listings but haven’t come across anything on ebay.

I tried just now and found two more using the search terms “raspberry pi compute 32”, but they’re expensive.
If you’re willing to wait a month, order here.
I’m sure there’s more options, I only googled twice to find these.

how do I kill rpiboot ? thanks for your help with this? on MacOS 10.13.6

I think ctrl + c should do it?

thank you for your help!!

1 Like

By kill I generally meant just stopping rpiboot if it was still running. Assuming it was run in the terminal shell you can use the CTRL-C key combo.

1 Like

Thank you and everyone here for making this a fairly painless operation! I have my Norns up and running

1 Like

ok my CM3+ arrived today and I’d like to go ahead and ‘upgrade’. Where do I find the latest img to download?

@riggar use this guide: Norns: CM3+ installation

we should make it official

Ok I’m on it

I’ve go to step 4 - Do not plug any cables in yet . Run sudo ./rpiboot (Note: when when you run sudo ./rpiboot you should be in the usbboot directory).

I’ve run sudo ./rpiboot and it’s asking me for a password? Which I wasn’t expecting tried things like the m/c signon password, ‘sleep’ to no avail - what now?

its asking you for an admin password on your system because sudo

2 Likes

ah ok! many thanks! :grinning::grinning::grinning:

Ok got passed the password - must take care as mac air numbers are a little tricky on the keyboard - some time since I’ve used it and forgot.

Now next problem is the sudo .rpiboot results in a command not found msg