Norns-crash -totally unresponsive

While using cheat codes I had a crash in which I could not get the unit to respond in any manner. The hard reset on the bottom did nothing. No button combination worked either. I had to let the norns unit run out of batteries. Is there a procedure to follow when this happens to restart the unit or prevent corruption? I could not find this specifically in the norns thread.

that’s astounding that the bottom button didn’t reset it— it’s hard-wired to cut the power, so perhaps your switch went bad (i can replace it)

we have a PR about ready to be merged which would provide a soft-reset in a lockup situation.

any chance you tried to connect via wifi? wondering what part of the system crashed.

Yeah. It was weird as I know the bottom switch is like the nuclear option. The wifi nub was in as I recently updated , but had not used it or transferred data during this session. It oddly kept producing sound perfectly. I didn’t notice until I couldn’t get the grid to respond and then realize ex nothing was responding. At the time of the crash, I was doing nothing new. I was editing the sound on another norns to feed in to the affected unit. Should I attempt to use the hard reset switch to test with a freshly restarted system?

might as well. as brian says, the only thing i can imagine is a bad switch.

have you opened the case? checked the internal disk mode switch? i remember one instance where that was left in a weird halfway state causing baffling problems

i’m also curious about the stuff that was happening while using cheat codes that got you into a crash state to begin with – i have only ever gotten into non-responsive states when I am testing accidentally-perpetual while loops, but never under normal circumstances. any data that you can share around that (using delays, any Patterns playing (how many?), were you meta-sequencing, how were you clocking, etc) would be :100:

(fwiw, nearly-ready update will reduce CPU when using meta-sequencing)

I tried repeatedly pressing and got it to work. I had my norns serviced before so perhaps it was seated slightly off from the guide hole.

Let me recall-three pattern recorders going. Using all three buffers that were sequenced with the pattern recorders.Delays were active. clocked internally. buffers set to one-shot. Had running perhaps 30 minutes mainly rerecording the buffers and altering the loop sizes. As mentioned it continued to run the audio with just the interface meta sequencing or external midi mapping. no arc in this case.

i’d be curious what the CPU and temp were reading at this point?

1 Like

I’ll keep an eye on those next session.

1 Like