norns disk space seems wrong?

i have a 4gb norns model. calculating the we folder size using cyberduck says the total is 805 mb. pressing k2 on the norns main screen shows 260 mb remaining. i noticed when using norns the other day that the available recording time on the tape kept dwindling down pretty rapidly even though i wasn’t doing/recording anything. i’m noticing this after updating to version 220321. before the update i had a lot more free space and didn’t see the available recording time going down inexplicably.

i tried expanding the filesystem by connected to the norns via the terminal and ssh, but that didn’t change anything. i also tried resetting the norns and that didn’t help either. i tried to update to see if there was a new version but i can’t because it says i need 400 mb and it only sees the 260.

am i missing something obvious?

There was a similar-sounding issue here.

tl;dr the issue was a mysterious audio file that was quite large. You may want to have a look at your tapes folder (and/or the audio folder/sub-folders) to see if there’s anything in there that you’ve forgotten about.

1 Like

there’s a post in the link you shared that says that a 4gb norns should have 1gb left after a clean install, which would fall roughly in line with what i have left. maybe the system files are just taking up more space than they used to or i didn’t notice before. maybe this isn’t an issue.

thanks for the link!

1 Like

this might be a logging overflow bug. try (via ssh or screen)

sudo du -h /var/log
2 Likes

here’s the output from that command. seems like there are several pretty large files. is that normal?

4.0K /var/log/samba/cores/nmbd

4.0K /var/log/samba/cores/smbd

12K /var/log/samba/cores

72K /var/log/samba

36K /var/log/apt

350M /var/log/journal/8c4778817d5b4fad92166a8840486cc8

350M /var/log/journal

4.0K /var/log/private

402M /var/log

you can safely do

sudo rm -rf /var/log/journal

we need to figure out why there is some superfluous logging happening

6 Likes