Norns: help

probably a good place to start, if you haven’t:

See tutorial scripts in scripts/r_tutorial, hacks in scripts/r_hacks and jah scripts moln, rymd, bob and shifty for more elaborate examples.

1 Like

Not sure if this is the right place but…

I have an old Akai APC20 is like to use with the Norns until I get a Grid. Is it possible to work with any midi controller, and can you send messages to controllers as well as receive - so you can trigger button lights etc?

Cheers.

Cool! So this means one could create a Lua script with any number of MultiOSC channels, each with its own timbre? :grinning:

1 Like

Yep, as long as it’s midi class compliant you should be able to connect it to norns and play notes or control params with CC

Amazing. Getting use out of old hardware :slight_smile: Thanks.

Check out this thread for reports on what people are using!

2 Likes

I’m updating my scripts for the norns 2.0 release. As part of this I’ve simplified the scripts a bit. The new versions (hosted at https://github.com/antonhornquist/jah-scripts) might also be of interest for anyone interested in the R engine.

6 Likes

Apologies this may be in the docs but I can’t find it - can the Norns send raw midi out?

Can you change patches on the fly, from a MIDI controller?

  1. Yes. Check Study 4 https://monome.org/docs/norns/study-4/

  2. I have not seen this as a stated feature.

Do you mean “change the current script running on norns? (Or load a different script?)” if so, not via midi. But you can from a web browser.

Ok thanks, would be a great feature for computerless performance.

The scripts are not like presets on a synth. They really are like independent instruments. Some scripts do currently offer saving and loading their own internal presets. This is pretty transparent.

Keep in mind norns is not like a beatbox or standalone synth. Those have a feature set and you pretty much work with what’s there.

That’s not norns.

in fact you can certainly call script.load() from a MIDI handler if that’s your thing, or execute any other lua code.

there are no ‘patches’ per se, just programs.

4 Likes

Oh wow… I was just wondering if that would work. Neat.

OK. So if I had different programs for different songs, I could create a kind of menu program and load the relevant script from MIDI.

I need to get into this thing and play. Pay day is 2.5 weeks away, then I just need to wait for shipping!

1 Like

FWIW - you’d need to have a set of functions for the midi script selection in EACH of your scripts.

With a master “script-launcher” you could launch another script, but would need something similar to get back to your script-launcher again.

Sounds like a good job for a user library

Also FWIW - Norns 2.0 includes a helper type for song_select MIDI message - so if your controller could send that message, you could map that to opening various scripts. You could really use any control message at all, but might be best to not use something obvious like CCs. Even more FWIW - Sysex messages are not yet supported.

1 Like

Must admit I’ve been very frustrated with my norns lately- totally unclear if its user error or if something is wrong with mine.

At the moment I just want to try out @LFSaw 's Haven script- noticed it appeared to be in Dust now. (though I am not a programmer so my knowledge of how github works is basically nothing, I don’t know what pull request is, etc. etc.)

In the past when I wanted to add scripts I just used wifi or hotspot, made a new script, and copy-pasted the code that I found in Dust. I noticed for Haven however that I also have to add an engine.

So I investigated how others merge dust updates with their norns, and I saw that some use a USB drive, where you download dust from github, unpack it and put it on a drive. Then “sync from” USB. (I’m aware this could mean loss of saved things but I don’t have anything I need to backup).

Tried doing that today, and when I select “sync from USB” it happens INSTANTLY, and it appears nothing has changed- no new scripts, etc. Tried with other USB drives, all freshly FAT formatted, same thing.

So I figured okay why not try WIFI/maiden again to see if I cant manually copy/paste the engine and script. And today for whatever reason, wifi can barely recognize any networks, and when it can and I try to connect, it consistently comes up with “failed.” This is a new problem, as wifi has worked for me in the past.

So I figured okay why not try hotspot, that has also worked for me in the past. Fire up hotspot, gives me the IP address, and my computer struggles enormously to find it in the list of available networks, and again when it does, it stalls for a bit and then drops connection.

At this point, is there some way I can do a damn factory reset or something? At a bit of a loss right now because I just cannot seem to ever get this device to behave the way I want anymore, and I’m so excited by everyone’s fantastic scripts, but again I don’t know if I’m doing things wrong or if my device is just totally out of whack.

2 Likes

i’m writing up instructions for an image reset right now.

part of 2.0 (beta of which i’m preparing to upload now) focusses on script sharing and collecting. the wifi system is overhauled and has been working more reliably (though hotspot is now not functioning, working on it.)

main issue is the Haven script has an engine that goes along with it, which needs to be properly installed, and beyond released updates we do not have a documented way for people to update their engines. until now many of the more complex processes have been left to developers… the 2.0 update aims to simplify sharing/collecting for everyone.

i’m sorry for the trouble and frustration— i understand and it’s been a huge goal to evolve this part of the ecosystem

17 Likes

For the technologically … timid … of us, it would be a huge relief to just be able to plug and go, so big thanks for all you’re doing to make this easy for the masses.

3 Likes

Hey im super new to the Monome world, so far loving it i just got a Norns and couldnt be happier, started using the scripts that came with the norns, i tried to get more from dust via usb, sadly some ss problem happened, in the end i had to delte some file using Cyberduck, anyway the thing is that norns funtions good again but the new scripts are failed to load, wondering if someone can help, thabks again and always.