Norns: help

the update should be ready later today— it includes a lot of fixes and changes and there is a small wifi fix but can’t say for sure it’ll fix your setup. are you just getting the “failed” bug? is your router on WPA mode?

2 Likes

20 characters of WPA2

I’m just glad its working like a charm now! what a great little machine, you can already tell its going to be a classic in ten years time (like everything monome).

Congrats on another great release!

:bird:

2 Likes

Seem to have gotten my norns into a non-booting state – stuck on the :star2: startup animation every time, no peripherals connected :thinking:

I was in the middle of trying to create a sc engine at the time, quite likely the sc file I just uploaded to norns had some silly errors in it. I rebooted, then got into this state.

Anyone have suggestions how to get back in there?

ah yea - that’s one of the bigger drawbacks at the moment. just pushed some changes to begin addressing it. (now you can continue to use the menu even if sclang fails to compile the class library.)

for now, connect over the serial port and revert your SC changes.

screen /dev/ttyUSB0 115200

2 Likes

cool got it. thanks for the speedy reply!

edit: I should add for anyone else who has the same problem that this format worked for me:
screen /dev/tty.usb(tab) 115200

1 Like

@Heath we’re not sure why wifi is failing for you, there are some UI inconsistencies addressed in next update but nothing major.

  • does hotspot mode work?
  • is the signal weak / have you tried moving close to your router? (you can see -dBm reading on the wifi screen; anything below about -48 is going to be problematic.)
  • @ppqq had some issues with certain authentication settings but i’ve forgotten what they were or what the fix was. iirc it was more granular than just “WPA2”
1 Like
  1. Yes, works.
  2. I don’t know. I can’t get it to work we’re it shows the signal strength. It’s about two feet from the router.
  3. I can enter my WiFi network and password, it fails and then 2 out of 3 times crashes to where I needed to reset. I’m now getting password fail errors when the password is (triple checked) correct

Thank you

This is a potentially dumb question, but when connecting to my wifi network and entering the password, is there no way to enter a space on norns?

I get these issues as well. I was able to tty in and run ifconfig. it looks like norns is actually connecting to my wifi but the norns reports it as a failed password not allowing me to use my browser to connect at the norns ip address or norns.local. i am able to get everything to work in hotspot mode.

1 Like

right. if your router has anything like a “performance mode” that may be the ticket, since it can bounce incompatible devices. i’d check on that and consider disabling it in favor of “compatibility” mode. possibly not a long-term solution but worth a try. also, be mindful of any potentially interfering firewall settings.

@Galapagoose: @tehn i think mentioned you having similar woes; do you recall what did it?

also, as @adrianf mentions:

it bears repeating that there are false negatives reported by the wifi script. it’s possible that you’re actually connected but don’t know it. if zeroconf works (e.g., your router doesn’t block it), you may just try connecting via a browser at norns.local:5000. failing that, using screen to make a serial connection and see what’s up is your next best bet for debugging. if you’re on mac os, i’m happy to help walk you through that. either here, via pm or on github.

2 Likes

How long should sync to USB take?

currently at 10-12min and wondering if I should let it keep going.

On average, it’s taken ~5-10 mins for me when I’m syncing around 250mb+ of new tape recordings.

It finished around 15min, but I did have some long Tape files.

1 Like

While not the most convenient if you have maiden open while the sync in performed you will see the file paths go by in the REPL as it works.

Ideally there would be similar progress/output to the display as well.

4 Likes

Nice! thanks for the maiden tip :slight_smile:

Experienced complete loss of audio today running Earthsea. Seemed to occur as I was moving the Grid to my lap… Might’ve jostled the USB connection. Mixer screen confirmed no audio being sent out. A sleep cycle fixed it.

this is likely related to an audio bug that is fixed in the update. hold tight.

1 Like

Had a little trouble getting norns to see my grid again – it did eventually work, but flipping the inside switch wasn’t doing it. Not sure what got it going this time, which makes me think it was probably a coincidence the first time. :thinking:.

I will play a bunch this week and try and confirm for myself if there is a problem or not.
If so, I will mail support directly and take it from there. :+1:

1 Like

A post was merged into an existing topic: Norns: updates