Norns: help

havent yet tried, but in theory should be as easy.

Thank you so much. I missed the case (lower) on code. Thanks again!

cd norns
./stop.sh
./crone.sh

(From memory, typing this on my phone) but that gave me actionable errors.

Haha I see the much more comprehensive answer above now. :see_no_evil:

1 Like

Have now, no joy. No signal. It’s cool though, made work install a new WiFi network for people’s personal gear, can now norns at the office :slight_smile:

Hi! I have recently updated to 2.0, but there was an audio engine error caused by duplicate items. So i tried connecting via serial usb connection, accidently deleted everything inside “dust” folder. Then i tried cloning dust git repository but my terminal wouldnt connect to git. I tried to figure out how to move all the dust files from github into Norn’s dust folder, but it was too confusing so I decided to just flash the image to make sure I havent deleted anything else on the way that is important. I used this command line: wget https://monome.nyc3.digitaloceanspaces.com/norns181008.img.zip to install the disk image. I believe it got installed with no isues, but I am not sure if this is even the newest disk image, not really sure wether the newest one is the one on github or its elsewhere, since links dont look similar at all. Now Norns does not turn off, stuck on the “sleep.” word.

Could someone please explain how to correctly reinstall the newest disk image to norns and make sure there are no duplicate engine errors? I am fairly new to terminal and github and it seems like all the information is scattered around different topics which makes it really frustrating to deal with.

Thank you very much!

do this:

it will reset your dust folder and fix your duplicate engine issue

Is there a general size limit to sample files loaded in the scripts?

no, it depends on the script /engine.

if using softcut, overlong files should get cropped to the buffer boundary when read.

1 Like

Is anyone using a wired network connection with Norns? If so, any connection advice?

I recently added a Belkin USB to Ethernet adapter. (It was on the approved Raspberry Pi - Linux list).

The Norns sees it:

STATUS: activating
NETWORK: Wired connection 1
IP:

The IP address remains blank, and it appears to be in permanent “activating” status.

Thanks!

@fac_6 - I use wired ethernet most of the time. My first guess is that the wired network you are connecting to doesn’t have a DHCP server running on it.

I’d look at whichever router you have to confirm DHCP is enabled for both the wireless and wired connections.

1 Like

Thank you, it is connected directly to a MacBook Pro (DHCP)…

I don’t know off the top of my head but I’d be surprised if macOS runs a DCHP server unless it is setup to “share its internet connection”. If you can’t get it to work I can do some experimentation later today.

UPDATE:

@fac_6 - I just tested out a direct ethernet connection with my MacBook Pro (a late 2016 touchbar model). If I open up System Preferences and select Sharing, Enable “Internet Sharing” (on the right) then select the network interface with norns attached on the left (which in my case is a USB-C gigabit ethernet adaptor) - then everything works.

…once sharing was turned on I could use norns.local in a browser to get to maiden and connect to it with ssh, sftp, etc. in a terminal. As a bonus if your laptop is connected via WiFi to another network with internet access norns will have access to the internet as well. In my case norns was given an IP address in the 192.168.2.* range once internet sharing was turned on.

2 Likes

Thank you! I will try it out today.

Bit late to the party here. Just updating to 2.0.

As USB has never worked for me (still doesnt :frowning:) I have dropped the 190405.tgz (original file) into the /updates folder via SFTP & cyberduck. When I go to UPDATE i get ‘no updates found’

Am I missing something? cheers for any help!

your answer should be in here (seems like you might need to install via serial connection): Norns 2.0.0

1 Like

cheers…apologies for being an idiot. it’s a while since Ive updated. In terminal, how do I auto fill the serial number of the USB. at what point do I hit TAB? for me it just gives me an error sound.

first, be sure your norns power port (usb mini) is connected to your laptop.

open a terminal, type:

screen /dev/tty.usb

then press tab.

is you get a bell, please tell us what OS and version you’re using (as this means your FTDI driver isn’t working)

Picked up my FM7 project with new developments. Been working exclusively on it for a couple days. I’ve added the following devices to the USB port

  1. Arc
  2. Grid
  3. USB MIDI adapter
  4. Wifi nubbin

I’m using the ~ 2 amp power adapter and the device has been on for more than 24 hours. While not a problem, I’ve noticed the battery level very slowly dropping. It’s been plugged into AC current this whole time but now the battery is ~ 88%.

Could this be caused by all four devices needing > 2 amps of current? I have left both Arc and Grid LEDs illuminated for hours at a time while coding.

this is expected given the power system arrangement. there really is a cap to how much power can be pulled from the USB system— having four ports certainly allows for over-drawing, but i wanted to include four because many devices use almost no current.

here are my suggestions:

  • design grid/arc LED interactions that are not overly bright, as current consumption is directly proportional to overall brightness
  • limit CPU use for your engine. the CPU alone when loaded can consume a lot of current
  • if neither of these are options, i’d suggest using a small externally powered USB hub, which i know is not elegant, but sadly there are limits to this system design and this was a compromise i judged as a reasonable tradeoff
4 Likes

Perhaps an offworld or two?