Norns: help

Picked up my FM7 project with new developments. Been working exclusively on it for a couple days. I’ve added the following devices to the USB port

  1. Arc
  2. Grid
  3. USB MIDI adapter
  4. Wifi nubbin

I’m using the ~ 2 amp power adapter and the device has been on for more than 24 hours. While not a problem, I’ve noticed the battery level very slowly dropping. It’s been plugged into AC current this whole time but now the battery is ~ 88%.

Could this be caused by all four devices needing > 2 amps of current? I have left both Arc and Grid LEDs illuminated for hours at a time while coding.

this is expected given the power system arrangement. there really is a cap to how much power can be pulled from the USB system— having four ports certainly allows for over-drawing, but i wanted to include four because many devices use almost no current.

here are my suggestions:

  • design grid/arc LED interactions that are not overly bright, as current consumption is directly proportional to overall brightness
  • limit CPU use for your engine. the CPU alone when loaded can consume a lot of current
  • if neither of these are options, i’d suggest using a small externally powered USB hub, which i know is not elegant, but sadly there are limits to this system design and this was a compromise i judged as a reasonable tradeoff
4 Likes

Perhaps an offworld or two?

Cheers for the help, terminal worked but update didn’t.
got NONE (error : AUDIO ENGINE) on menu page with parameters etc

Just in case its relevant im on Mac OS Mojave 10.14.3.
I have uploaded the update to Norns via SFTP and also tried all available inputs with 2 different FAT 32 USB sticks.
Norms seems to be connected via my network at times then says password fail at others. So then I tried hotspot. this connects but doesn’t really get me further.
via cyberduck I can see the update (190405.tgz) is in both the /update and /dust/usb0 folders.

just to add. in further attempts terminal gives me ‘could not find a PTY’ after saying something is busy… so quick I cant see what it says.
The USB stick is recognised as when its not connected and I go to sync I get no USB found. when connected I can see the three options.

Also tried (in terminal)

sudo cp /media/usb0/*.tgz ~/update/

but says update does not exist.
In maiden im getting:
ls: cannot access ‘/home/we/update/norns*.tgz’
: No such file or directory

prior to sudo cp ... do

mkdir /home/we/update

what you actually need to do is this: Norns: update fail recovery

1 Like

I’ve noticed that its also higly depends on mini usb cable, used for charging. Just tested 3 different cables (lost original one, unfortunately) and only one gave 300mA, while with others it kept discharging

the included cable we shipped is high quality (molex) with thick conductors, and the power supply provides 5.25V (instead of 5V) which means high current draw will not brownout the supply (voltage drop due to resistance of the cable).

so, running norns with a thin cable off of a low-current/low-voltage supply (ie, an old old USB port that limits to 500ma) will not be optimal.

What is the best way to increase the overal longevity of the Norns battery? Can I just leave it powered all the time? Should I “cycle” it by letting it run down and then charging fully?

i don’t have any battery life suggestions but it’s a standard lipo so you can google.

also it’s the same model as this: https://www.adafruit.com/product/2011

so you can get a replacement whenever.

6 Likes

Can we put a bigger one like the 4400 mah?

if you can make it fit, yes, but that is very unlikely

I was having issues with mlr this morning; I tried resetting multiple times to no avail so I tried deleting and reinstalling the script, but now I’m just getting an error message that says error:init. Has anyone seen this before? Any ideas on how to fix it?

connect with maiden and you will see the full error message, paste it here and I can help!

1 Like

Hello,

I get allot of norns but I am wondering if it can do this.

Can it take instrument samples and allow me to plug in a midi controller and play in polyphony?

If so, how many voices can it handle?

Thanks a ton but I cant find this in my research.

1 Like

various Norns scripts might be able to do what you’re looking for. here’s one: Timber

[mod note; moved this to the main Norns help thread]

1 Like

fo some reason, my norms just reports Audio engine failure now. Why woul this change all of a sudden. Attempting to load any script just hangs. 2.0 was looking quite positive up till this point

Did you run any updates or put new scripts on?

I added scripts a while ago with librarian, stufff worked at the time. Just switched on and now my head in a bash terminal - just want to use it to play play samples

It is likely that you have a duplicate engine installed. If you search lines for “norns duplicate engine”, you’ll find a solution. (on my phone, or I would post a link. sorry :sweat_smile:)

(Outside of this, maybe it’s best to remove librarian from the Library. Or add protections for duplicate engines?)