Norns: help

Can we put a bigger one like the 4400 mah?

if you can make it fit, yes, but that is very unlikely

I was having issues with mlr this morning; I tried resetting multiple times to no avail so I tried deleting and reinstalling the script, but now I’m just getting an error message that says error:init. Has anyone seen this before? Any ideas on how to fix it?

connect with maiden and you will see the full error message, paste it here and I can help!

1 Like

Hello,

I get allot of norns but I am wondering if it can do this.

Can it take instrument samples and allow me to plug in a midi controller and play in polyphony?

If so, how many voices can it handle?

Thanks a ton but I cant find this in my research.

1 Like

various Norns scripts might be able to do what you’re looking for. here’s one: Timber

[mod note; moved this to the main Norns help thread]

1 Like

fo some reason, my norms just reports Audio engine failure now. Why woul this change all of a sudden. Attempting to load any script just hangs. 2.0 was looking quite positive up till this point

Did you run any updates or put new scripts on?

I added scripts a while ago with librarian, stufff worked at the time. Just switched on and now my head in a bash terminal - just want to use it to play play samples

It is likely that you have a duplicate engine installed. If you search lines for “norns duplicate engine”, you’ll find a solution. (on my phone, or I would post a link. sorry :sweat_smile:)

(Outside of this, maybe it’s best to remove librarian from the Library. Or add protections for duplicate engines?)

Restarting likely activated new engines from what you added in Librarian and you probably have a conflict.

Open maiden when and you launch a script and you should see some debug output which will tell you about the duplicate engine

Just hangs loading, maiden reports

script load: /home/we/dust/code/timber/keys.lua

pset >> write: /home/we/dust/data/step/step.pset

cleanup failed

script clear

pset >> write: /home/we/dust/data/system.pset

script run

loading engine: Timber

Nothing runs - just sits loading

sorry - slight wrong instructions.

try ;restart in the maiden REPL and then get that output

mmaiden report
1

matron

sc

*** WARNING *** The program ‘matron’ uses the Apple Bonjour compatibility layer of Avahi.

*** WARNING *** Please fix your application to use the native API of Avahi!

*** WARNING *** For more information see http://0pointer.de/avahi-compat?s=libdns_sd&e=matron

OSC rx port: 8888

OSC crone port: 9999

OSC ext port: 57120

starting lua vm

running lua config file: dofile(’/home/we/norns/lua/core/config.lua’)

MATRON

norns version: 0.0.0

git hash: 6073f2c

norns.lua

running startup

norns.lua:startup()

network connections:


1 BTHub4-3P9G_EXT

start_audio():

norns.startup_status.timeout

script clear

SCRIPT ERROR: AUDIO ENGINE

try ;restart one more time from the SC tab in the REPL (I forgot the correct steps from this off the top of my head)

report:

1

matron

sc

compiling class library…

Found 716 primitives.

Compiling directory ‘/usr/share/SuperCollider/SCClassLibrary’

Compiling directory ‘/usr/share/SuperCollider/Extensions’

Compiling directory ‘/home/we/.local/share/SuperCollider/Extensions’

Compiling directory ‘/home/we/norns/sc/core’

Compiling directory ‘/home/we/norns/sc/engines’

Compiling directory ‘/home/we/norns/sc/ugens’

Compiling directory ‘/home/we/dust’

ERROR: duplicate Class found: ‘Engine_FM7’

/home/we/dust/code/fm7_norns/engine/Engine_FM7.sc

/home/we/dust/code/we/lib/Engine_FM7.sc

WARNING: Could not open directory: ‘/home/we/norns/sc/abstractions’

To resolve this, either create the directory or remove it from your compilation paths.

ERROR: There is a discrepancy.

numClassDeps 1444 gNumClasses 2886

1 Like

there’s your problem. you have a duplicate Engine_FM7.sc

Remove the one at /home/we/dust/code/we/lib/Engine_FM7.sc

1 Like

Thanks Dude -all sorted - nice and responsive ui again… No idea how that happened

1 Like

Here’s what happened - you added a new script from the Librarian that included an engine that was already installed. In this case it’s because your we directory is out of date and had an old engine in it from a previous software update. You should probably update the we scripts from https://github.com/monome/we

4 Likes