Norns: help

I foresee that your future will be mine, regarding the grid & the arc. No, honestly, thanks for your perspective on all this, this makes my decision easier I think. I’m not turned off by a steep learning curve, I did jump into modular almost 3 years ago without any prior knowledge of synthesis and I managed fine, so if I can find the same kind of enthusiasm for norns, I’ll be set.
I also had the same experience with everyone on here, everyone is incredibly kind and thoughful. It’s a great place.

On a completely unrelated note, I have this extra kidney lying around. Anyone… ?

1 Like

awesome! Yeah I usually have it plugged in but for some reason forgot and then lost a bunch of stuff. That being said theres no indication thats its plugged in either. Not a complaint just an observation/feedback. With minimal interfaces its a challenge to get these types of things in.

heads up: i moved your queries here, and their replies, to the Approaching:norns topic, which contains much preliminary details and discussion, and posts like this, which is about as clear as it can get about what norns hardware does/doesn’t include:

other existing topics i considered: Monome for beginners, Monome beginner questions, Why monome? New to monome…, &c.

a request: this topic is where we watch for specific questions about norns usage; multiple pages of broader discussion hinder the topic’s function, so consider starting those discussions elsewhere.

for example i genuinely would be interested to see a broad discussion about why people do or do not use / buy / design / understand single-purpose sound computers (norns, organelle, axolotl, bela, MOD, &c) when, indeed, laptops can do all/most of the same things. so i started a new topic.

I’m actually having a similar issue with very distorted audio inputs. I’m trying to route audio from my phone (Pixel 3, USB-C) to the Norns via a 1/8" TRS to dual 1/4" TS adapter.

When plugged into the Norns L/R inputs, I get a weak, distorted, almost phaser-like sound out of the headphone jack. I do see activity on the input level, but it’s very low.

I accidentally discovered though that plugging the same jacks into the “Output” ports results in crystal clear audio. I’m still fairly new to Norns so won’t pretend to understand why this is, but I am confused about why the audio is so distorted when plugged into the Input jacks.

Any ideas what I might be doing wrong to produce this?

Hey, asking for a second time here.

How do I factory reset norms?

you could do this: Norns: update fail recovery

@tehn’s suggestion above applies if the main norns system stuff is borked (in /home/we/norns)

but there is no “factory reset” of the scripts and stuff in /home/we/dust. that’s up to the user to manage. individual scripts typically have a page here and/or a github repo where they can be re-acquired if the local copy has been messed up.

if you give us more details about what is not working, we can provide better answers about how to fix it.


alternative: here’s a copy of the default dust folder:

just delete the existing dust and put this one in its place.

1 Like

As others reported I’ve also encountered tape recordings recording on top of other recordings as they confuse the numbers…

I will check the menu logic and make sure the state file gets saved after each record. seems that maybe it’s getting missed?

Update: strangely enough, after setting it aside for a couple hours and then coming back, everything seems to be fine. Initially, I restarted the Norns and the distorted sound persisted, but now I can’t reproduce it. shrug.

Is this going to change? Trying to send cc through different channels, no luck…Thanks

What script(s) are you working with?

Earthsea for example does not have code to handle cc’s but it could be added pretty easy: Around this line add something like this (totally untested):

    -- cc
  elseif msg.type == "cc" then
    cc(, msg.val / 127,
1 Like

Thanks, Timber player/keys

add cc case as described above, to midi handler in timber/keys.lua, like here:

dunno if i’m totally following the thing about channel numbers. also haven’t really used timber/keys, but it appears to associate each midi channel with a particular sample ID, and likewise with a block of voice IDs:

so i guess in your CC handler(s) you would want to likewise target a particular sample for modulation according to the channel number. (Timber modulation commands affect sample slots, rather than individual voices, AFAICT.)

1 Like

I can’t seem to clock Norns externally through a USB MIDI ‘dongle’. Doesnt work on any if the stock scripts. MIDI out works great… I’m a little confused. Do I need to edit scripts eventhough they have a external clock indicator in the parameters menu to get MIDI sync in to Norns?

This will vary from script to script.

I did a quick test with “awake” - it takes clock just fine. You do need to change line 80 of the script to the midi dongle’s vport. I’m gonna guess it’s not on 1.

Something is definitely happening where my tape state gets reset to 0. I haven’t been able to consistently reproduce it, but recently I shut down norns with “sleep,” and when I turned it back on it said “none” and did not auto-load the last script (as if it had crashed or I did a hard shutdown) and I saw the tape state was back at 0. I see the state file also keeps track of the last loaded script, so maybe the whole file is resetting to its default state.

Hey all, having the same problem as @kcikdrumk updating to 2.1 from a previous 1.xx release.

My Norns updated successfully (kinda), but now it’s only loading with an error message that reads, “NONE (error: AUDIO ENGINE)” on the main menu. When I attempt to select any script, it freezes on the “loading…” screen and I have to back out. Wifi and network connections are unavailable. I tried several resets and lit some candles and recited some incantations that I found on another forum. No dice.

As you can probably see, I’m not so good with this troubleshooting stuff. Anyone have any ideas? Please let me know if I should be posting this in the help thread instead.

I’m still not able to connect to Maiden because Norns has connection issues. On the wifi page it says, STATUS: unavailable

Both Network and IP are empty, and the Hotspot and Connect buttons below do nothing when I choose them.

Hotspot causes the Norns to freeze and wifi mode is not showing any networks. I’ve tried updating from a flash drive, but using the update method also doesn’t seem to work. The one thing I haven’t tried is a USB A-A cable, but I’d prefer to avoid that if possible. Does anyone have any insights (other than The Candle Method mentioned in the other thread)?

I’ve tried hard reset (5-6 times) and sleep. I’ve used the hotspot with my computer to test the dongle and it seems to be working on that.


(frstly, caveat: both the update scripts and the wifi config are a bit outside my wheelhouse. so i’m sorry i don’t have any actual specific ideas, having never actually performed 1.x - 2.x update except by manual means.)

it’s worth using screen 115200 to connect via serial port, checking network with nmtui, ifconfig &c, and checking for duplicate SC engines (in dust) with following bash command:

find ~/dust/code -type f -printf '%p/ %f\n' | sort -k2 | uniq -f1 --all-repeated=separate | grep *.sc

or, simpler, just try killing and launching sclang from command prompt, which will show you if there are duplicate classes at any location. (maybe update did not clear out old norns .sc files in ~.local/share/SuperCollider/...)


don’t use the hard reset unless you are actually experiencing a crash and cannot shut down by any other method - including serial login and the shutdown linux command.

every hard reset has a chance of corrupting the filesystem and it will not fix anything. in fact probably worth using fsck to check the health of the filesystem if you’ve used the Rude Button.

(@tehn it seems like a good idea to have some prominent link to full disk image to be reflashed in case of just such a corruption [and only then - bandwidth isn’t free.])