Norns: help

Is this going to change? Trying to send cc through different channels, no luck…Thanks

What script(s) are you working with?

Earthsea for example does not have code to handle cc’s but it could be added pretty easy: Around this line add something like this (totally untested):

    -- cc
  elseif msg.type == "cc" then
    cc(msg.cc, msg.val / 127, msg.ch)
1 Like

Thanks, Timber player/keys

add cc case as described above, to midi handler in timber/keys.lua, like here:

dunno if i’m totally following the thing about channel numbers. also haven’t really used timber/keys, but it appears to associate each midi channel with a particular sample ID, and likewise with a block of voice IDs:

so i guess in your CC handler(s) you would want to likewise target a particular sample for modulation according to the channel number. (Timber modulation commands affect sample slots, rather than individual voices, AFAICT.)

1 Like

I can’t seem to clock Norns externally through a USB MIDI ‘dongle’. Doesnt work on any if the stock scripts. MIDI out works great… I’m a little confused. Do I need to edit scripts eventhough they have a external clock indicator in the parameters menu to get MIDI sync in to Norns?

This will vary from script to script.

I did a quick test with “awake” - it takes clock just fine. You do need to change line 80 of the script to the midi dongle’s vport. I’m gonna guess it’s not on 1.

Something is definitely happening where my tape state gets reset to 0. I haven’t been able to consistently reproduce it, but recently I shut down norns with “sleep,” and when I turned it back on it said “none” and did not auto-load the last script (as if it had crashed or I did a hard shutdown) and I saw the tape state was back at 0. I see the state file also keeps track of the last loaded script, so maybe the whole file is resetting to its default state.

Hey all, having the same problem as @kcikdrumk updating to 2.1 from a previous 1.xx release.

My Norns updated successfully (kinda), but now it’s only loading with an error message that reads, “NONE (error: AUDIO ENGINE)” on the main menu. When I attempt to select any script, it freezes on the “loading…” screen and I have to back out. Wifi and network connections are unavailable. I tried several resets and lit some candles and recited some incantations that I found on another forum. No dice.

As you can probably see, I’m not so good with this troubleshooting stuff. Anyone have any ideas? Please let me know if I should be posting this in the help thread instead.

I’m still not able to connect to Maiden because Norns has connection issues. On the wifi page it says, STATUS: unavailable
NETWORK:
IP:

Both Network and IP are empty, and the Hotspot and Connect buttons below do nothing when I choose them.

Hotspot causes the Norns to freeze and wifi mode is not showing any networks. I’ve tried updating from a flash drive, but using the update method also doesn’t seem to work. The one thing I haven’t tried is a USB A-A cable, but I’d prefer to avoid that if possible. Does anyone have any insights (other than The Candle Method mentioned in the other thread)?

I’ve tried hard reset (5-6 times) and sleep. I’ve used the hotspot with my computer to test the dongle and it seems to be working on that.

@kcikdrumk
@Jonathan_Riley

(frstly, caveat: both the update scripts and the wifi config are a bit outside my wheelhouse. so i’m sorry i don’t have any actual specific ideas, having never actually performed 1.x - 2.x update except by manual means.)

it’s worth using screen 115200 to connect via serial port, checking network with nmtui, ifconfig &c, and checking for duplicate SC engines (in dust) with following bash command:

find ~/dust/code -type f -printf '%p/ %f\n' | sort -k2 | uniq -f1 --all-repeated=separate | grep *.sc

or, simpler, just try killing and launching sclang from command prompt, which will show you if there are duplicate classes at any location. (maybe update did not clear out old norns .sc files in ~.local/share/SuperCollider/...)


also:

don’t use the hard reset unless you are actually experiencing a crash and cannot shut down by any other method - including serial login and the shutdown linux command.

every hard reset has a chance of corrupting the filesystem and it will not fix anything. in fact probably worth using fsck to check the health of the filesystem if you’ve used the Rude Button.

(@tehn it seems like a good idea to have some prominent link to full disk image to be reflashed in case of just such a corruption [and only then - bandwidth isn’t free.])

I can confirm this. Personally I found date stamp naming fine :neutral_face:

Thanks @zebra , I’ll try this out later today and see what I can come up with. Appreciate the support.

I was using the hard reset because the system was locking up when enabling hotspot mode. Sorry, I should have clarified. I let it sit for 30 minutes or so the first time before I resorted to that. Thanks for the correction, though! Will be more mindful in the future.

Ahh, disregard. I had my ports mixed up :sweat_smile:

Thank you!
I actually tried a reboot inbetween trying all of the different ports - none worked…
Not sure which port I should change to in the script, or what to type either.

If anyone could figure our how to get MIDI clock in to Orca (Norns version), please let me know!

Ok so here’s what you would need to do…

Step 1 - look at the norns system menu and find which device your midi dongle is using. This is at SYSTEM>DEVICES>MIDI and this lists your devices by number. That number is what you need to use in scripts for that device

Step 2 - edit the script. with Awake for example you would look for midi.connect and make that change:

local clk_midi = midi.connect(1) changes to local clk_midi = midi.connect(3)

Now… midi clock to Orca for norns might not work at all. I’m not sure if that midi-in is enabled at all. You might bring that up in the Orca thread. Or you could try changing the line with orca.midi_out_device = midi.connect(1) to whatever your device number is.

I have to do a hard reset at least once per session. I’m not a sys admin, therefore I poke it in the eye when it won’t behave. Can someone provide some details for serial login and Linux shutdown commands? Or point me to it? Appreciated!

1 Like

Oh no! Called out be the ZEEB. :scream:
Luckily I don’t need to hard reset much anymore.

if you ssh into the Norns from a terminal on your computer

$ ssh we@[device IP] 

with the default password “sleep”

you should be able to shut it down with

$ sudo shutdown now
1 Like

in the context of this discussion, networking might not be functional, ssh isn’t an option; use the serial port:

(from the docs)

Without WIFI, you can connect to norns via USB-UART by connecting the power cable to your computer. On Mac/linux do:

screen /dev/tty.usb(tab) 115200

where (tab) means: use the shell’s autocompletion to give you the right device path to norns; it will be the only one starting with /dev/tty.usb (or maybe /dev/ttyUSB) unless you have other usb-serial things attached.

on windows, use PuTty and a COM port; same baud setting

that’s definitely not good and indicates some root issue that should be addressed instead of subjecting the flash storage to constant abuse.

2 Likes

ah this is good to know!

posting this here as well as the meadowphysics thread incase people here know of a solution. Meadowphysics used to run fine, but now I get the following error:

pset >> read: /home/we/dust/data/meadowphysics/mp_midi/mp_midi.pset

### SCRIPT ERROR: init

/home/we/dust/code/meadowphysics/mp_midi.lua:52: bad argument #1 to 'pairs' (table expected, got nil)

stack traceback:

/home/we/norns/lua/core/norns.lua:185: in function </home/we/norns/lua/core/norns.lua:185>

[C]: in function 'pairs'

/home/we/dust/code/meadowphysics/mp_midi.lua:52: in field 'action'

/home/we/norns/lua/core/params/option.lua:48: in function 'core/params/option.bang'

/home/we/norns/lua/core/params/option.lua:35: in function 'core/params/option.set'

/home/we/norns/lua/core/paramset.lua:246: in function 'core/paramset.read'

/home/we/norns/lua/core/paramset.lua:264: in function 'core/paramset.default'

/home/we/dust/code/meadowphysics/mp_midi.lua:211: in global 'init'

/home/we/norns/lua/core/script.lua:71: in function 'core/script.init'

[C]: in function 'xpcall'

/home/we/norns/lua/core/norns.lua:186: in field 'try'

/home/we/norns/lua/core/engine.lua:83: in function </home/we/norns/lua/core/engine.lua:82>

>> reading PMAP /home/we/dust/data/meadowphysics/mp_midi/mp_midi.pmap

This is weird error because I can clearly see that table defined in the script, and it would be broken for everybody if it wasn’t… I would just try removing and re-adding meadowphyics if you haven’t already.