Norns: help

Hi, I installed several programs with the librarian application , most work but fo rsome reason meadowphysics_norns/mp_mII doesnt load. It gets to the initial instruction page but going further return the following in maiden

any ideas?

Maiden Dump

1

matron

sc

pset >> write: /home/we/dust/data/system.pset

script load: /home/we/dust/code/meadowphysics_norns/mp_midi.lua

cleanup

script clear

including /home/we/dust/code/awake/lib/halfsecond.lua

SCRIPT ERROR: load fail

/home/we/dust/code/meadowphysics_norns/mp_midi.lua:21: module ‘meadowphysics/lib/meadowphysics’ not found:

no field package.preload[‘meadowphysics/lib/meadowphysics’]

no file ‘/home/we/norns/lua/meadowphysics/lib/meadowphysics.lua’

no file ‘/home/we/norns/lua/core/meadowphysics/lib/meadowphysics.lua’

no file ‘/home/we/norns/lua/core/params/meadowphysics/lib/meadowphysics.lua’

no file ‘/home/we/norns/lua/lib/meadowphysics/lib/meadowphysics.lua’

no file ‘/home/we/norns/lua/softcut/meadowphysics/lib/meadowphysics.lua’

no file ‘/home/we/dust/code/meadowphysics/lib/meadowphysics.lua’

no file ‘/usr/local/share/lua/5.3/meadowphysics/lib/meadowphysics.lua’

no file ‘/usr/local/share/lua/5.3/meadowphysics/lib/meadowphysics/init.lua’

no file ‘/usr/local/lib/lua/5.3/meadowphysics/lib/meadowphysics.lua’

no file ‘/usr/local/lib/lua/5.3/meadowphysics/lib/meadowphysics/init.lua’

no file ‘/usr/share/lua/5.3/meadowphysics/lib/meadowphysics.lua’

no file ‘/usr/share/lua/5.3/meadowphysics/lib/meadowphysics/init.lua’

no file ‘./meadowphysics/lib/meadowphysics.lua’

no file ‘./meadowphysics/lib/meadowphysics/init.lua’

no file ‘/usr/local/lib/lua/5.3/meadowphysics/lib/meadowphysics.so’

no file ‘/usr/lib/arm-linux-gnueabihf/lua/5.3/meadowphysics/lib/meadowphysics.so’

no file ‘/usr/lib/lua/5.3/meadowphysics/lib/meadowphysics.so’

no file ‘/usr/local/lib/lua/5.3/loadall.so’

no file ‘./meadowphysics/lib/meadowphysics.so’

stack traceback:

/home/we/norns/lua/core/norns.lua:185: in function </home/we/norns/lua/core/norns.lua:185>

[C]: in function ‘require’

/home/we/dust/code/meadowphysics_norns/mp_midi.lua:21: in main chunk

[C]: in function ‘dofile’

/home/we/norns/lua/core/script.lua:140: in function </home/we/norns/lua/core/script.lua:140>

[C]: in function ‘xpcall’

/home/we/norns/lua/core/norns.lua:186: in field ‘try’

/home/we/norns/lua/core/script.lua:140: in function ‘core/script.load’

/home/we/norns/lua/core/menu.lua:423: in field ‘key’

/home/we/norns/lua/core/menu.lua:164: in function </home/we/norns/lua/core/menu.lua:141>

script clear

Change the directory from meadowphysics_norns to to meadowphysics

There are hardcoded references to this directory name in the script and it won’t work properly if it’s different.

Also - for anyone running into similar problems after installing something with the Librarian app. Your first troubleshooting step should probably be deleting the thing you just installed and try to re-install it manually (i.e. not using Librarian)

1 Like

Cant see how reinstalling would help in that case. I think there are should be more strict scripts structure guidelines, so things just work without renaming folders or smth

unfortunately it seems like at least one big issue is Github adding text (branch name) to the repo name when downloaded as a ZIP.

There’s some overall issues with how lua handles paths (specifically with require and include) that are the root of the problem.

EDIT - Also - my suggestion to not use Librarian was meant to suggest by doing the install manually, the person might better understand what was happening in the install process and could then better troubleshoot the situation.

2 Likes

Thanks Okyeron - works now!

What is the difference between the threads:

it’s not stated very clearly; the top posts are terse and could use some work. my understanding was:

“help” means just that - something is not working and i need help getting it going.

“scripting” - sharing knowledge and tips about the lua environment, features.

2 Likes

I will make a list of major norns help line threads in the tutorial, I’m trying to disambiguate them. So

  • help, is for non-developers
  • scripting, is for developers

Am I getting that right?

3 Likes

seems reasonable to me

2 Likes

apologies, the norns support/discussion threads are really confusing.

norns is a device designed for coding and learning coding, so “developers” is a difficult word. i more interpret that as “people working on the infrastructure” and we have Norns: Development theoretically for that, though much talk is on github instead.

so there are maybe three groups: people working on the infrastructure, people writing scripts, and people that are playing others’ scripts (that hopefully will get into making their own scripts soon) :slight_smile:

  • Norns: scripting — this is for getting help with the scripting system in general… something you might be working on, issues with syntax or libraries
  • https://llllllll.co/c/library — issues with individual published scripts should be posted in that script’s thread
  • Norns: help — this is the catch-all for things that don’t fall into the above. ie problems with the menu system, maiden, file management, or hardware. (there are separate threads for problems with updating).
6 Likes

did you manage to get your norns working?
i’m in the same situation (except for me nothing shows up when i chose select in the menu) and updating to 190422 via serial didn’t solve anything, i still have the audio engine error and wifi unavailable.

Yes, I did. I followed the instructions that @tehn laid out below.

Then went and deleted the duplicate engine script (it was passerby, in my case).

I never resolved the WiFi issue, so I purchased a new nub and it worked fine.

thanks a lot!
i missed this one

1 Like

Reach out if it doesn’t work, I’ll gladly retrace my steps for you.

I am receiving an “error:init” whenever I try and load a script. Is that also a duplicate engine? I am checking in cyberduck but can’t see any duplicates

if you can, use maiden in a browser and go to the “sc” tab in the bottom portion of the window (the REPL section)

Then type ;restart (and hit enter) at the very bottom and look at that output. It should tell you if there’s a duplicate engine.

06%20PM

1 Like

Hrm, unless it specifically says something about “audio engine” I would assume it is a lua bug or missing .pset or something of that nature.

But yeah checking both REPLs and posting output is a helpful first step

I can see its unable to find “abstractions” and I don’t have that folder when I look through cyberduck, should I add one or remove it from compiling?

not sure why that’s there, but i think that’s harmless.

For completeness - i’d suggest going to the matron tab in REPL and doing ;restart as well.

FWIW - have you tried turning it off and on again? :grin:

Yes I have unfortunately this starting happening a few weeks ago but I just haven’t had the time to getting around to figuring it out. After the maiden restart its giving me an audio engine error