Norns: help

it’s not stated very clearly; the top posts are terse and could use some work. my understanding was:

“help” means just that - something is not working and i need help getting it going.

“scripting” - sharing knowledge and tips about the lua environment, features.


I will make a list of major norns help line threads in the tutorial, I’m trying to disambiguate them. So

  • help, is for non-developers
  • scripting, is for developers

Am I getting that right?


seems reasonable to me


apologies, the norns support/discussion threads are really confusing.

norns is a device designed for coding and learning coding, so “developers” is a difficult word. i more interpret that as “people working on the infrastructure” and we have Norns: Development theoretically for that, though much talk is on github instead.

so there are maybe three groups: people working on the infrastructure, people writing scripts, and people that are playing others’ scripts (that hopefully will get into making their own scripts soon) :slight_smile:

  • Norns: scripting — this is for getting help with the scripting system in general… something you might be working on, issues with syntax or libraries
  • — issues with individual published scripts should be posted in that script’s thread
  • Norns: help — this is the catch-all for things that don’t fall into the above. ie problems with the menu system, maiden, file management, or hardware. (there are separate threads for problems with updating).

did you manage to get your norns working?
i’m in the same situation (except for me nothing shows up when i chose select in the menu) and updating to 190422 via serial didn’t solve anything, i still have the audio engine error and wifi unavailable.

Yes, I did. I followed the instructions that @tehn laid out below.

Then went and deleted the duplicate engine script (it was passerby, in my case).

I never resolved the WiFi issue, so I purchased a new nub and it worked fine.

thanks a lot!
i missed this one

1 Like

Reach out if it doesn’t work, I’ll gladly retrace my steps for you.

I am receiving an “error:init” whenever I try and load a script. Is that also a duplicate engine? I am checking in cyberduck but can’t see any duplicates

if you can, use maiden in a browser and go to the “sc” tab in the bottom portion of the window (the REPL section)

Then type ;restart (and hit enter) at the very bottom and look at that output. It should tell you if there’s a duplicate engine.


1 Like

Hrm, unless it specifically says something about “audio engine” I would assume it is a lua bug or missing .pset or something of that nature.

But yeah checking both REPLs and posting output is a helpful first step

I can see its unable to find “abstractions” and I don’t have that folder when I look through cyberduck, should I add one or remove it from compiling?

not sure why that’s there, but i think that’s harmless.

For completeness - i’d suggest going to the matron tab in REPL and doing ;restart as well.

FWIW - have you tried turning it off and on again? :grin:

Yes I have unfortunately this starting happening a few weeks ago but I just haven’t had the time to getting around to figuring it out. After the maiden restart its giving me an audio engine error

switch your REPL to the sc tab (instead of matron) and ;restart

got @Minimum fixed up. Note the cause of the problem was not having awake installed (specifically PolyPerc) - see

1 Like

Are older grids not supported based upon the variable brightness? I’m a little bummed that much of the Norns would not work with my gs128.

Any thoughts if the potential upgrade for variable brightness would allow older grids to work with these scripts?

the norns platform can be used with all grids going back to 40h.

some scripts assume variable brightness for grid UI design.

it is easy to modify them. (change value of grid:led(...) calls…)


Are there keyboard limitations for norns?
I tried using my ajazz ak33 keyboard and it regularly displays in the HID menu (actually two keyboards “keyboard” and “keyboard 2” pop up when i plug it in) but then inputs are not recognized by Orca

This 2 Hid devices thing seems common for usb keyboards.

Try connecting to the second one using the vport number (the number listed in the devices menu)

myhid = hid.connect(2)

Or… I can’t remember if the keyboard select thing got added to orca - check the params menu.

1 Like