Norns: help

If I recall correctly, the Sync feature was in norns 1.x, but was removed in 2.x as it was problematic? See this post for the mention of the change

1 Like

Using Maiden for library mgt seems to be working great, but this morning I was looking at the data folder and there are now multiple copies of everything that I have updated from Maiden. I assume Maiden leaves the “-master” on the folder name? My habit has always been to remove it? How should I clean this up? Thanks

Is there a way to have Norns control soft synths on a Mac or iOS device. I tried the Mini and USB Type A jacks from Norns to the Mac/iPad but neither of the will recognize those devices.

Search on “host to host” and you’ll find a number of suggestions/solutions.

2 Likes

in general, no, it clones a project’s repository if possible. i guess it’s possible for it to grab a download link with foo-master.zip if that is the only thing available for a project - haven’t seen this happen but also haven’t tried everything in the catalogs.

you’re just seeing stuff in the data folder? like there is (1) dust/data/foo and (2) dust/data/foo-master, but only (3)dust/code/foo and no (4) dust/code/foo/master right? if so, i’d guess (2) is from an older installation, (1) and (3) are from the maiden installation. (the stuff in data is generated by the norns system for script state persistence, i don’t think the project manager touches them.)

Just been playing around with Mlr and ran into this issue -

anyone seen it before, or knows how to fix it?

Is it like that in all the menus? If so I would check the soldering on the 3 legs of your potentiometer to see if any are bridged.

Did you get “detented” encoders by any chance? Or one with a resolution other than 24 PPR?

This looks like typical behavior with detented encoders jumping 4 values for each detent.

Pedantic, but still important - it’s Encoders not Potentiometers on this device

@Jonny nope it works fine in every other page

@okyeron hmm… I don’t think so - I’m pretty sure I ordered the exact ones from the BOM

Edit: - they are these; https://www.mouser.co.uk/ProductDetail/Bourns/PEC11R-4015F-N0024?qs=Zq5ylnUbLm5obMMbrbYrpA==

I just realised these are 12 PPR instead of 24. I guess mouser must have replaced them without me noticing, as they have no 24 PPR encoders in stock… is there any software fix for this?

No, very important! Sorry to cloud the conversation!

2 Likes

Had a look into this - I don’t know if this is the right place to post about it because this is related to the norns software.

Inside the lua/core/encoders.lua file, we call util.time(), which is supposed to return a timestamp like

1576259801.7825

however, on my norns image, when I call this function;

> s = 1576259801
> us = 782489
> s + us/1000000
1.57626e+09

I get this result, which, when the encoders.process function diffs to find the time between the last encoder change, it gets a result of zero, and thus applies the maximum “acceleration” for the encoder of 6*.

I rewrote the time diff function to diff between seconds and microseconds manually, and this works fine, I can use the encoders normally in scripts again!

My lua version;

# lua -v
Lua 5.3.5  Copyright (C) 1994-2018 Lua.org, PUC-Rio

I don’t know if this is an issue I should make a pull request for, or if I’m running the wrong version of something, or what… but at least I got to the bottom of it! :slight_smile:

i’ll check this out and see if i can reproduce. are you using the norns shield disk image?

1 Like

I built the latest image from here - https://github.com/simonvanderveldt/norns-image

I guess this might be a bit too bleeding edge and the cause of the issue?

Well, as far as I know everything works, although it still need more testing.
If you run into any issues please let us know, some more testing/feedback is always nice :slight_smile:

Apart from that I’ve noticed some skipping behavior on some scripts as well (16 sliders is the one I noticed it on) from my testing this started with norns 2.2.4. I haven’t created an issue for this yet, will do so this weekend.

[edit] Btw I’m assuming this is on the norns shield. Is that correct? If so we should probably move these posts there, could be confusing otherwise.

Hey everyone.

My “Disk free” is saying 0MB. last time I was using Norns it was frozen in a couple scripts like MLR and Boing, so I forced shut down. Seems like maybe something went wrong. Any tips on how can I sort this out?

suggested disk image is in the DIY shield thread top post

1 Like

Quick question: To have Norns speak to Axoloti usb to usb ie Awake to sequence an axoloti synth, I would need a host-host adapter like 2host? Or am I missing something?

Axoloti specs say:

Full size USB host port

so I’m gonna say yes - you need 2host or a savila soft usb dingus.

EDIT - but it also says

Micro-USB device port

but I dont understand what that means here. Maybe @TheTechnobear can chime in with details?

micro-usb serves connection for Axoloti software, a power source, and act as a class compliant midi device.

So try that?

Axoloti can act as a usb host and usb device.
So you can plug it directly into Norns without any adapters etc.

3 Likes

I use a Roland UM-ONE from Norns USB to the midi in on a Scarlett 2i4 to control soft synths on my Mac.