Norns: help

when it says “complete” just touch any KEY (1,2,3) on the top of the device to shut down.

as @Justmat said, the bottom reset button is the nothing works at all panic button. don’t use this unless something is truly broken and not working. it shuts the computer down hard which likely puts it in a bad state.

1 Like

Hey ya.

i have the ### SCRIPT ERROR: SUPERCOLLIDER FAIL problem.

i went digging around but couldn’t find a definate “how to” fix the problem.
:frowning:

  • tried ;restart from maiden
  • tried sleep
  • tried reset

here’s what maiden says after a ;restart

Summary

*** WARNING *** The program ‘matron’ uses the Apple Bonjour compatibility layer of Avahi.
*** WARNING *** Please fix your application to use the native API of Avahi!
*** WARNING *** For more information see http://0pointer.de/avahi-compat?s=libdns_sd&e=matron
OSC rx port: 8888
OSC crone port: 9999
OSC ext port: 57120
starting lua vm
running lua config file: dofile(’/home/we/norns/lua/core/config.lua’)
MATRON
norns version: 0.0.0
git hash: 9ceae9a5
running startup
start_audio():

ttyACM found, but not a crow
dev_list_add: error allocating device data
arc added: 1 monome arc m1100231 m1100231
grid added: 2 monome 128 m1000648 m1000648

script clear

norns.startup_status.timeout

SCRIPT ERROR: SUPERCOLLIDER FAIL

thanks for any help!

In maiden there are two tabs in the REPL area. The first one is for matron which is the control program which is running scripts and controlling the display. The second tab is sc (for supercollider). Can you click the sc tab, type ;restart into that REPL and post the results here.

The selected tab controls which portion of the norns software actually gets restarted. It seems like restarting supercollider might yield more information as to the nature of the problem.

1 Like

looks like it’s something to do with OTIS and a thing called Engine_Decimator.
here is the info from the SC tab:

Summary

compiling class library…

Found 716 primitives.

Compiling directory ‘/usr/share/SuperCollider/SCClassLibrary’

Compiling directory ‘/usr/share/SuperCollider/Extensions’

Compiling directory ‘/home/we/.local/share/SuperCollider/Extensions’

Compiling directory ‘/home/we/norns/sc/core’

Compiling directory ‘/home/we/norns/sc/engines’

Compiling directory ‘/home/we/norns/sc/ugens’

Compiling directory ‘/home/we/dust’

ERROR: duplicate Class found: ‘Engine_Decimator’

/home/we/dust/code/otis-master 11.26.19/lib/Engine_Decimator.sc

/home/we/dust/code/otis/lib/Engine_Decimator.sc

ERROR: There is a discrepancy.

numClassDeps 1441 gNumClasses 2880

AH!
OK!

using maiden i deleted the two installs of OTIS.
(one had a date in the file name)

then i reinstalled OTIS from maiden.

i then did a ;restart of the matron and it error-ed again.
did a ;restart on the SC tab and it gave me a clean boot up!
went back to the matron tab and did a ;restart and it booted up all new with “none” at the top.

THANK YOU SO MUCH FOR THE HELP!!!

also…
i didn’t realize that that little SC in maiden was another tab of info!
:stuck_out_tongue:
learning more everyday!
yikes!

2 Likes

I’m running out of USB ports on my Norns and I’m not quite sure how it handles hubs.

  • is there a recommended USB hub or one people have had good experience with?
  • do grid and arc still work when connected via a hub?
  • do midi devices work when connected via a hub?

@ngwese just showed me this one: https://www.amazon.com/UGREEN-Compatible-MacBook-MateBook-Notebook/dp/B07MGL1VW1/ref=pd_sbs_147_img_2/138-6205557-8029159?_encoding=UTF8&pd_rd_i=B07MGL1VW1&pd_rd_r=68d766d6-25b2-4b15-a8e6-71724f62c581&pd_rd_w=9pPw4&pd_rd_wg=M2VaW&pf_rd_p=5cfcfe89-300f-47d2-b1ad-a4e27203a02a&pf_rd_r=WGF6DPCMKMB1YZ3XAQ90&psc=1&refRID=WGF6DPCMKMB1YZ3XAQ90

which has a port to be externally powered— pretty essential if you’re using a ton of USB power!

everything should work as expected.

1 Like

I wanted to play around with ORCA but noticed that my mechanical keyboard wasn’t doing anything when pressed. It looks like the keyboard is being recognized by Norns but the keys aren’t registering. So in the effort of troubleshooting I installed HID_Demo. I have no key press response from Keyboard_Test or HID_Events. Any ideas on what my issue may be? I’m new to Norns. Thanks in advance!

When HID Events is loaded Matron sees the following. Pressing a key does not print those key events Matron as I think it should.

vports
1: Keyboard - WhiteFox:truefox PixelMap USB
2: Keyboard - WhiteFox:truefox PixelMap USB 2
3: Keyboard - WhiteFox:truefox PixelMap USB 3
4: Keyboard - WhiteFox:truefox PixelMap USB 4
reading PMAP /home/we/dust/data/hid_demo/hid-events/hid-events.pmap

I think this has something to do with USB2.0 vs USB3.0 current spec. I have a Minivan keyboard that also shows up in the list but does not work.

1 Like

try assigning vport 1 to your various options (ie USB 2, USB 3, etc)

it may be working on one of them?

2 Likes

vport 1 set to USB 2 worked! Thank You!

3 Likes

Yeah - from my own limited testing with keyboards, they can show up as multiple instances and you have to try them to see which is the one you need. Glad you got it sorted.

1 Like

I feel like I might be missing something obvious, but I haven’t found a sync option on my Norns. It’s not listed under the system menu as some previous posts have suggested and I haven’t been able to find explicit instructions on how to sync in the docs. I’ve just updated to 2.1.1 via maiden and have a FAT-32 flash drive, freshly formatted, plugged in. Can anyone send me a hint?

If I recall correctly, the Sync feature was in norns 1.x, but was removed in 2.x as it was problematic? See this post for the mention of the change

1 Like

Using Maiden for library mgt seems to be working great, but this morning I was looking at the data folder and there are now multiple copies of everything that I have updated from Maiden. I assume Maiden leaves the “-master” on the folder name? My habit has always been to remove it? How should I clean this up? Thanks

Is there a way to have Norns control soft synths on a Mac or iOS device. I tried the Mini and USB Type A jacks from Norns to the Mac/iPad but neither of the will recognize those devices.

Search on “host to host” and you’ll find a number of suggestions/solutions.

2 Likes

in general, no, it clones a project’s repository if possible. i guess it’s possible for it to grab a download link with foo-master.zip if that is the only thing available for a project - haven’t seen this happen but also haven’t tried everything in the catalogs.

you’re just seeing stuff in the data folder? like there is (1) dust/data/foo and (2) dust/data/foo-master, but only (3)dust/code/foo and no (4) dust/code/foo/master right? if so, i’d guess (2) is from an older installation, (1) and (3) are from the maiden installation. (the stuff in data is generated by the norns system for script state persistence, i don’t think the project manager touches them.)

Just been playing around with Mlr and ran into this issue -

anyone seen it before, or knows how to fix it?

Is it like that in all the menus? If so I would check the soldering on the 3 legs of your potentiometer to see if any are bridged.

Did you get “detented” encoders by any chance? Or one with a resolution other than 24 PPR?

This looks like typical behavior with detented encoders jumping 4 values for each detent.

Pedantic, but still important - it’s Encoders not Potentiometers on this device

1 Like