Norns: help

norns

#531

I think we’re good to go. I just removed all cables from all ports then reattached power, grid and cold started the unit. Sampled 4 long tracks, lots of interaction with grids, and recorded to tape, to boot. Still going now.

Previously, I had been restarting from a crash but not sure why that would matter either way.

No MIDI in, no.


#532

i apologize but could you clarify what changed? i’m not sure what you mean by cold start vs. restart from crash?

there’s some deeper wifi-connected debugging i could have you do try next (which would actually provide some feedback as to what broke. i’ll include it below.

deep debug instructions
  • start norns normally
  • connect via wifi
  • ssh in then cd norns then ./stop.sh then ./crone.sh
  • make another terminal, ssh in again, cd norns then ./matron.sh
  • now you can see the two processes running and get visual feedback as that what’s going on. run mlr normally, and if something goes haywire you’ll be able to see some info that will help us fix it.
  • thank you so much for your patience!! and i assure you we’ll straighten this out (mlr is my central performance tool, so i’m dedicated)

#533

Meaning I put the unit to sleep, then restarted; instead of pressing the reset button on the back, then restarting.

As far as I know, nothing changed between troubleshooting sessions. If connected MIDI input is a possible troubleshooting vector, I’m happy to try that as well.

I’ll do the deeper debug this evening.


#534

i’m not sure why a clean shutdown (sleep) would make a big difference, but thanks for the tip.

midi is possibly a bug right now (usb subsystem issues, which we just found out may be fixed upstream in a new linux kernel, so we’re working on it.)


#535

I love the fact that maiden has an emacs mode, but has anyone gotten around to use commands that the browser interprets (e.g. ctrl+n opens new window of firefox instead of going to the next line)

So this is probably more a browser-question than directly a maiden bug.
Any hints?

Other than that we also should change the shortcuts for “save” (ctrl +s) and “run” (ctrl + p) in maiden since they are overwritten by the emacs shortcuts.
Any pointers which files would need editing? (A quick search in the maiden repository for “emacs” did yield no results)

Cheers


#536

No clue but happy all the same.

Running the wifi test now.


#537

ah, yeah. we’ll have to go the extra mile and capture those commands specially (if it’s even possible; browsers are quirky).

oh, yeah. this is a good point. (i don’t use emacs so i never noticed the conflict.) those bindings getting established here:

not sure how best to handle mode awareness though… or maybe there’s a natural binding that works for both?

feel free to open an issue on the maiden repo and we can carry on over there.

:beers:


#538

FWIW, I was able to get this working with the Digitakt and Earthsea. Pretty sweet. Can drive Passerby, Earthsea, et al. and modulate CC values per step. All-in-all I’m pretty impressed with the Norns so far.


#539

I can’t get my Korg PadKontrol to work with norns. I think it’s probably due to it having two “ports” to output from. The device gets recognized by norns in the MIDI devices menu, but no script sees MIDI messages from it. I tried configuring the pad itself but neither output port setting works. Any tips?


#540

Slightly off-topic, but has anyone tried hooking up an MPD218 or other Akai pad controller to norns?


#541

Are you trying to power the PadKontrol from norns over usb, or is it powered via the AC adapter?

You might need to designate the port number on midi.connect()

  • check norns to see what port the padKontrol is connected to (in SYSTEM>DEVICES>MIDI )
  • use that port number with midi.connect()

example: Korg NanoKontrol on port #2

local mo = midi.connect(2)
-- process incoming midi
mo.event = function(data) 
  d = midi.to_msg(data)
  tab.print(d)
end

#542

Should i be able to enter a password on the wifi screen? Im all up to date on my Norns. Im able to enter my wifi network, but there is no place to enter my wifi password.


#543

probably more of a quirk/bug report -

sample loading - in glut and MLR at least don’t follow symbolic links! (was trying to keep my rubbish out of my local copy of dust so I can update easily)

Not a burning issue but might be nice (not least because you could also use a symbolic link to point to a USB stick)


#544

iirc the padKontrol isn’t class compliant, at least it wasn’t when I had one many years ago… does it have support for linux?


#546

Just adding this for anyone with a Launch Control (not the XL version)… it works fine with MLR and hello_gong if used with a powered USB hub; not sure how much power it would need but I thought it is worth mentioning.


#547

I am having troubles syncing my norns through my ROLAND UM-One MKII MIDI In. I tried the following without success :

beatclock = require ‘beatclock’
clk = beatclock.new()
clk_midi = midi.connect(1)
clk_midi.event = clk.process_midi

function init()

clk.on_step = function() print(“step”) end
clk.on_select_internal = function() clk:start() end
clk.on_select_external = function() print(“external”) end
clk:add_clock_params()
clk:start()
end

My ROLAND UM-One MKII is receiving MIDI clock from analog RYTM and is associated to the port1 in “devices”.

When using internal MIDI, “step” is printed in Matron, switching to external makes appear external but that is all, the ‘print step’ function is not activated anymore.

Could someone help with that or test it with the same usb/MIDI adaptator?


#548

I was unable to get beatclock’s midi processing working with the syntax you have above but swapping in this snippet is working for me in another script (I haven’t tested the rest of your code, just noticed that one thing):

clk_midi.event = function(data)
    clk:process_midi(data)
end

I think this is broken in awake - I can make a pull request if this syntax is how beatclock is meant to be used.


#549

good find @markeats i’ll check this as well


#550

What’s the best way to go about sending messages to norns from another computer? Say for example I want to create an art installation and use norms to make sound that reacts to the art piece. Would you send OSC messages down a USB cable using serial? Or midi of some sort?


#551

OSC is covered in the next study! i’d say this is the best method at this point.

study ETA end of the week

in the meantime you can do a weird midi hack by using two usb-midi cables and a female connector, but that’s not ideal.