Norns: help

norns

#552

i just test awake and indeed it seems to work perfectly for sync out, with both keystep and emu xmidi 1x1 (usb dongle).

EDIT. @markeats bug is correct. i’ll fix the study and awake etc. need a colon, not period:

clk_midi.event = function(data)
    clk:process_midi(data)
end

#553

Tried that change with the beatclock script of the 4th study and my MIDI IN is now working as expected :+1:
Could you just explain the “data” thing please ?


#554

I’ll try, pretty sure someone else could do this better…

data is basically the raw data of each packet in the midi stream (or put differently, it contains all possible types of midi. notes, cc etc… )

the function in question gets called on every midi event with the raw data as input . you then pass that to the clk class to process it as implemented in process_midi. basically do something when the statusbyte corresponds to one of the clock signals (clock, start, stop etc.


#555

I’m really struggling with MIDI. I’ve been able to get Norns to recognize MIDI IN data from a MIDI Fighter Twister, but haven’t been able to get it to work with an EMU Xmidi 1x1 (even though Norns recognizes it in MIDI/DEVICES). Tehn says he tested it with awake and it worked, so I’m not sure if I’m missing something here. Are there any code examples of MIDI out that I can test with?

I really want to send MIDI back and forth with Ableton. What are people doing to accomplish this? I thought I’d be able to do it easily with the EMU but no luck so far.

Thanks!


#556

I had the REBOUND script running for about four days with the same pattern. Playback was fine and I recorded a short piece. I went into the SLEEP menu and the text “sleep.” is dim as if I confirmed the sleep command but the device continues to operate the screen and all DSP. The SELECT menu is broken, it does not show any scripts other than REBOUND.

I can’t imagine how to reproduce this bug but it looks like a “hard reset” one.

Tried plugging in the wifi dongle. The SYSTEM menu has crashed and the encoders have stopped controlling the visible menu. They continue to control the parameters from the REBOUND script.


#557

I use the EMU Xmidi 1x1 with my Norns fairly regularly to send midi, so far I haven’t ran into any problems.

i just updated foulplay to send midi out, It’s kind of a lot to dig through, but you are welcome to take a look around. foulplay


#558

Hmmm. Maybe there’s just something wrong with my emu. I’ll take a look at your code. Thanks for directing me to it and for the response.


#559

very minor grumble - when my Norns power USB is plugged into laptop usb (so I can develop via it) there is a very definite audio tone.

Here is a spectrum of it

Not a big deal - if I am recording it with it I can just move it to a proper power supply but thought I’d note the issue


#560

unfortunately this is a known issue and common to many devices of similar configuration. luckily the fix is easy: run off battery it use the provided power supply. or monitor off headphones and leave the outputs disconnected

also, devices via WiFi is very effective (no ground loops!) but I have certainly appreciated seeing your UART term tips!


#561

ah no worries - it’s only during dev so I can live with it easily - just thought I’d note it in passing.


#562

I lost the wifi nub that came with norns, does anyone know the model or will any similar one work? like this: https://www.amazon.com/TP-Link-TL-WN725N-wireless-network-Adapter/dp/B008IFXQFU/ref=sr_1_8?s=pc&ie=UTF8&qid=1538369126&sr=1-8&keywords=wifi+dongle


#563

i believe almost any wifi nub will work. pretty sure this is the one we ship now (we get it OEM):

link

https://www.amazon.com/150Mbps-Adapter-LOTEKOO-Wireless-Raspberry/dp/B06Y2HKT75/ref=pd_sbs_147_28?_encoding=UTF8&pd_rd_i=B06Y2HKT75&pd_rd_r=36242006-c576-11e8-a606-db11b044450e&pd_rd_w=5lyNC&pd_rd_wg=ZzAMD&pf_rd_i=desktop-dp-sims&pf_rd_m=ATVPDKIKX0DER&pf_rd_p=53dead45-2b3d-4b73-bafb-fe26a7f14aac&pf_rd_r=24C4PSVWK71S15YGJS6D&pf_rd_s=desktop-dp-sims&pf_rd_t=40701&psc=1&refRID=24C4PSVWK71S15YGJS6D


#564

Same thing happened when I connected a USB to 5pin serial MIDI adapter. Thanks for the data.


#565

More of a bandaid than a fix, but for the same issue with my op-1 I use a cheapo ground-loop-isolator I got on ebay for like $5 and it works a treat.

It looks like this (that’s a 3.5mm jack)


#566

Hey guys. Im having a bit of trouble connecting norns to my ableton push 1. Im able to see the device in the devices screen, however i never seem to get midi from the device. I can get notes from a midi keyboard no problem. Any ideas?


#567

Update: I was worried that maybe there were drivers needed to use the push as a plane-ol midi controller. So I verified that the Push 1 does work as a normal midi controller on a raspberry pi (as opposed to my mac which I installed the push software on ages ago). I was able to send and receive notes to the Push through PD on the Pi, no problem.

Any ideas would be appreciated!


#568

i’m wondering if the push 1 has some sort of usb2-only connection. we’re about to release a norns update that re-enables usb2. can you hold tight for a day or two and see if the update fixes your issue?


#569

Sounds like a plan, thanks!


#570

After updating norns to latest release (180904), as well as dust to the latest master state (as of a few days ago, unsure what particular commit). norns seems to have issues running any apps. tehn/earthsea will not load (from maiden repl):

# script init
### SCRIPT ERROR: init
/home/we/norns/lua/params/control.lua:47: attempt to call a nil value (method 'unmap')
stack traceback:
	/home/we/norns/lua/norns.lua:159: in method 'unmap'
	/home/we/norns/lua/params/control.lua:47: in function 'params/control.set'
	/home/we/norns/lua/paramset.lua:183: in function 'paramset.read'
	/home/we/dust/scripts/tehn/earthsea.lua:101: in function 'init'
	[C]: in function 'xpcall'
	/home/we/norns/lua/norns.lua:160: in field 'try'
	/home/we/norns/lua/script.lua:52: in function 'script.init'
	/home/we/norns/lua/script.lua:91: in function </home/we/norns/lua/script.lua:90>
	[C]: in function 'xpcall'
	/home/we/norns/lua/norns.lua:160: in field 'try'
	/home/we/norns/lua/engine.lua:87: in function </home/we/norns/lua/engine.lua:85>
reconnecting grid...
reconnecting midi...
READING PMAP

For awake, I get:

### SCRIPT ERROR: init
/home/we/norns/lua/params/option.lua:16: bad argument #1 to 'pairs' (table expected, got string)
stack traceback:
	/home/we/norns/lua/norns.lua:159: in function </home/we/norns/lua/norns.lua:159>
	[C]: in function 'pairs'
	/home/we/norns/lua/params/option.lua:16: in function 'params/option.new'
	/home/we/norns/lua/paramset.lua:57: in function 'paramset.add_option'
	/home/we/dust/lib/lua/beatclock.lua:121: in function 'beatclock.add_clock_params'
	/home/we/dust/scripts/tehn/awake.lua:75: in function 'init'
	[C]: in function 'xpcall'
	/home/we/norns/lua/norns.lua:160: in field 'try'
	/home/we/norns/lua/script.lua:52: in function 'script.init'
	/home/we/norns/lua/script.lua:91: in function </home/we/norns/lua/script.lua:90>
	[C]: in function 'xpcall'
	/home/we/norns/lua/norns.lua:160: in field 'try'
	/home/we/norns/lua/engine.lua:87: in function </home/we/norns/lua/engine.lua:85>
reconnecting grid...
reconnecting midi...
lua: 
/home/we/norns/lua/paramset.lua:109: attempt to index a nil value (field '?')
stack traceback:
	/home/we/norns/lua/paramset.lua:109: in function 'paramset.get'
	/home/we/dust/scripts/tehn/awake.lua:275: in function 'redraw'
	/home/we/norns/lua/menu.lua:299: in field 'set_mode'
	/home/we/norns/lua/menu.lua:245: in field 'init_done'
	/home/we/norns/lua/engine.lua:88: in function </home/we/norns/lua/engine.lua:85>

#571

be sure to pull master on the norns repo also!

update coming tomorrow