Norns: help

norns

#653

@jasonloeffler @jflee @Wirelesswine @jonsimon @ioflow &c

we’re seeing a greater number of random hard crashes and kernel panics since moving from scsynth to supernova. (or that is the best guess for general cause.) trying to find more specific mechanism. it’s not a particular engine, script or peripheral. not everyone is equally affected; some users report crashing every 30s, others have never had a crash. more data points are appreciated.

personally i am thinking we should probably roll this change back for the moment. this won’t take away all the other additions and new scripts, though it will lower voice count for polyphonic synths. have been spending night time past week on attempted diagnosis; this week will work on a rollback (should go quickly; with some work can move aux effect processing to a separate scsynth process.)


Norns: update 181023
#654

norns is a USB midi host, so you’ll need to use a method to connect two midi hosts. there is discussion of this in other threads here but there doesn’t seem to be a perfect device/solution for this. you can always use two USB MIDI dongles and connect them with a female-female adapter.


#655

i’m preparing a rollback now. i apologize for the trouble, everyone.


Norns: update 181023
#656

thanks @tehn and @zebra and anyone else.
sorry this release has been so difficult, must be supremely frustrating. i’ll be honest and say that i actually have had a TON of fun with it. the playfair euclidean with presets has been crazy, and even 6 channels of mlr. i’ve been using the crashes as the end of the song, haha. i knew it would be fixed soon.
:two_hearts:


#657

Supernova exists for multi threaded + multi core CPUs, right?


#658

yes, using supernova lets us easily run e.g. multiple synths in parallel using ParGroup. under the hood it has a pool of DSP worker threads, and the scheduler will automagically spread these across different cores.

we’re still working out the best answer to the issues. it may or may not involve changing the SC backend.


#659

note to everyone:

if you’re not actively using the wifi usb nub, don’t plug it in. it uses a bunch of power, reducing the battery life and system power overhead for everything else.

in general, if you’re not actively using a peripheral, i’d highly suggest not plugging it in.

ok!


#660

Follow up question re: battery. Do you have a part number handy? How many cycles does the mfg spec claim? Is the battery user serviceable?


#661

mine has this (datapower dtp803860)

[ https://datapower.en.alibaba.com/product/60800184030-807518142/Wholesale_lithium_polymer_battery_3_7v_2000mah_lipo_battery.html ]

How many cycles does the mfg spec claim?

it doesn’t, AFAICT. ballpark is 1000 - 1500 cycles for this kind of battery (as i understand it.)

oop, i was wrong, it says 500. that’s from the alibaba page, i didn’t dig more. seems conservative.

Is the battery user serviceable?

yes, it is easily accessed / removed / replaced.

next logical question is about the charge controller (woop, i stand corrected), which is this fancy TI “fuel gauge” jobbie.


#662

the fuel gauge actually just measures current and capacity.

the actual charge controller is a BQ24075


the battery has a standard JST header. any battery can be plugged in here given it fits in the space. i believe the 2000mah battery from adafruit will fit and is easily attainable. we ordered in bulk from the manufacturer which was a total pain. the actual battery in production units is 2250mah and slightly different dimension.


#663

Good to know. Just looking 3-5 years down the road…


#664

i’ll do my best to keep a stockpile as well. though we’ve been suffering from random end-of-life parts recently.


#665

Hi all, I’ve been reading everything I can about norns after @Benjamin_Mauch showed me his in person. Can MLR and the other cool sequencers like Loom sync to an external MIDI clock?


Approaching: norns
#666

I believe currently some can and some cannot and those that cannot are likely planning to have that feature implemented soon


#667

Is there a way to revisit the instructions screen after you’ve initiated the script? I’m afraid I’m One Of Those People who does not absorb complex instructions quickly. :frowning:


#668

You could pull up the scripts from Github on your phone so you can the read the instructions as you’re playing.


#669

yes you can head back over to the SELECT screen and choose a script to read the instructions (and then KEY1 to toggle back) as long as you don’t KEY3 again from the instructions, the script won’t be reloaded


#671

Started the studies tonight to try and understand Norns better. Already stuck on the first one. keep getting this in the console on maiden

   stack traceback:
	/home/we/norns/lua/paramset.lua:177: in function 'paramset.t'
	/home/we/norns/lua/menu.lua:690: in field 'key'
	/home/we/norns/lua/menu.lua:144: in function </home/we/norns/lua/menu.lua:121>
lua: /home/we/norns/lua/paramset.lua:177: attempt to index a nil value (field '?')

followed the walkthrough on monome.org verbatim and even resorted to fully copy pasting the code from the site and still get this message. I can get the initial sine wave, and change the hz, but printing the keys and encoders has me stumped. Am I missing something?


#672

try running your script on a clean boot. something seems like it’s initializing incorrectly, though we revised a lot of the system to ensure this doesn’t happen.


#673

So I put it to sleep and when I rebooted it launched immediately into the study script and played engine.hz(100) the screen says “no parameters”
I reset audio in system and it stops the script and deselects the script so “none” is loaded.
Ive tried launching the script from norns and the same thing shows up in console that I posted earlier. Instead of launching the script inside norns, Ive used maiden to save and then play the script like it says in the tutorial and again the same thing. Ive repeated all this a couple times, every time i turn on the norns now it launches the study script and plays the 100hz tone with “no parameters” on the screen.
My script is in a folder i titled “bkcp” inside the “scripts” directory.

Onlything plugged in is headphones, and the wifi nub. Running on hotspot. Haven’t been able to get the wifi to connect otherwise.