Norns: help

norns

#674

the script for study-1 doesn’t define any parameters, so “no parameters” is accurate.

the error is spurious. menu is trying to map a parameter, but there are none. that should be cleaned up.

if you want to see how parameters work, there appears to be a study just for that: https://github.com/monome/dust/blob/master/scripts/study/param.lua

(i guess this is study 6, not yet written up.)

is study-1 not working as expected in some other way?

it’s intended to just do the things it says in its intro comment, in “play mode.” but it seems to me that you’re navigating to the params page in “menu mode.” (presumably by hitting key1, &c.)


#675

I got to the point that you make the simple key function to print out what key is pushed, then those errors in the console popped up so all those intro comments:

-- many tomorrows
-- norns study 1
--
-- KEY 2 toggle sound on/off
-- KEY 3 toggle octave
-- ENC 2 randomize amplitude
-- ENC 3 change frequency

These never worked, they still don’t work even when i copy paste the entire completed script from the example. I push key 2 and it bounces me to the menu, instead of key 1 as usual, even when inside the script it would show “no parameters”.
I copy and pasted the param.lua you linked and it seems to work.
Norns now automatically launches into this script every time I boot up, it used to boot up clean and say “none” so I could select what i wanted to load, I now have to reset audio to get to “none”.
Im pretty new to code and was hoping these studies would help, but got stopped in my tracks and couldn’t figure out if it was a user error or bug.


#676

that’s the intended behavior. it loads the last script you ran on boot.

that’s the intended behavior when something goes wrong, like a crash or hard power-down. it’s to avoid being stuck in an unrecoverable loop with a script that crashes. (i guess it will also boot in this state if you do a clean shutdown right after enabling wifi or resetting audio, and before loading any script.)

I push key 2 and it bounces me to the menu, instead of key 1 as usual

that, i am kinda at a loss to explain. sounds weird. it is totally possible to put:

function key(n, z)
   if n == 2 then 
      norns.key(1, z)

etc, in your script. thus creating a confusing UI wormhole. not recommended!

but all the scripts from the studies should already be available in the STUDY script directory. (if they aren’t there, you might be in need of an update.)


#677

Thank you for taking the time to help. Im glad the script loading automatically is intended. I found the study1.lua script already on norns and I have the same strange functionality I was running into, “no parameters” inside the script and key 2 bounces to the menu.
updated to 181101 the day it was released. checked the other studies and they seem to be fine. That first one had me thoroughly confused.

Sidenote: Im experiencing a lot of crashes/freezes ect. Ive been trying to write them all down. Is there someplace I should be sharing these, are they helpful and should I even share them? I have yet to turn it on without something strange happening. I don’t want to post a bunch of useless info daily. Thanks again for all your help @zebra


#678

i just checked this out and it’s the same for me and my otherwise normal norns. not sure what is going on with it, will let you know if i can figure it out

edit: super weird. i tried messing with the script in maiden (adding redraw function, etc) and now it still pushes me back to what looks like the menu screen but the script works as expected and pressing key 1 takes me to the real menu as expected


#679

ok was able to get it running, try this:

-in the init function, add the command “redraw()” before the end of the line

-at the end of the script, add a function, something like this:

function redraw()
screen.clear()
screen.text(‘literally any text’)
screen.update()
end

the error has to do with redraw, not sure why. sorry for sloppy formatting, on phone!


#680

ah, i see.

@tehn something funky related to this PR?


#681

yep. this was a requested feature and it broke study 1’s logic.

i’ll update the study.

edit: this is probably not reasonable default behavior. blank play screen is likely better.

in the meantime, @ypxkap has the right suggestion. just add this to the bottom of the script:

function redraw() end

#682

please post crash information here!


#683

is panning typically something that is app specific? for instance, working in crane (@Dan_Derks) using stereo inputs (left and right mics on piano) and I hear the monitor output with the wide left-right panning I expect, but recording/looping with cranes seems to fold things down to be mono.


#684

monitor is a built-in system thing, and can be set to mono or hard-panned in SYSTEM > AUDIO. it would be straightforward to add a “width” parameter if that is a common need.

SoftCut engine used by cranes has 4 mono voices. the input and output balance of each voice can be arbitrarily defined in a script. by default, both ADCs are mixed to each voice input bus, and each voice output bus is split to both DACs.

right now we’re doing some major surgery on backend architecture to improve efficiency. stereo tracks in SoftCut has been a popular request so will come back to that. it’s non-obvious how to address both mono and stereo use cases efficiently and accurately.

in the current structure, it would probably be enough to add an engine command which issues a reset to two voices simultaneously on the SC side. phase within the ugen itself is quite accurate and i wouldn’t forsee any problem with drift.

if you simply send two engine commands to reset two voices (each addressing the content of one channel) then it’s possible that the reset will be executed on a different audio block for one voice than for the other. (i don’t think it’s very likely, but still.)


#685

@n-So, i was holding off for this rather than tempt running two consecutive buffers for L and R to remain stereo. will be pushing an update to the repo before the weekend to include some new things, though :slight_smile:


#686

Thank you for the help @ypxkap


#687

Bit of a MIDI problem I can’t seem to solve. I can get Norns to work as a midi master clock to Ableton Live (@Justmat’s foulplay works fine if I set it to send midi clock out to Ableton), but I can’t seem to make it work as a midi slave. If I set it to external clock and use Ableton as the master, it won’t work. Using a Roland UM-ONE.

Similar problem, I can send midi clock from my norns, but when I try to make foulplay send midi notes to channel 1, Ableton doesn’t recognize it. Are there some settings in either Ableton or norns that I have wrong somewhere.

I tried searching the topic for specifics, but can’t really find any solutions to what seems like a simple problem.


#688

I know it isn’t much help, but I was just able to send clock and midi notes to Ableton Live 9 from Foulplay. I don’t own an UM-ONE, but for what it’s worth, I was using one of these.


#689

(this is not a super well informed question - i don’t really use MIDI - but something to check)

is it possible that UM-ONE exposes multiple ports, and that ableton is choosing a different one for clock out than it uses for clock in? sounds weird but i dunno.

supporting multiple ports is a known issue, a fix will happen, but could take a couple different forms, and that decision is related to other decisions in the pipeline.


#690

Oddly, I was able to get midi out to Ableton to work by making sure that my UM-ONE was the #1 MIDI out device in the norns menu, but that still doesn’t let me externally sync to Ableton. I’ll have to keep playing here. Nothing boosts creativity like device interoperability issues, amiright.


#691

Apropos the missing file at norns-image/config/bashrc in the 181101 update, are there any changes to the existing April 18 timestamped .bashrc file we should be aware of?


#692

it’s just a modification to the command prompt display to show up address instead of hostname


#693

I would love this. I would also like some feedback when I stop a recording - it just disappears and I don’t think I’m successfully stopping them all the time - some of the tape files are way longer than I think they should be.

Also - huge thanks to everyone who has worked on norns - it’s such a great machine - I love it.