Norns: help

norns

#714

well the timer automatically sets it - you just have it as a param in your callback

the whole lua environment on Norns is very well thought out - I’ve come to appreciate it a great deal - and given the day I should be saying a big thank you to @tehn and co for their work :slight_smile:


#715

BTW your code basically adds a table element called ‘stage’ to the counter - and that is of course - whatever you set it to

if you look at the code for metro

I’ve found the code base very helpful in understanding what’s going on

then you’ll see you can set it when you set up the metro

and the internal variable seems to be called init_stage but I’d not mess with that - Lua doesn’t make things private unless you jump through hoops - but in general if you mess about with the inner workings of other peoples code they’ve not exposed via the api - expect things to break :wink:

(when I’m working on Norns stuff I normally have one GitHub tab open on Norns/lua)


#716

yeah - totally. I was staring at metro.lua for a bit before I posted, but sometimes these things are not entirely clear to me. :slight_smile:

(also… sooo many open tabs :stuck_out_tongue_winking_eye: )


#717

Wondering if anyone has both of these and has been successful sending midi out of Norns to the FH-2. Seems it should be possible using a usb A to C cable as that would be the same way you’d connect a computer to FH-2 to send midi to cv


#718

I have an FH-1 - never had any joy with direct connection (it shouldn’t’ work in theory anyway because they are both hosts - but I have tried. Just in case :wink: )

What does work is my iConnectMIDI - you need to go into the old config app and make sure it routes USB<–>USB by default - the Norns sees it as a single connection unlike the computer which see it has 4 separate devices (DIN1, DIN2, USB and none which seems to be a virtual port thing)

this may have changed in FH-2 of course…

(and it would be nice if the Norns saw the iConnectMIDI more like the computer does - something to investigate one day)


#719

Can someone let me know how the usb ports are numbered - which one is port 1.


#720

Go to the menu under SYSTEM->DEVICES->MIDI and they will be listed by number.

Is that what you need?

Wait - you want USB ports? (I don’t think the physical ports are numbered in any way) Do you need that for MIDI/Grid connections or something else?


#721

Just got my norns and hotspot works fine, but I can’t enter a password in the wifi section because ENC3 only switches between the alphanumeric selection and the OK, not to DEL. On occasion if i flip back and forth to different wifi networks it will work the other way - I can choose between DEL and the character entry, but not OK. The password field is also padded with “22222222” for some reason, so I always need to be able to delete that before I can select OK.
Oddly, it worked the very first time, but I got a “password failed”. I see that’s a known issue; I didn’t know that at the time so I don’t know if the password actually worked or not, but I can’t get back to that password now anyway because of the encoder field selection problem. Am I doing something wrong?


#722

Norns update instructions include this:

 copy this file to the root folder of a FAT-formatted USB thumbdrive.```

However - it looks like ExFAT format drives will not work (looks like they don’t mount automatically).

@tehn Perhaps it would be good to update instructions to say FAT-32 instead?


#723

If you’re willing to go command line you might be able to get FUSE running and move your audio around the hard way? Not sure that’s recommended though…


#724

yeah - there’s instructions here, but a touch convoluted for non-command-line folks

(and you have to configure each drive by UUID to mount automatically - which is fine for a regular drive, but not ideal for a flash-drive or sd-card (via usb card reader))


#725

i guess it is GH issue 536 linked above and again here


#726

yes that looks exactly like the same issue - I was just mentioning it in passing rather than reporting - I’ve not investigated but yes

I’ve added a comment to that issue for the moment - happy to investigate more and report back if anyone needs more information


#727

Thanks for reply - yes I seem to remember somewhere, it saying that the Grid must be connected to usb port 1. I’m waiting for a Grid to arrive, so thinking ahead really. Not aware though anywhere that says which port is which?


#728

You should be able to attach the Grid to any physical USB plug on the device.

“port” in the docs is probably talking about the virtual port the device is assigned.

When you get the grid, plug it in and see SYSTEM->DEVICES->GRID in the norns menus to see which virtual port the Grid is using. Or assign it however you like.


#729

Got it! Thanks!:+1: :+1:


#730

I’ve just got around to doing the fifth study and, after going through and typing it all out, ended up with a blank screen and no audio. I thought I might’ve missed something, so I copied and pasted the code directly from the study page and the screen is still blank, and still no audio. I had a mic plugged in, similar to the setup in the study demo video, and although the parameters were all visible, and I could hear the dry input, I couldn’t get the script to make any sound.

I haven’t really been keeping abreast of bugs recently, so I could’ve missed something, but thought I’d ask here to see if anyone ran into similar issues. I suppose there’s also a possibility that there’s something wrong with my code, but having copied and pasted it directly, it seems unlikely.

Anyone got any ideas?

Edit: it’s been a long day and I am silly. I had my sound source plugged into norns’ output. Sorry everyone.


#731

Hello, first post :vulcan_salute:! Recently acquired a used norns and grid (thanks @lei ) and having a lot of fun.

Just started using the tape function to record some mlr jams. Tape is recording, but playback on Norns is silent? When retrieving the .aif files via scp, they play fine on my computer… I’m on OS 181101

Cheers


#732

does the test file hermit_leaves play?


#733

Just got my norns, and am working through the studies -
has anyone gotten the filter cutoff working on the PolyPerc engine as described in studies 1,2, and 3? I get a stacktrace like this whenever I try to adjust it:

lua: 
/home/we/dust/scripts/study/study3.lua:46: attempt to call a number value (field 'cutoff')
stack traceback:
	/home/we/dust/scripts/study/study3.lua:46: in field 'action'
	/home/we/norns/lua/params/control.lua:75: in function 'params/control.bang'
	/home/we/norns/lua/params/control.lua:57: in function 'params/control.set_raw'
	/home/we/norns/lua/params/control.lua:65: in function 'params/control.delta'
	/home/we/norns/lua/paramset.lua:166: in function 'paramset.delta'
	/home/we/dust/scripts/study/study3.lua:77: in function 'enc'
	/home/we/norns/lua/encoders.lua:56: in function 'encoders.process'