Norns: help

norns

#754

Thanks, I’ll give that a go.


#755

I encounter the same issue as @disquiet does.


#756

Hm, I had several issues with the Launch Control Mini and could only get it to work OKish via a powered USB hub. I can recommend the faderfox pc24 as a small, light weight but at the same time very usable knobby controller which does not need any powered hub to work with Norns. I used it on stage recently twice running @artfwo’s wonderful Glut script without any issues. Haven’t used MLR extensively yet.


#757

the current build is CPU heavy when using MLR/cranes and the AUX Reverb at the same time. i’d highly recommend disabling the reverb while using MLR/cranes for the meantime.

there’s a very substantial update on the way that will address all of this. i apologize for long period without an update— large undertakings snowballed into a major version change.


#758

Which MIDI box are you finding workable?


#759

PS: That little Away case you mentioned works perfectly, especially when paired with a cloth diaper. :slight_smile:


#760

no, I didn’t record it… but i think the sound guy might have.
I should try and track it down.


#761

i’ve tried it w/ the naked boards 8 fader thing, kenton killamix mini and my old doepfer pocket series controllers (via a 5pin midi - usb adaptor).


#762

That would be super.


#763

I’ve used the SYSTEM => SYNC => SYNC TO USB feature for the first time. It’s a somewhat new 64 GB flash drive. It’s been running for over 10 minutes. Is this within the expected timing? What is being synced?


#764

no that’s weird. it’s just running update.sh i think. should be doable from ssh session


#765

Oh, I expected the “sync to USB” to copy recordings I made earlier with the TAPE feature.

Also unexpectedly, the 30 minute “syncing to USB” did finish, resulting in the USB drive having no contents. Much to my surprise.


#766

SYNC is being removed in the upcoming update. use SFTP instead (it’s much more reliable and gives progress status)


#767

For reference - It executes this:

os.execute("sudo rsync --recursive --links --verbose --update $HOME/dust/ "..m.sync.disk.."/dust; sudo sync")


#768

Huh, it definitely did not do that. When the screen said the sync was finished the USB drive was empty. I took the risk and plugged in the Wifi dongle. Unexpectedly it worked first try so SSH copy was fine.


#769

I did some testing with a USB stick and an SD card reader and noticed there was an issue with the USB stick being ExFAT formatted which was not recognized by the script searching for lsblk -o mountpoint | grep media

So you gotta be sure your USB stick is FAT32.

Awhile back I thought that I’d make some utility scripts to do copy to USB and then noticed it was already there with the SYNC thing, but @tehn said that’s going away in the next update. I may still try some limited/targeted utility scripts for this in the future.


#770

I don’t completely understand what Norns is, how the software can be run on a Raspberry Pi or what most of the discussions related to Norns are… but it’s all very interesting to me so perhaps I’m a Friend of Norn.

Failing that, a Strymon El Capistan is friends with just about everything


Friends of norns
#771

Norns hardware at it’s core is a linux computer (based on a Compute Module 3 - which is “a Raspberry Pi 3 in a more flexible form factor, intended for industrial application”).

Norns software is a set of “apps” or “scripts” that run on the hardware that can interact with monome devices like Grid, MIDI devices, or other outboard gear. The scripts are user-hackable/extendable with the lua scripting language - so it’s easy to create your own custom scripts if needed.


#772

Excellent - that’s really helpful. Am I correct in understanding that the scripts be a wide variety of things - instruments, effects, sequencers - depending on your needs? If it’s not a stupid question: can it be more than one thing at once?


#773

Can Norns send/receive MIDI via Bluetooth? I’m assuming this might be possible with an adapter. Does anyone know the steps to get it working?