Norns: help

norns

#795

you need a bunch of scripts from lib/sc/ansible too - I know it will be included in the next update but give me a shout.

It’s not doing anything odd - you are most likely just missing something


#796

:grinning::grinning::grinning: thanks for the midi pointers - will check these out …
also big :smile: for QUENCE with midi out from norns to pc/ableton - via usb/midi din ‘wire’ - input to my aging maudio soundcard. great fun


#797

quick question re study4 - what’s the 144 value?
’ m.send{144,60,127}
note the braces, as this is a syntax we haven’t seen yet. it’s equivalent to m.send({144,60,127}). if an argument is a single table, you can skip typing the parens.’


#798

144 here is the numeric control byte value for midi note-on (on channel 1) See expanded midi message list for more. The example in the study is just sending raw bytes.

(as the study mentions) you can send like this as well:

m.note_on(72,100)

or also like this:

m.send{type="note_on", note=72, vel=100}

FWIW - midi handling has been improved and will have some new functionality in the coming update.


#799

Thanks that’s really helpful. Midi for me has always been a bit of a dark art. It’s easy to connect say a controller to the PC without knowledge of the fundamentals. That’s going change …


#800

hi all,

i am having a few issues on norns - i have searched through the forums and can’t find my problem.

i am currently running 181023. i am trying to update to 181101. what is interesting is my free space reads 0mb, but i have not uploaded anything. I reformatted a thumb drive, synced it with norns correctly, but the dust folder only reads 68.2MB.

i am reading that i can fix a lot of these issues with setting norns to hotspot and connect to maiden - but the “WIFI” menu does not change when the network adapter is plugged into any of the USB ports. it’s stuck on “off” - cannot move it to hotspot or network. i have tried rebooting, hard resetting, etc.

something doesn’t seem right. any help would be appreciated!


#801

that’s no good. while we’re waiting on someone more qualified, i have something else you could try. you can access norns via laptop/usb, as seen here:

&

i am not by my mac but i have done this before and i think once you get in it should be the same as ssh(??) and then it’s just a matter of locating any large files to delete. first place i would check would be audio files on the tape:

in the terminal type:

cd dust/audio/tape

ls -S -s

this will show you a list of all the files in the tape which you can remove with this command: rm filname.aif

again, no clue what would be causing this i am just one guy sitting around online on a saturday

edit: just to be super clear doing this will delete your files. so don’t delete anything you might need


#802

hey thanks, i appreciate your help. i tried what you suggested - here’s what i got:

we@norns:~/dust/audio/tape$ ls -S -s
total 13616
13612 hermit_leaves.wav 4 readme.md
we@norns:~/dust/audio/tape$

looks like just the default audio files in the tape section.

i checked that post from brian as well, but it just tells me i have no space left -

we@norns:~/update$ ls
norns181101.tgz
we@norns:~/update$ sudo cp /media/usb0/*.tgz /home/we/update
cp: error writing ‘/home/we/update/norns181101.tgz’: No space left on device
we@norns:~/update$

do you know if there are other directories other than “tape” where i should check for large files?

thanks again for reaching out.


#803

Sounds like it could be a linux issue where the file system wasn’t expanded to fill the storage.

What does this command show?

df -h


#804

It’s maybe huge log files? /var/log I think


#805

hey jonny, this is what i got. looks like dev/root is where the issue lies?

we@norns:~$ df -h
Filesystem Size Used Avail Use% Mounted on
/dev/root 3.6G 3.5G 0 100% /
devtmpfs 486M 0 486M 0% /dev
tmpfs 490M 83M 408M 17% /dev/shm
tmpfs 490M 6.4M 484M 2% /run
tmpfs 5.0M 4.0K 5.0M 1% /run/lock
tmpfs 490M 0 490M 0% /sys/fs/cgroup
/dev/mmcblk0p1 43M 30M 13M 70% /boot
/dev/sda1 58G 145M 58G 1% /media/usb0
tmpfs 98M 0 98M 0% /run/user/1000

i am very much illiterate when it comes to this kind of stuff… so apologies if i typed it in wrong but this is what it sent me -

we@norns:~$ /var/log
-bash: /var/log: Is a directory


#806

No worries, try this:

cd /var/log
then
ls -S -s

‘cd’ is the command to change directory. This will get us in the /var/log folder and then list the files in order, with largest first.


#807

alternately you could use this command without cd-ing to the directory

ls -lahS /var/log

This is a directory listing command (ls), showing all items (-a) sorted by size (-S) with human readable size values (-h) ( 2.1G , 151K , 7.1M etc)


#808

Thanks guys! Appreciate the help.

@Jonny - here’s what came up -

we@norns:~$ cd /var/log
we@norns:/var/log$ ls -S -s
total 2394496
1187248 syslog 12 lastlog 4 apt
1185020 kern.log 148 dpkg.log.1 4 samba
7088 daemon.log.1 108 auth.log 4 boot.log
5080 syslog.1 108 debug.1 4 btmp.1
3080 kern.log.1 80 user.log.1 4 faillog
2476 messages.1 76 wtmp 0 alternatives.log
2176 daemon.log 24 debug 0 bootstrap.log
828 auth.log.1 16 user.log 0 btmp
476 wtmp.1 12 dpkg.log
412 messages 8 alternatives.log.1

@okyeron here’s what came up -

total 2.3G
-rw-r----- 1 root adm 1.2G Nov 4 00:18 syslog
-rw-r----- 1 root adm 1.2G Nov 4 00:16 kern.log
-rw-r----- 1 root adm 7.0M Sep 7 2018 daemon.log.1
-rw-r----- 1 root adm 5.0M Sep 7 2018 syslog.1
-rw-r----- 1 root adm 3.1M Sep 7 2018 kern.log.1
-rw-r----- 1 root adm 2.5M Sep 7 2018 messages.1
-rw-r----- 1 root adm 2.2M Nov 4 00:18 daemon.log
-rw-r----- 1 root adm 821K Sep 7 2018 auth.log.1
-rw-rw-r-- 1 root utmp 470K Sep 7 2018 wtmp.1
-rw-r----- 1 root adm 408K Nov 4 00:18 messages
-rw-rw-r-- 1 root utmp 286K Nov 4 00:18 lastlog
-rw-r–r-- 1 root root 142K Aug 30 2018 dpkg.log.1
-rw-r----- 1 root adm 104K Nov 4 00:18 auth.log
-rw-r----- 1 root adm 102K Sep 7 2018 debug.1
-rw-r----- 1 root adm 75K Sep 7 2018 user.log.1
-rw-rw-r-- 1 root utmp 72K Nov 4 00:18 wtmp
-rw-r----- 1 root adm 20K Nov 4 00:16 debug
-rw-r----- 1 root adm 16K Nov 4 00:16 user.log
-rw-r–r-- 1 root root 9.4K Sep 7 2018 dpkg.log
-rw-r–r-- 1 root root 4.1K May 23 2018 alternatives.log.1
drwxr-xr-x 4 root root 4.0K Sep 8 2018 .
drwxr-xr-x 11 root root 4.0K May 14 2018 …
drwxr-xr-x 2 root root 4.0K Sep 7 2018 apt
drwxr-x— 2 root adm 4.0K Mar 5 2018 samba
-rw-r–r-- 1 root root 3.8K May 14 2018 boot.log
-rw------- 1 root utmp 3.4K May 21 2018 btmp.1
-rw-r–r-- 1 root root 2.6K May 15 2018 faillog
-rw-r–r-- 1 root root 0 Sep 7 2018 alternatives.log
-rw-r–r-- 1 root root 0 Apr 18 2018 bootstrap.log
-rw------- 1 root utmp 0 Nov 4 00:18 btmp

sounds like youre right - it looks to be a huge syslog and kern.log… is that something i can clear? or minimize somehow?


#809

something is going on. the log files should not blow up huge like this.

can you run

tail /var/log/syslog

and send it to info@monome.org ?

then short term fix:

sudo rm -rf /var/log/syslog
sudo rm -rf /var/log/kern.log

you should have your disk space back then


#810

thanks brian - email sent. the quick fix worked as well. appreciate it!


#811

Has anyone had any success sending MIDI to a Kenton MIDI USB Host via the Norns? I’m a bit of a novice with the Norns but have a USB Host and cv.ocd box I’m trying to sequence via Awake in Norns. The USB host doesn’t appear to show up under devices.


#812

I bought Norns from day 1 (well almost…if I remember well I got confused with timezones and had to wait for batch 2), but I didn’t touch it. Too intimidating.
I want to create my own stuff, to use with a grid (does it even support arcs ?).
The studies look fantastic, but would they really make me to master the machine ? And they don’t even talk about the SuperCollider side. Ouch.
I’m quite confident with Max/MSP, I can more or less “read” code but never wrote anything in code, except for some super simple arduino stuff. Made a few Teletype + Grid scenes, but it took some time and work.
Would you advice me to give it a chance ? Is it worth it ?


#813

i was in the same boat, i tried to post updates on my progress as i was doing it here, with videos when possible. if you want to see what i was up to and how long it took.

i would say definitely yes. my prior experience was reading “automate the boring stuff with python” and applescript for fixing shortcoming in my company’s workflow. so i knew how to write scripts line by line. but i have tried to do the max/msp tutorials 4 or 5 times and could never work it out well enough to even do the max grid study.

definitely do the studies! don’t worry about supercollider yet. i’d expect once the next update gets pushed for the device with the new soft cut there will be a couple more.


#814

Is that the engine used in mlr ?
Thanks for the reply (and thanks to tehn who, in addition to making wonderful stuff, moved this topic here) !