Norns: help

norns

#876

i haven’t had any issues, but i have the reverb turned off and have only spent limited time with MLR which i think was the one people notice the bug on. there is definitely a problem with certain combinations of scripts and reverb but it hasn’t been affecting me. it would be good to follow up with people who had the most alarming to you posts and seeing what the status is for them.

the “major change” coming is a rewrite of the sample engine used by MLR and some other apps to be a lot more efficient (going to c instead of living in supercollider (i am oversimplifing and also i barely know what i’m talking about but)). it will hopefully fully solve that issue, but nobody will know for sure until it gets loaded onto more machines.

again though i’m speaking in the abstract because i haven’t noticed this problem nor specifically tried to reproduce it. smooth sailing here except when i fuck up my own scripts. just didn’t want your question to get lost in the discussion above!


#877

thanks! all input is useful.


#878

It’s a bit unstable for now, have a performance in two weeks and I’m quite sceptical…


#879

the current build is cpu intensive. it makes sense to disable to global reverb for more headroom.

this is all fixed in the upcoming update.

earlier (less heavy) updates were also very stable-- i left norns running for days on end, played high pressure long shows, no problems at all.

there’s also cpu monitoring on-device so you can get an idea of what you’re working with. but again, the upcoming update is version 2.0, with very fundamental changes to the architecture. a big improvement.


#880

Where’s this? (more characters)


#881

I have a rather long wifi password. It scrolls off the screen on Norns. I can’t tell if the extra characters are being typed. But the auth fails.

Is there a password length, or a way to scroll to the right of a long password?
Is it possible to set the wifi password via maiden?

update: looks like I’m on 180906. Pretty far back. trying to update firmware now.
…getting the ‘no updates found’ message.


#882

I think it’s found here:

SYSTEM > RESET AUDIO [TEMP / CPU %]

(don’t press… unless you want to)


#883

I’m trying to update Norns. Just received it. It appears to be on 180906. I downloaded the tgz file and put on a newly formatted 32gb flash drive FAT32 (windows).

I’m getting the ‘no updates found’ message.
The log says ‘bad update file’

I opened the tgz on windows desk. It has both tgz and md5 files.

md5: 7de65862f065564d4a389cb4b57200a7


Norns: updates
#884

Have you tried the hotspot/alternate method on this page?

https://monome.org/docs/norns/update/


#885

@swhic I’ve had much better luck with speed/stability/etc. using norns in hotspot mode and connecting my computer to the norns network, as opposed to norns connecting to my home wifi.


#886

Hotspot for me for some reason gives me extremely low speed transfers


#887

I’m not really clear what hotspot mode is? Do I need to do something to set things up?
:expressionless:


#888

I didn’t try ftp last night.

Hotspot works for connection but it’s not ideal because then I can’t connect to net on my pc. It doesn’t change the update problem either.

I wasn’t able to get update working.

Are there limits to the ram size on the flash drive?

Are there any plans to roll updates into maiden? Seems doable. Would be much simpler.


#889

You should give ftp over hotspot a try if you’re having trouble with the usb drive method. You’ve already got the update file on your computer, so you won’t need to connect to the internet. I realize you said it’s not your ideal way, but if your goal is to get up to date, it’s worth a shot.


#890

It’s just another option in the settings > network menu. You scroll to it and click the right most button and it will put it in hotspot mode. Then you should see a WiFi network called norns on your computer (you may have to turn on and off WiFi on your computer to get it to show up)


#891

I actually read the norns docs today. Found the procedure for loading samples via a FAT formatted USB drive. Worked lovely.


#892

is there an ETA for 2.0?


#893

I’ll do that this evening. Thanks.


#894

I’m still having some problems with the update and would really appreciate some pointers.

I bought this Norns on reverb last week.

The latest error makes me wonder if the previous owner wasn’t poking around in the file system and deleted some files accidentally.

I know that some of the scripts are working; I’ve been able to play and hear notes through a few scripts.

Win 10

hotspot start, connect
sftp the update file
ssh using the alt method
unzip, etc, all looks good.

we@norns:~/update/181101 $ ./update.sh
(Reading database ... 44074 files and directories currently installed.)
...
Processing triggers for man-db (2.7.6.1-2) ...
cp: cannot stat 'norns-image/config/bashrc' cp: cannot stat 'norns-image/config bashrc': No such file or directory

Am I missing files?
Is a total firmware/file system refresh possible to make sure everything is solid?

Thank you


#895

This error was mentioned previously in this thread. I think you can ignore it.

Just reboot and you should be good (I think).