Norns: help

norns

#896

Using maiden (the norns web editor) on a tablet device like an iPad is possible but there are aspects of the UI which aren’t touch input friendly so the overall experience is compromised. The general expectation for the editor was that people are using computer.

As always enhancements to maiden are welcome if folks are so inclined.


#897

Can someone explain what a “tape” is in norns? I’ve seen this mentioned several times in the threads, but haven’t yet come across a definition or examples. Thanks.


#898

Tape is a recorder. Navigate to the Levels page and hold key2 to see the record option. press key3 twice to start recording (this is one press to arm, another to begin recording). Holding key2 and pressing key3 again will stop the recording.

Here are the docs there is a section on TAPE :slight_smile:


#899

I don’t have advice that will help other than I’m pretty sure I had similar problems when I was starting out - now I can’t remember how I got past them though. If I remember it was half something weird norms was doing and half something wrong I was doing.

Can you summarize where you’re at?


#900

Thanks. Missed that doc section.

1/ does this record whatever script sound is currently playing or audio coming in inputs?
2/ where do the tape files reside? In the ‘tape’ folder?

Thanks.


#901
  1. TAPE records the incoming audio as well as the output of whatever script you’re running.
  2. That is correct. The tape folder is located in the audio menu.

#902

EDIT- updating to 181101 fixed it


#903

Restarting norns after the missing file error worked. I re-ran update once more just to be sure; got the error again, but it seems to be working.

How stable should norns be at this point? Being new to it, I don’t know if it should freeze up and crash every thirty minutes or so. I can usually start one script. If I exit the script and start a different script, there’s a high probability that norns will lock. In the last week, I have had to shutdown using the bottom button more times than I can count.

I this typical for others?


#904

This is no longer typical for me.

I’ve had norns since the first batch, and initially experienced what you describe. Over the last month, however, it’s been part of my daily setup, on for hours at a time, and it’s only crashed once.

One difference between my scenario and yours: with the latest update script, I opened up the file & commented out the line that is leading to a problem:

cp norns-image/config/bashrc /home/we/.bashrc

I did this to make sure that the lines after it get run. Those are:

cd /home/we/norns/sc
./install.sh

I’m not sure whether or not the sc ./install.sh piece would be run as part of normal operations, or even how important it is to the update process; I’m just highlighting it as a measure I took since I’m not experiencing the same degree of instability.


#905

If you are using the global effects engine (reverb), turn it off for now and see how it performs. I had similar issues with norns and turning that off solved most of the freezes. This component will be redone in the 2.0 update.


#906

Thanks. Great suggestion. I’ll post back later when I know if it helped.

This seems like a fix that should have been patched in the release immediately.


#907

I’ll double check that reverb is off. Thanks.


#908

the .bashrc error is really no cause for alarm… it just adds the IP address to the command prompt which has no actual effect on normal usage.

as stated above, the over-CPU crashes will greatly reduce (hopefully eliminate) crashes, a problem which has been solved in the forthcoming update with a massive redesign of the DSP system. thank you for the patience as we finish it up.


#909

For my own desire to understand the update process: does the sc ./install.sh not matter, or get run automatically outside of the update process?


#910

heyyyyyy there. first post here.

have Arc4, so wonderful. use it with Ansible with euro chibblets. lucked into a trade for a Norns, went ahead and ordered a Grid.

i’ve got a decent handle on how i’m going to approach integrating Grid with euro shtuff, but curious on any suggestions where to start with Grid and Norns playing together?


#911

there are several readymade scripts that use the grid already on the norns. if you’d like to start learning to make your own check out the studies: https://monome.org/docs/norns/study-1


#912

It may have mostly been turning fx off, and not the update fix, but Norns is much more stable now!


#913

Do any of the current synths expose their parameters to be edited via external MIDI CC?


#914

If you see the parameters in the submenu, you can map your controller to them. This was a little tricky for me to find in the beginning:


#915

Thanks, @Jonny. Works great. Looking forward to mapping a KMI QuNeo.