Norns: help

norns

#957

A suggestion: scroll to the end of the study. Copy and paste the final complete study code into maiden and run it.

This may give you a better idea of what is involved in the particular “lesson”. Then you can go back and take each snippet, piece by piece.

tehn does a great job at simplifying things, but I find seeing what I’m looking forward to as a motivation for each step in the process. Just an idea.


#958

There’s also good documentation on what’s breaking or needs updating to work on 2.0. The changes are pretty easy fixes so they should get updated quickly in the main repo (probably during beta testing). The question will be if they docs/studies pages get updated quickly or not. Brian’s got a lot of plates spinning with this update.


#959

updating the studies is a top priority prior to official 2.0 release. as are proper docs. lots to do! but it’s actually getting done rapidly. lots of help from smart people make it happen.


#960

my norns doesn’t seem to recognize the usb nub in any of the ports. in the wifi menu status just comes up empty. used to work fine.

have tried ever port, power-cycling, etc.

EDIT: just tried to revert to an old firmware to reset things, stuck on checking for updates.

my “Disk free” is saying 0MB. last time I was using norns it was frozen in MLR so i force shut down. seems like maybe something went quite wrong.


#961

Resetting audio: What is this and why do I need to do it so often?

Thanks.


#962

it stops and restarts the supercollider processes.

you shouldn’t need to do it often. but there are a couple particular issues which have been discussed in detail.

supernova may crash when there is too much stuff (which is why we are ditching supernova for scsynth again in 2.0, and moving a lot of functionality to standalone jack client)

[ https://github.com/monome/norns/issues/603 ]

both SC backends may crash when system time is syncd (e.g. when joining network)
this is why audio is disabled and must be reset after enabling wifi

[ https://github.com/monome/norns/issues/399 ]


#963

how are your command line skills?

you’ll need to serial in with screen (from the docs:)


When connected via WIFI you can SSH into norns at the IP address shown in SYSTEM.

  • user: we
  • password: sleep

Without WIFI, you can connect to norns via USB-UART by connecting the power cable to your computer. On Mac/linux do:

screen /dev/tty.usb(tab) 115200

Where (tab) appears hit TAB to autocomplete the serial number. Login is the same as above.


culprit is like tape recordings:

cd dust/audio/tape
ls -l

this will show the files (and sizes)
to remove one:

rm (filename)

if it’s not there, we have to dig in deeper


#964

thanks so much Brian- is there a way to do the USB thing on Windows?


#966

Hello folks. Could someone please point me to some more details about midi mapping? I have followed the instructions buried above, but have had no response from the parameters in question.

The devices I’ve tried show up in devices>midi and it seems to go into learn more… But then no midi control. What am I doing wrong?

Oh, and can one map midi control to params currently set to norns buttons and encoders? eg. Use a foot pedal to trigger recording in cranes?

Many thanks!


#967

if this is in cranes, the current software doesn’t allow for the type of params in the script to be midi mapped. this will be addressed and cranes will be changed in the coming update, though!


#968

Good to know about cranes (which I love, by the way). But the mapping problem seems to be in other patches too.


#969

which I love, by the way

thanks so much for the kind words! :slight_smile:

I believe the issue is pervasive, depending on the script you’re loading:

to confirm, you haven’t been able to get any scripts responding to midi map?


#970

managed to delete the tape files using Putty to emulate linux commands. confirmed they were deleted by loading up a sampling script and navigating to the folder in norns, and they were in fact removed successfully.

disk still showing up 0MB free and wifi not working. :woozy_face:


#971

logs?


#972

ooh interesting! these are the top files

-rw-r----- 1 root adm 783M Feb 12 06:25 daemon.log.1
-rw-r----- 1 root adm 783M Feb 12 06:25 syslog.1
-rw-r----- 1 root adm 207M Feb 12 22:42 syslog
-rw-r----- 1 root adm 207M Feb 12 22:42 daemon.log
-rw-r----- 1 root adm 948K Feb 12 02:26 kern.log.1
-rw-r----- 1 root adm 707K Feb 12 06:25 messages.1
-rw-r----- 1 root adm 432K Oct 2 06:25 syslog.7.gz

EDIT: navigated up to your original comment you quoted and did Brian’s suggested temporary fix to remove the top 2 files. disk space is back, and wifi is working!

begs the question though as to how this happened, if it could happen again, what to do from here :thinking:

but thank you so much @okyeron and @tehn for what appears to be a temporary fix!


#973

made GH issue. we should install a logrotate cron job or whatever the contemporary equivalent


#974

i’ve already run into trouble on the first study - i also ran the included study code (study 1 in the study folder) and ran into the same issue.

for the part of the tutorial where i’m supposed to be seeing key names and states, keys 1 + 2 don’t do anything, key 3 returns an error. is there a certain screen i’m supposed to be on when i do this? i wasn’t getting encoder info in the message box either.

error starts with " attempt to index a nil value (field ‘?’) "

here’s everything i get when i run the first study. i only have up until the intro of the key function. the error text happens when i press k3:

norns.script.load("many_tomorrows.lua")
# script load
# cleanup
# script clear
# script run
loading engine: TestSine
<ok>
Engine.register_commands; count: 2
___ engine commands ___
amp	 	f
hz	 	f
___ polls ___
amp_in_l
amp_in_r
amp_out_l
amp_out_r
cpu_avg
cpu_peak
pitch_in_l
pitch_in_r
tape_play_pos
tape_rec_dur
# script init
the end and the beginning they are the same.
READING PMAP
lua: 
/home/we/norns/lua/paramset.lua:177: attempt to index a nil value (field '?')
stack traceback: /home/we/norns/lua/paramset.lua:177: in function 'paramset.t'
/home/we/norns/lua/menu.lua:690: in field 'key'
/home/we/norns/lua/menu.lua:144: in function </home/we/norns/lua/menu.lua:121>

#975

I ran into this issue and got the answer over on the studies thread:

There are a couple of things over there that may save you some grief until 2.0 comes out.


#976

huh. i was scouring the forum and never saw that. lots of information here! thanks a lot.


#977

I’ve done a bit of diving on the subject but couldn’t really find anything concrete. I also went through the physical study, somewhat grasp the markeats passersby example. Any rate, I still can’t get an external sync to work. I’ve had success with CC and MIDI learn, but no clock sync. I’m specifically trying to sync playfair and/or foulplay.

I’ve tried numerous scripts that utilize external sync with Ableton (MIDI and USB) and an OP-1. Has anyone else had any luck with this? Am I missing something obvious? :woozy_face: