Norns: help

norns

#978

There are some improvements in midi - specifically clock - that I worked on that are not in the current (181101) release.

So this is greatly improved in the next release, but that doesn’t help you much right now.

If you were feeling adventurous you could get the more recent midi.lua, replace that, stop/start norns and then update the scripts with the new midi fu.

I have an example test script which should work with external sync. You’d need to work from here to update playfair or foulplay.


#979

Some things to check:

  • Is the device you’re trying to sync with configured to send clock? Are you connecting that device directly to norns? Are you able to sync things other than norns to that clock source?
  • Can you receive midi note data from the clock source to norns? Try one of the scripts that responds to midi notes.

The more specifically you describe your situation the easier it is for folks to jump in with suggestions.


#980

Thanks for the reply.

External devices (Ableton and OP-1) are set to send clock and they work with other devices. I’m also able to send note data and CC to Norns. The issue I’m having, specifically with playfair and foulplay is when I set the clock to external, norns is unresponsive. I’m able to clock things with norns just fine but for certain projects I prefer to have one master clock coming from my DAW.


#981

This is perfect, thanks for the test script. I can always sync from norns for the time being but I’m happy to hear about midi improving.


#982

What software version is your norns running?


#983

Running the latest version 181101. Actually just re-uploaded the install thinking that might fix it but no luck.


#984

i might suggest manually running the installer. unpack it in update/ and manually execute update.sh via screen or ssh (can provide further details if needed)


#985

I’m not able to create new folders in Maiden, only new scripts. When I try to save a new folder nothing happens. Is that normal behavior?


#986

I actually just did the manual update last night because my norns wasn’t functioning (disregard the email I sent to info@monome, all good now). Not sure if this is the same process or not but I’m still not getting any external sync after the update.


#987

I had this issue a while ago, and - as far as I an remember - it seemed to be a Firefox problem (running on High Sierra). I was able to create folders in Safari.


#989

Thanks. Yes, it works in Safari. I cannot create folders in Chrome or Firefox. I’m running High Sierra.


#990

I just received a 2nd hand norns (as a spare). Screen is very dim. I can barely read anything.

Is there something I can do or should I return? Thanks.


#991

In regards to the clock issue, would that also stop the wifi from working at all?

I have turned on my norns with the supplied wifi dongle to get back into it but my wifi is not working at all. Cannot make hotspot, cannot connect to an existing network.

I’ve tried moving the dongle to other usb ports, tried sleeping and waking up, hard rebooting from bottom button, and tried using another generic wifi dongle.


#992

I’m sending it into monome HQ on Monday. Brian seemed as curious as I as to what would have gone wrong.


#993

This sounds like the same issue that cropped up for me last night. I turned on my Norns and and the writing on the screen was extremely dim except for what I currently had selected with the encoder. I rebooted this AM and it’s even dimmer.
I’m also sending out to Brian this week, so he can take a peek at it.


#994

as someone new to the world of norns, how similar is its language to teletype?

in other words, how compatible is lua with my knowledge in tt?

and is ‘crow’ the bridge being built from norns to modular?


#995

I don’t yet have a Norns and have not yet started to code with lua but from what I’ve gathered -

how similar is its language to teletype?

I don’t find Lua hugely similar. if you’re familiar with a coding language like JavaScript or Python, then you will likely be able to grasp the concepts of functions, loops etc quite rapidly. But your knowledge gained with Teletype will be valuable, as the trick with coding is to develop a sense of computational thinking rather than worrying too much about syntax. With Teletype you already have a head start there.

and is ‘crow’ the bridge being built from norns to modular?

It looks like it will be - https://github.com/monome/crow is a good place to read up on it, but you may want to wait and see when it is released!


#996

thank you!

well on track with teletype, so i hope the computational thought will assist.


#997

is anyone having trouble with norns powering certain midi controllers? it powers my grids fine, but it couldn’t make sense out of my little akai 25-key. one of the lights on it flashes very dim for a few seconds and i can’t get any midi info from it.

it’s not a huge deal as i didn’t really see myself controlling norns with a keyboard, i’m just curious if anyone else has run into anything like this.


#998

No problem here. Does the midi kybd show up in the norns midi config list? Don’t know how you are testing, but norns study 4 includes getting midi into norns from an external midi device.