Norns: help

norns

#1040

Must admit I’ve been very frustrated with my norns lately- totally unclear if its user error or if something is wrong with mine.

At the moment I just want to try out @LFSaw 's Haven script- noticed it appeared to be in Dust now. (though I am not a programmer so my knowledge of how github works is basically nothing, I don’t know what pull request is, etc. etc.)

In the past when I wanted to add scripts I just used wifi or hotspot, made a new script, and copy-pasted the code that I found in Dust. I noticed for Haven however that I also have to add an engine.

So I investigated how others merge dust updates with their norns, and I saw that some use a USB drive, where you download dust from github, unpack it and put it on a drive. Then “sync from” USB. (I’m aware this could mean loss of saved things but I don’t have anything I need to backup).

Tried doing that today, and when I select “sync from USB” it happens INSTANTLY, and it appears nothing has changed- no new scripts, etc. Tried with other USB drives, all freshly FAT formatted, same thing.

So I figured okay why not try WIFI/maiden again to see if I cant manually copy/paste the engine and script. And today for whatever reason, wifi can barely recognize any networks, and when it can and I try to connect, it consistently comes up with “failed.” This is a new problem, as wifi has worked for me in the past.

So I figured okay why not try hotspot, that has also worked for me in the past. Fire up hotspot, gives me the IP address, and my computer struggles enormously to find it in the list of available networks, and again when it does, it stalls for a bit and then drops connection.

At this point, is there some way I can do a damn factory reset or something? At a bit of a loss right now because I just cannot seem to ever get this device to behave the way I want anymore, and I’m so excited by everyone’s fantastic scripts, but again I don’t know if I’m doing things wrong or if my device is just totally out of whack.


#1041

i’m writing up instructions for an image reset right now.

part of 2.0 (beta of which i’m preparing to upload now) focusses on script sharing and collecting. the wifi system is overhauled and has been working more reliably (though hotspot is now not functioning, working on it.)

main issue is the Haven script has an engine that goes along with it, which needs to be properly installed, and beyond released updates we do not have a documented way for people to update their engines. until now many of the more complex processes have been left to developers… the 2.0 update aims to simplify sharing/collecting for everyone.

i’m sorry for the trouble and frustration— i understand and it’s been a huge goal to evolve this part of the ecosystem


#1042

For the technologically … timid … of us, it would be a huge relief to just be able to plug and go, so big thanks for all you’re doing to make this easy for the masses.


#1043

Hey im super new to the Monome world, so far loving it i just got a Norns and couldnt be happier, started using the scripts that came with the norns, i tried to get more from dust via usb, sadly some ss problem happened, in the end i had to delte some file using Cyberduck, anyway the thing is that norns funtions good again but the new scripts are failed to load, wondering if someone can help, thabks again and always.


#1044

A solid method is to turn on wifi in norns, then point your web browser to https://norns.local. This opens maiden and allows you to store and run scripts. It’s covered in the norns docs here: https://monome.org/docs/norns/


#1045

most people have been waiting for updates to run new scripts, if they include an engine.

the alternative is to connect to wifi (network, with internet), log in via SSH, and then cd dust; git pull

after a reboot things should work.


#1046

I’m still on the old (1.0) norns software and I’m experiencing more JACK xruns than usual it would seem. How can I go in and adjust the buffer settings for JACK to adjust to decrease the number of xrun drops?


#1047

what is your CPU use at? have you disabled the reverb?

you can edit the jack config here: /etc/systemd/system/norns-jack.service

ps, 2.0 is substantially optimized.


#1048

CPU with reverb was 11%, without reverb is ~8%. The xruns do seem to stop once I turn the reverb off. Seems strange though since the CPU usage didn’t seem so high. I might just use an external reverb until I upgrade my norns to 2.0! :grin:


#1049

this tallies with my experiences. i don’t think these are xruns as JACK reports them (i.e., a client failed to deliver a processed buffer in time.) rather i think they are stalls in individual DSP worker threads within supernova. it’s an issue that seems unique to supernova on ARM, and appears when (as here) there is a single heavy UGen/synth (the reverb) that takes input from multiple parallelized synths.

i recommend updating to norns 2.0 ASAP for many reasons. among other things, the FX and mixing calculations are placed in different processes in a more intentional way that leads to saner load-balancing.


#1050

I hope I’m asking this question in the right thread. I have a theremin I want to interface with my Norns. The theremin has mono audio out, CV pitch, CV vol, and gate. I would like to be able to get the CV outs into Norns. Is there a product I could use to convert the CV to some sort of USB protocol? Midi, osc, or hid would work… I did some looking but didn’t find something that looked simple. Maybe I could make something with a teensy board?

I just think it would be really cool to do effects on the theremins sound tied to the CV values. Also controlling a synth with the theremin would be nice.


#1051

I’d say a Kenton Pro midi to cv plus a cheap midi to usb cable. Not sure about what you can do with it though.


#1052

It sounds like crow from monome will end up being useful for that. crow will have 2 CV inputs that you’d be able to use to control any kind of parameter on norns. there is still no release date but it should be out in the next few months.


#1053

crow will do precisely this… approaching quickly.


#1054

somebody (me) needs to sell something fast.


#1055

That sounds pretty nice! Depending on the price I might want two, one for my isims and one that I just use with theremin and Norns. Maybe I’m being silly but I like the idea of just the theremin and Norns.

Is there a gate input on the Crow? Not that it’s super important because I could just add a threshold trigger to the vol CV.


#1056

a standalone cv-midi would work well for non-euro (ie theremin) as powering it would be less complex.

crow has all sorts of threshold a hysteresis for trigger detection. it also has polling and streaming input modes…more details soon.


#1057

The hysteresis threshold is done on Crow? That’s not a very expensive function, is it on Crow instead of host because you can use Crow with out Norns too? Crows is sounding pretty interesting.


#1058

I asked this question in the thread Monome stock updates already, but I think many of you won’t notice it there.

I just ordered Grid + Arc – and it will take a few more months until Ansible will be available again. So I’m wondering if Norns + a MIDI/CV/Gate expander (like FH-2, FHX-8GT) might be a better option than waiting for two Ansibles?

I don’t see myself coding for Norns, so I would probably only use exisiting/shared scripts. Norns is still kind of a mystery to me, so perhaps some of you, who own Norns and Ansible could comment on the pros and cons? I think one disadvantage of Norns is not having i2c…?


#1059

instead of a norns, i might recommend using your computer with ableton/m4l or max? this way you don’t spend extra money on something that might not be quite right. the documentation for norns is getting overhauled right now, so check back in soon and perhaps it will be more clear. crow will function as a highly integrated cv bridge between norns and eurorack (and more).