Norns: help

What’s Otis? 20 char

Something I am going to post this weekend. :slight_smile:

9 Likes

Otis rules! I’ve only done some light testing, but truly amazing work

1 Like

Thanks all! Also I’m so excited for Otis! We are living in exciting times.

1 Like

Is anyone else having WiFi issues? Hotspot isn’t working nor is connecting to a Macs hotspot. Home WiFi works a treat.

Same here…

Tbh I think we’ve pretty much exhausted our options regarding the included wifi nub. If it isn’t working my suggestion would be to find any other wifi USB stick which doesn’t use a Realtek chipset and give that a try.
I’ve got one of these and it’s been working fine since day one https://www.fasttech.com/product/1147301-sl-1506-802-11n-150mbps-usb-wifi-wireless-network
(although I’ve never used norns as a hotspot nor connected to a machine running a macOS hotspot).

have you tried serial login and running nmtui?

1 Like

New Norns owner here, and am really enjoying getting to grips with it after spending months reading about it.

Am I right in thinking that there is no way to get the Tape->Play to loop? That would be a really nice thing to have.

Is the Sevilla Soft MIDI USB-USB still the best way to get MIDI from Norns to a laptop?

1 Like

I have this problem right now. What’s the more verbose way?

I’ve used the Sevilla soft adapter to control Norns with iOS apps from iPad and so far has worked flawlessly.

1 Like

And vice versa, drive iOS apps from Norns MIDI?

you should be able to see these errors by connecting with maiden, navigating to the SC REPL tab, and entering ;restart at the REPL prompt.

otherwise, you can stop/start things manually from the terminal on norns:

~/norns/stop.sh to stop everything

(killall sclang, killall scsynth to just stop supercollider components.)

sclang to launch the supercollider interpreter - it will start an scsynth process automatically

~/norns/build/matron/matron to launch matron/lua.

~/norns/build/crone/crone to launch the crone process (the ‘master’ jack client - not supercollider - which boots very fast and shouldn’t really need to be relaunched.)

(to be clear: the ~/norns/start.sh script (and the systemd services) willl launch matron and sclang with wrappers to pipe their stdin,stdout to the browser interface (via websocket.) so that’s the motivation for launching things manually if you want to capture output on the terminal instead.)

(NB: if you stop/relaunch SC components without stopping/relauching matron, not everything innorns menus / scripts will work - there is a handshake step that needs to happen. if you just need to see if SC interpreter is successfully launching - duplicate classes will prevent this - then it doesn’t really matter if matron is running correctly or not.)


lastly: if you just want to search for duplicate .sc files in ~/dust, this bash one-liner works for me (and yes, we should just bake something like this into the norns menu):

find ~/dust/code -type f -printf '%p/ %f\n' | sort -k2 | uniq -f1 --all-repeated=separate | grep *.sc

(alternatively, install and use fslint, for more options and ease of use at cost of some disk space)

(and a final pedantic point: what actually breaks SC is not duplicate filenames, but duplicate class names. in practice, for norns engines you are unlikely to encounter the latter without the former.)

yeah that’s on me, still. sorry! maybe i can do these today / tomorrow, they should be easy but life has been very full lately.


4 Likes

Thanks for this. I accidentally deleted code as well. I must be missing something simple, because I followed the reset manually instruction, but Norns still can’t see anything when I go through the select option? I searched in the forum and can’t figure out what I’m doing wrong. I have Norns up to date. Thanks for any help.

need more data.

can you shell into norns and do ls ~/dust, ls ~/dust/code?

or for the full monty, if your norns is online:

sudo apt-get install tree
tree ~/dust

havent yet tried, but in theory should be as easy.

Thank you so much. I missed the case (lower) on code. Thanks again!

cd norns
./stop.sh
./crone.sh

(From memory, typing this on my phone) but that gave me actionable errors.

Haha I see the much more comprehensive answer above now. :see_no_evil:

1 Like

Have now, no joy. No signal. It’s cool though, made work install a new WiFi network for people’s personal gear, can now norns at the office :slight_smile:

Hi! I have recently updated to 2.0, but there was an audio engine error caused by duplicate items. So i tried connecting via serial usb connection, accidently deleted everything inside “dust” folder. Then i tried cloning dust git repository but my terminal wouldnt connect to git. I tried to figure out how to move all the dust files from github into Norn’s dust folder, but it was too confusing so I decided to just flash the image to make sure I havent deleted anything else on the way that is important. I used this command line: wget https://monome.nyc3.digitaloceanspaces.com/norns181008.img.zip to install the disk image. I believe it got installed with no isues, but I am not sure if this is even the newest disk image, not really sure wether the newest one is the one on github or its elsewhere, since links dont look similar at all. Now Norns does not turn off, stuck on the “sleep.” word.

Could someone please explain how to correctly reinstall the newest disk image to norns and make sure there are no duplicate engine errors? I am fairly new to terminal and github and it seems like all the information is scattered around different topics which makes it really frustrating to deal with.

Thank you very much!