Norns: help

Not a norns user, but the OP-1 tape is pretty tough to sync to anything in my opinion. Are you on the newest OP-1 firmware?

i am. i thought it might just be the op-1, but as i mentioned ableton seems to be able to work “as expected”, so it seems like it should be possible…

on the off chance that there is some common element, what gear have you tried and not gotten working? and did you have this specific problem or just general annoyingness?

i’ve had the same results trying to sync op-1 tape to mlr midi. my “solution” was to just set them both to the same tempo and manually start the op-1 tape in time. they held sync pretty well. not a real solution tho :slight_smile:

2 Likes

@ypxkap this is the same way I’ve been able to sync the op-1 to other gear too. The tape makes it really unstable, super cool function but not friendly to other devices. Just kind of the way it is :man_shrugging:

1 Like

to clarify, i know the op-1 midi stuff is all (famously!) half baked. but that wouldn’t explain (i think) why ableton is able to do it, or why awake seems to do better than loom.

i’m getting the sense i am going to have to figure out how to compare the exact clock messages from the three contestants… or at least put enough time with op-1/ableton to see if it’s actually not working right and i’m just insane.

hypothesizing:

  • norns midi clock is definitely susceptible to jitter. all the clock stuff is implemented in lua and sent out from the main thread, where many things are competing for CPU time. (norns metros themselves are quite accurate (as much as a simple threaded implementation can be) but the actual evlauation of metro callbacks is susceptible to other stuff. this should be easily improvable in near future with artfwo’s coroutine + worker thread implementation.)

  • loom has a lot more stuff going on in the main thread than awake does.

  • different midi clock clients will handle jitter more or less well. some will take clock timing at exactly face value with no processing (guess: op-1.) some will apply hysteresis, other filtering, attempt to detect and extrapolate missing clocks, &c (guess: ableton.)

1 Like

Hi, I installed several programs with the librarian application , most work but fo rsome reason meadowphysics_norns/mp_mII doesnt load. It gets to the initial instruction page but going further return the following in maiden

any ideas?

Maiden Dump

1

matron

sc

pset >> write: /home/we/dust/data/system.pset

script load: /home/we/dust/code/meadowphysics_norns/mp_midi.lua

cleanup

script clear

including /home/we/dust/code/awake/lib/halfsecond.lua

SCRIPT ERROR: load fail

/home/we/dust/code/meadowphysics_norns/mp_midi.lua:21: module ‘meadowphysics/lib/meadowphysics’ not found:

no field package.preload[‘meadowphysics/lib/meadowphysics’]

no file ‘/home/we/norns/lua/meadowphysics/lib/meadowphysics.lua’

no file ‘/home/we/norns/lua/core/meadowphysics/lib/meadowphysics.lua’

no file ‘/home/we/norns/lua/core/params/meadowphysics/lib/meadowphysics.lua’

no file ‘/home/we/norns/lua/lib/meadowphysics/lib/meadowphysics.lua’

no file ‘/home/we/norns/lua/softcut/meadowphysics/lib/meadowphysics.lua’

no file ‘/home/we/dust/code/meadowphysics/lib/meadowphysics.lua’

no file ‘/usr/local/share/lua/5.3/meadowphysics/lib/meadowphysics.lua’

no file ‘/usr/local/share/lua/5.3/meadowphysics/lib/meadowphysics/init.lua’

no file ‘/usr/local/lib/lua/5.3/meadowphysics/lib/meadowphysics.lua’

no file ‘/usr/local/lib/lua/5.3/meadowphysics/lib/meadowphysics/init.lua’

no file ‘/usr/share/lua/5.3/meadowphysics/lib/meadowphysics.lua’

no file ‘/usr/share/lua/5.3/meadowphysics/lib/meadowphysics/init.lua’

no file ‘./meadowphysics/lib/meadowphysics.lua’

no file ‘./meadowphysics/lib/meadowphysics/init.lua’

no file ‘/usr/local/lib/lua/5.3/meadowphysics/lib/meadowphysics.so’

no file ‘/usr/lib/arm-linux-gnueabihf/lua/5.3/meadowphysics/lib/meadowphysics.so’

no file ‘/usr/lib/lua/5.3/meadowphysics/lib/meadowphysics.so’

no file ‘/usr/local/lib/lua/5.3/loadall.so’

no file ‘./meadowphysics/lib/meadowphysics.so’

stack traceback:

/home/we/norns/lua/core/norns.lua:185: in function </home/we/norns/lua/core/norns.lua:185>

[C]: in function ‘require’

/home/we/dust/code/meadowphysics_norns/mp_midi.lua:21: in main chunk

[C]: in function ‘dofile’

/home/we/norns/lua/core/script.lua:140: in function </home/we/norns/lua/core/script.lua:140>

[C]: in function ‘xpcall’

/home/we/norns/lua/core/norns.lua:186: in field ‘try’

/home/we/norns/lua/core/script.lua:140: in function ‘core/script.load’

/home/we/norns/lua/core/menu.lua:423: in field ‘key’

/home/we/norns/lua/core/menu.lua:164: in function </home/we/norns/lua/core/menu.lua:141>

script clear

Change the directory from meadowphysics_norns to to meadowphysics

There are hardcoded references to this directory name in the script and it won’t work properly if it’s different.

Also - for anyone running into similar problems after installing something with the Librarian app. Your first troubleshooting step should probably be deleting the thing you just installed and try to re-install it manually (i.e. not using Librarian)

1 Like

Cant see how reinstalling would help in that case. I think there are should be more strict scripts structure guidelines, so things just work without renaming folders or smth

unfortunately it seems like at least one big issue is Github adding text (branch name) to the repo name when downloaded as a ZIP.

There’s some overall issues with how lua handles paths (specifically with require and include) that are the root of the problem.

EDIT - Also - my suggestion to not use Librarian was meant to suggest by doing the install manually, the person might better understand what was happening in the install process and could then better troubleshoot the situation.

2 Likes

Thanks Okyeron - works now!

What is the difference between the threads:

it’s not stated very clearly; the top posts are terse and could use some work. my understanding was:

“help” means just that - something is not working and i need help getting it going.

“scripting” - sharing knowledge and tips about the lua environment, features.

2 Likes

I will make a list of major norns help line threads in the tutorial, I’m trying to disambiguate them. So

  • help, is for non-developers
  • scripting, is for developers

Am I getting that right?

3 Likes

seems reasonable to me

2 Likes

apologies, the norns support/discussion threads are really confusing.

norns is a device designed for coding and learning coding, so “developers” is a difficult word. i more interpret that as “people working on the infrastructure” and we have Norns: Development theoretically for that, though much talk is on github instead.

so there are maybe three groups: people working on the infrastructure, people writing scripts, and people that are playing others’ scripts (that hopefully will get into making their own scripts soon) :slight_smile:

  • Norns: scripting — this is for getting help with the scripting system in general… something you might be working on, issues with syntax or libraries
  • https://llllllll.co/c/library — issues with individual published scripts should be posted in that script’s thread
  • Norns: help — this is the catch-all for things that don’t fall into the above. ie problems with the menu system, maiden, file management, or hardware. (there are separate threads for problems with updating).
5 Likes

did you manage to get your norns working?
i’m in the same situation (except for me nothing shows up when i chose select in the menu) and updating to 190422 via serial didn’t solve anything, i still have the audio engine error and wifi unavailable.

Yes, I did. I followed the instructions that @tehn laid out below.

Then went and deleted the duplicate engine script (it was passerby, in my case).

I never resolved the WiFi issue, so I purchased a new nub and it worked fine.

thanks a lot!
i missed this one

1 Like

Reach out if it doesn’t work, I’ll gladly retrace my steps for you.