Norns: maiden

Yes this is a fine place to talk about a features, bugs, or anything maiden related.

cool, thx @ngwese! i’m really enjoying the whole norns ecosystem, but one thing i’m not aware of is how to tell when new scripts get added to the community section of ‘available’. right now i just look through at all the scripts i haven’t installed already and try and remember if i’ve tried them out or not, or if they look new.

also it i’m not sure how to know when a script i already have installed has one or more updates from what i have installed.

i’m not really a coder so i’m not sure if its appropriate to put out suggestions or feature requests for something that is free and very clearly a labor of love and passion.

thanks for your time!

Unfortunately at the moment there isn’t a way to tell what is new. The best indicator of newness or updates is actually the activity here on the forum.

The package/script/project manager isn’t terribly sophisticated. All maiden knows is that there are one or more catalog files that it can download which list the available scripts (one file per section on the available page). One thing which is definitely not captured right now is when (in calendar time) a script was added to the catalog - the absence of that information is the biggest reason why maiden can’t provide a view into what is new.

Knowing when there are script updates has similar challenges. A conscious decision was made back when the project manager was built to avoid requiring all the scripts be stored in a specific place and to avoid requiring authors to version their works. The idea was to allow script authors to share via any service/host they were comfortable with as long as the files were publicly downloadable. One consequence of that choice was that maiden doesn’t have much visibility into when things change. In practice I periodically hit the update all button (or one of the script specific update buttons) on the installed page.

I wouldn’t worry about that. Suggestions and feature requests are always welcome, they help to shape how parts of the system evolve and can serve as inspiration for people who want to get more deeply involved.


thank you for your kind and insightful words, and quick response @ngwese!

I’ve recently got a Norns Shield (from the Monome kit), which is all working great, and updated to the newest OS.

I can connect to Maiden fine, and install scripts. But after ‘refreshing’ available scripts, the most recent scripts don’t appear e.g. Kolor or Flora.

If anyone could shed any light on why this might be, that’d be great. Thanks

Welcome to the world of Norns. :slight_smile:
Not all scripts are available in Maiden but there is ways to place these manually, the top entry of Kolor has directions listed under “download”.
For Flora there is a download link and you could use Cyberduck but shouldn’t and do this instead, to copy the contents to the correct place (dust/data). Remember to get rid of the “-master” in the folder name.
For Flora entering this into maiden might also work ;install

1 Like

Thanks for getting back to me. Yes very exciting to have it, just overwhelmed with the options currently!

I realise you can download them seperately, and I did manage to get Flora working this way.
I was just trying to workout why these scripts weren’t appearing, as the creator of Flora told me that both these scripts should definitely be on Maiden, and I most likley have an issue my end. Just trrying to figure out what the issue may be.

Hm, I cannot check right now, but can you try a general update of your norns (system) first?
The thing is: Maiden should now automatically update (you used to have to press the update circles for community scripts before in Maiden) and then present you with a list of available scripts.

I did already update my norns to the newest version, but I will try it again.

Having looked at the main community file at norns-community/community.json at master · monome/norns-community · GitHub, it appears my list it not matching this up-to-date list.

Try in an incognito/private window, could be a cache issue ?


please— everyone— the much easier way of transferring files is via samba, as indicated in the docs. please stop suggesting SFTP/cyberduck, it’s a total pain in comparison (if you don’t already have cyberduck/etc, which most people don’t).

for script downloading, ;install absolutely the best way if something is not in the catalog, please let this be the only recommendation onwards.


Thanks. Tried that too. Plus tried on different computers. Feel like I’m missing something obvious.

Are you refreshing the right part of maiden? There’s both ‘base’ and ‘community’ that can be refeshed, see screenshot attached.

Ok, edited my post above.

Yes, tried refresh all. Then refreshed each parts separately.

I guess I might just reflash my SD card to see if that fix’s it.

Out of curiosity are trying outside of North America? It is a long shot but if the catalogs don’t seem to be updating there have been reports of difficulty accessing GitHub.

Can you download this file in a browser on your computer?

Just to double check Is the shield connected to your WiFi network directly? For downloads, updates, etc to work, norns needs to be directly connected to the network as opposed to running in hotspot mode.

Just tried to understand the issue and can confirm the same thing:
both scripts also do not show up in maiden for me.

I tried refreshing (all and each base community and again), my norns shield is up to date.
I emptied my cache and tried again, did a reset and tried again, no dice.
I have these scripts installed (manually).

@doomglue, @Comoving_Observer Sorry. This one is one me - it looks like the latest update included the change to switch the norns-community repository to use more inclusive branch names. The new main branch was out of date so flora and kolor where not included (fixed now).


Great. Nice one figuring it out so quickly!

I thought I was just making some fundamental error. All the scripts seem available now.


@DoS - can you provide more information and a screen shot? Which browser are you using? Do you have any browser extensions installed (like Greasemonkey) which “add” functionality to web sites?

Other than updating the version of the underlying editor component which maiden uses the styling hasn’t been modified in the latest update and I haven’t noted any changes in font size.

1 Like