Norns: maiden

excellent q!
no password, just knowledge of the hostname or IP, which is why we encourage changing the hostname from norns.local to a personally meaningful string :slight_smile:

1 Like

I see! I guess there is not a big chance the person in charge of the it in the building (which would be the only guy who could log into the router and check all connected devices hostnames) would do this, but it is always good to know these things.

Thanks for the quick answer @dan_derks ! Ordered my Shield yesterday and are looking forward to joining the Norns gang :slight_smile:

1 Like

fyi changing the password is now an option in the SYSTEM menu, no command line needed!

4 Likes

Hi all, a very simple question: what’s the best way to keep track of new scripts? I often just check in on the library for new posts, but it would be rad if on maiden there was a way to categorize but most recently added. I am missing anything?

2 Likes

I received a duplicate error message and for some reason deleted the We folder with all the core engines in it… it is not an option to download via Maiden. Please help!

we has been removed from the catalog because those “core engines” have been moved to the main norns repo in the latest update (which requires a new disk image.) having both will fail.

you can still install manually by entering into the REPL:
;install https://github.com/monome/we.git

do not do this if you are on the latest norns image.


you are not missing anything, maiden uses simple catalogs which do not include version/update tracking. the forum and norns.community are fine places to find things. since the catalogs include git URLs i suppose another tool / service could collect update history.

3 Likes

I wonder what would be the odds someone logging into my unprotected norns and making wicked beats and otherworldly pads on it… :thinking::thought_balloon:

PS One a less fabulist note vulnerable IoT devices is a growing security concern.

2 Likes

Haha yes this is actually a possibility! In my studio f.ex. we are lots of people sitting on the same network :stuck_out_tongue:

1 Like

Hey!

maiden has a “slight” scaling problem on my iPhone/Safari iOS 15.4 which makes it kinda unusable since there is no way to see the text.

there is no way to scroll to the left

also the as (or even more) important files tab is unusable sadly since the left side is so huge (I can drag it a bit to the left …but only 10px)

not possible to read anything from matron REPL

I like using my iPhone at times to quickly do stuff … so this is a problem. I’m not any good at CSS / HTML sadly.

Somew kind of filtering would be nice as well I was thinking – like “show me all grid-enabled synths sorted by date”

1 Like

Yes - This is a known shortcoming which has existed for the life of maiden. Since the initial focus of maiden was on writing scripts where a large screen and keyboard are particularly desirable, authoring on mobile devices was not on given any attention. The increasing presence of tablet with keyboards changes the calculus somewhat since there are aspects of the current ui that are not particularly touch friendly. The script catalog and support for installing things via maiden came some time later after the assumption of desktop browsers was fairly established.

Better support for mobile devices of all shapes and sizes would be a great opportunity for folks in the community with some web dev skills to jump in. Improvements like this would be genuinely welcome.

(on the catalog page) That is interesting behavior, I don’t know of anything specifically in the code which is trying to prevent that. Rotating the phone does make the script names readable but still not particularly pretty.

(on repl visibility) If one clicks/touches the script/page icon on the side bar it will toggle visibility of the file side bar. Hiding the listing and holding the phone in vertical orientation can make the repl minimally usable with the on screen keyboard displayed but it is not great.

Ultimately reaching a more usable state on a phone most likely requires some reimagining of how the interface could/should work.

2 Likes

Aight! Then I guess I use ssh terminal directly on my phone for this – I’m a bit sad that I don’t have the possibility to enter commands there. Would be a nice addon.

Time to learn coding :upside_down_face: a friend just showed me Astro Vim …love the UI – I hope this is what the future of Linux looks like for every cmd line app - check it out if you don’t know it! – and I could see myself having fun coding there (first time I’m not hating Vim because I keep forgetting how to use it).

That does exist. Nearly all of the functionality in the web editor is available via the maiden command. The maiden repl command does provide a way to enter commands - it is not polished but several of the devs use it at times.

1 Like

Anyone out there using Opera as their main browser? Since the new updates Maiden doesn’t want to display, though it works as normal in Chrome.

I just downloaded the latest version of Opera and did a quick test - nothing seems immediately off.

  • Have you tried flushing the browser cache?
  • Is it possible that there are extensions installed which block http (non-encrypted access)?
  • Which OS and browser version are using?
1 Like

Yes, pretty much all the time, and Maiden has been fine here since the update.

This is basically exactly what https://norns.community/ was made for! For example, here’s all grid-enabled synths, sorted by newest first: https://norns.community/t/grid/synths?sort=createdat&dir=desc

2 Likes

Thanks yes I did look at that. I just wish it would input all scripts instead of having to add tags. A one click and see all new scripts sort of thing.

you can order by “last modified”!

though, i guess we’d need an “all” sorting option

1 Like

clearing the cache did it, thanks!

Hello! I tried to see if this has been addressed before and couldn’t find anything, so I hope this isn’t a repeat question. I just received my norns shield in the mail today, and setup went fairly smoothly until I tried to install scripts via maiden. Every script I try returns an error of the following kind, using Otis as an example:

Installing project “otis” failed
install failed: Get “https://github.com/justmat/otis/info/refs?service=git-upload-pack”: x509: certificate has expired or is not yet valid: current time 2022-03-07T02:07:30Z is before 2022-03-15T00:00:00Z

I have no idea why the current time seems to be set three days from now. I live in Hawaii, so a time zone issue wouldn’t surprise me, but I don’t think that would cause an error this large. I’m connected to wifi, so the raspberry pi’s time and date should be updated, right? Am I missing something?