Norns: maiden

Yes, tried refresh all. Then refreshed each parts separately.

I guess I might just reflash my SD card to see if that fix’s it.

Out of curiosity are trying outside of North America? It is a long shot but if the catalogs don’t seem to be updating there have been reports of difficulty accessing GitHub.

Can you download this file in a browser on your computer?

Just to double check Is the shield connected to your WiFi network directly? For downloads, updates, etc to work, norns needs to be directly connected to the network as opposed to running in hotspot mode.

Just tried to understand the issue and can confirm the same thing:
both scripts also do not show up in maiden for me.

I tried refreshing (all and each base community and again), my norns shield is up to date.
I emptied my cache and tried again, did a reset and tried again, no dice.
I have these scripts installed (manually).

@doomglue, @Comoving_Observer Sorry. This one is one me - it looks like the latest update included the change to switch the norns-community repository to use more inclusive branch names. The new main branch was out of date so flora and kolor where not included (fixed now).

3 Likes

Great. Nice one figuring it out so quickly!

I thought I was just making some fundamental error. All the scripts seem available now.

3 Likes

@DoS - can you provide more information and a screen shot? Which browser are you using? Do you have any browser extensions installed (like Greasemonkey) which “add” functionality to web sites?

Other than updating the version of the underlying editor component which maiden uses the styling hasn’t been modified in the latest update and I haven’t noted any changes in font size.

1 Like

I don’t have any extensions like that - see below for a screenshot and more details.

Right - I should have thought it probably wouldn’t be the same across every browser; but a quick check with Chromium, Firefox and Opera (the browser I use most), the font size seems quite a bit smaller than before - here’s Firefox, for example, on a screen with 1680 x 1050 resolution

It may of course be that a) I just got new varifocal glasses and everything seems smaller ; 2) I also recently had to switch to Linux Mint 19.3 from Manjaro 20, though on the same screens at the same resolutions, so I don’t think that would be the reason - and the font face change did happen immediately after updating the Norns Shield to the latest version.

Thanks for taking the time to look into this. Being able to make the font size for the code window larger would certainly be useful, given 1) above in particular, if it’s at all possible. Zooming in on the browser does work too though, so if it’s not possible at any point it’s liveable with for sure.

I just checked to make sure nothing changed between the previous maiden release and the current maiden release - a side by side comparison of version 1.0.2 and version 1.1.0 is identical (when using the same browser on the same OS).

The maiden style sheet does not specify a particular font, only monospace. One consequence of that is that it uses whatever font is set in the browser preferences as the default to use as monospace. The rendering of maiden that I get with Firefox on Debian 10 looks like your screen shot, the text in the editor and in the file tree is slightly smaller (12px) than text used in the “matron” and “supercollider” repl tabs (which is computing to 14.66px for some reason). On macOS using Chrome the editor and file tree renders with a 12px font but the text used repl tabs is getting computed as 13 px.

The main takeaway:

  • …there are rendering differences between the platforms (not surprising)
  • …the loose CSS specifications around the REPL can give the impression (particularly on Linux) that editor font is smaller than intended when it looks like the reverse is true (the REPL is rendering larger than intended).
  • …the rendering hasn’t changed in the latest maiden release. If there is very noticeable shift then there is a strong possibility that any changes to the browser, OS font selection, and/or browser settings could could be the source of the difference.

I’ve created a ticket for adding font size control:

1 Like

Thank you hugely for taking the time to research this @ngwese . It’s really appreciated. For now I will use the browser zoom on higher-resolution screens as that works OK.

this would be a great first issue for any of the web-smart programmers— i know you’re here!

Is there any thoughts on adding more contrast or adding a high contrast mode, particularly in the library section?

Had a bit of a “man, I’m getting old” moment last night installing flora and grds.

There are one or two tickets around finishing a dark mode and other theming type features but there isn’t any specific timetable attached to the work.

maiden could benefit from adopting a style sheet compiler - there are a fair amount of duplicated values across the CSS code. While it would be a decent chunk of work to add support for a new style or multiple styles I don’t think it would be too difficult for someone with the requisite CSS knowledge or a decent sense of curiosity. High impact, without getting to far into the weeds.

This too would be a great first project for anyone looking to contribute.

4 Likes

Is there a way to change the IP address and point the DNS on the norns? I’m guessing you would do that with maiden?

I’m having a weird issue and been trying to figure it out on my own but no luck.

Basically maiden community will not update and i can not find some apps like cheat codes 2

I also arrived in China last week so I’m guessing it’s a firewall issue and want to get it connected to my laptop sharing a vpn through a mobile hotspot.

The norns software is setup to use DHCP to acquire both an IP address and DNS - there aren’t any controls to set them directly other than manually configuring a network connection via ssh. I’m quite confident that in China the GFW will prevent connections to GitHub and elsewhere. The best strategy is the path you are on, using a laptop as a hotspot, connect norns to that hotspot, and then establish a VPN connection on the laptop to tunnel traffic.

Feel free to DM me and I can try and provide more specific suggestions.

1 Like

OK I got it! It wasn’t as easy as just turning on a vpn and turning on a mobile hotspot but it wasn’t hard either. The hotspot wasn’t going though the vpn. I could not find any tutorial online to route the hotspot through it but I figured it shouldn’t be any harder than patching a modular lol. So I’ve attached an image of what I did just incase anyone else has this problem.

Thank you Greg for confirming this would work! I have about 3 weeks left confined to a single hotel room for quarantine. Now I am looking forward to the space and time to myself!

3 Likes

just very quickly checking that git submodules are good to go in catalog scripts !

Using git submodules does work for the typical install flow and it is functionality that I’m actively using in my own scripts.

It wasn’t an intentional feature (it just happened to be handled by default in the git library used in the maiden backend) so if any weirdness is observed please drop a note here or open an issue on GH

1 Like

Hi Everyone,

I am new to Norns and Maiden, and had a quick question. With the help of everyone on the alternative grids forum (Norns: alternative grids - #258 by bharris22), I have successfully set up a couple of Launchpads to use as 64 and 128 grid systems. Some apps, like Arcologies and Buoys, can be used with either a 64 grid or 128 grid system, depending upon which midigrid library you have it load. I would like to save two versions of each of these apps, one that loads the 64 grid, and an identical one that loads the 128 grid. How can I duplicate a folder under Code in Maiden so that I can make this small change, and then save the new library under a different name (for example, I would like to have Arcologies_128 and Arcologies_64 as two separate apps for loading within Norns).

Thanks in advance for your assistance!

The file management in maiden is pretty basic so making complete copies of a file tree isn’t as straightforward as it could be, two options that come to mind:

  • Mount the dust folder on your mac/pc and duplicate the files as you wish - see wifi + files - docs
  • Select the arcologies folder in maiden, click the rename (pencil) button at the top of the file tree, rename the folder to arcologies_64, then reinstall arcologies from the project manager.
1 Like

Thank you very much!!