Norns: maiden

Hi all.

My Norns fails to connect to Maiden - a new issue just from today. The device is connected to the internet (it updated just fine) but when connecting via a browser to the IP address the request times out.

Any advice here? I’ve done all the usual restarting etc.

hey hey! hope all’s well otherwise :slight_smile:

  • have you tried clearing cache as well?
  • have you tried other browsers? any difference?
  • norns.local giving the same trouble?
  • are you able to connect to norns through either smb or ssh? (just confirm whether your norns is reachable over your network)

I’ve tried 2 browsers and my phone. Can I clear cache on the norns do you mean?
norns.local has never worked for me to connect to the norns unfortunately.
I’ll try connecting via an FTP but i wonder if that will resolve the issue?
I wonder if I should reflash the card?

1 Like

Just to verify, the IP address you are using to connect to maiden is the IP address that is reported on the norms display? I ask because most folks (myself included) have IP addresses assigned dynamically by the wifi base station so it is not necessarily the same each time the device is turned on.

Another possible thing to verify is if the device is running low on space. It is possible that an update ran out of space while being installed. If memory serves maiden is dealt with towards the end of the update script. Freeing space and forcing the update to be reapplied might be an easier first step than reflagging the whole device.

Thanks for your input. It randomly started working after a full day of failing! I wonder if my PSU is giving enough power as I have plenty of buggy, restarty issues. :man_shrugging:

i’ve seen you mention those, yeah!

best advice:

here’s the PSU we recommend, which meets these criteria: 5V 2.5A Switching Power Supply with 20AWG MicroUSB Cable ID: 1995 - $7.50 : Adafruit Industries, Unique & fun DIY electronics and kits

the Pi3B has a micro-USB power port and requires at least 2A and 5.25V ideally supplied through a cable with 24AWG or less. lower AWG = lower noise & more stable voltage delivery for better performance. most consumer USB cables do not meet this spec, so please be sure to keep an eye out.

I’ll get my gear in order before posting any more troubles I’m having! :slight_smile:

1 Like

no worries! i’m really glad you’re asking! it helps to centralize the info — much rather see questions early on than after hours of troubleshooting :slight_smile:

1 Like

I’m having the same problem as Dan above, google chrome refuses to connect to norns.local and it’s IP address. As windows 10 refused me access to dust, I’m currently using cyberduck to interface my PC with norns , is there any way to access maiden through that?

When using cyberduck, are you using norns.local as the host name? My experience with Windows is limited but during testing I struggled to get a norns.local to work and often had to type in the IP address of norns to connect.

Does it work if you explicitly use http://ip_address_of_your_norns/

Cyberduck has no problem connecting to norns. I have tried to use my IP address in browser to connect directly but to no avail. Is there anyway to access maiden with cyberduck?

I can usually access maiden in Chrome with just ip_address_of_my_norns/maiden/

1 Like

I’m in! Thank you so much <3

1 Like

Woohoo! Now the fun starts… or is it: trouble begins?!

Fwiw, if I want to get into the Shield using File Explorer (eg. for moving audio files/samples around) then \\ip_address_of_my_norns generally works…

for what it’s worth, i’m able to resolve norns.local in chrome on win10.

i don’t recall having to do anything special to enable zeroconf or anything like that…

I seem to remember that some previous versions of Windows did not have zeroconf installed by default? (Could be wrong tho)

I just got my norns (shield) and I really, really like it so far!
I have some annoying issues with maiden on my iPad (my iPad Pro is my “main” computer).
See my screen recording:

It’s like some kind of focus that sometimes forces the page to zoom to different areas.
Is this a known issue?

That does look like strange behavior and I believe this is the first report of behavior like that I’ve seen. I just did a quick test on an iPad running iOS 14.5.1 and couldn’t reproduce the behavior in the video.

The only person I’m aware of who is (or was) actively using maiden via a mobile device/browser was @xmacex.

More details about your setup would help:

  • Do you have a keyboard, trackpad attached to your iPad?
  • Are any of the Accessibility options like Zoom or Magnifier turned on in Prefereneces?
  • Which version of iOS are you running?

(DM me if you’d rather not detail it here)

I’m running 14.6 with a keyboard and trackpad connected.
I think the problem might be that there is a bar at the bottom that appears when the focus shifts to a text field etc. The bar at the bottom appears instead of the software keyboard when a hardware keyboard is connected.
No accessibility settings active.

That sounds plausible. I don’t have a physical keyboard to test with (or maybe I can just plug in an external USB one :thinking:)

I do find it odd that the small bar problematic while the much larger soft keyboard is not. Will have to do some research.