Norns: maiden

norns

#61

not sure there’s a way to stop mac os from creating them (iirc they have to do with storing filesystem metadata in the absence of a partition supporting extended file attributes). as @okyeron mentioned, there’s an issue open to filter them in maiden (https://github.com/monome/maiden/issues/110). maybe chime in over there too?


#62

@okyeron Actually I got it yesterday and I didn’t notice it was not updated yet. Thanks for the heads-up!
@ppqq I will! Thanks! (not sure about the appropriate behavior on GitHub though)


#63

Is there a way to access the docs in dust/docs from maiden?


#64

I think it’s just norns.local/doc, eh? (or whatever ip address norns has, in place of norns.local)


#65

thanks! but, I know about those docs. I am talking about the markdown docs at dust/docs…

these guys


#66

doh! I spoke too fast! But now I know about more docs than I used to. Thanks!


#67

Here’s a stupid solution:

cd ~/norns/doc
ln -s ~/dust/docs

then http://norns.local/doc/docs/index.md

A better solution would be to add a sidebar panel in maiden which has the dust docs linked. But - I’m not sure if there’s an easy md- -> html converter that could be used (maybe http://showdownjs.com)?


#68

i love the idea of an inline doc viewer. interesting idea to use JS for conversion too. i’d been imagining lua but doing it in the client has some interesting possibilities. anyway, there’s a related issue over on GH…

feel free to chime in if you want! :+1:


#69

ok this is driving me nuts - does maiden cache the files somewhere?

updated a file on disk - still can see the old version in maiden - restarted browser, restarted maiden , restarted norns - can still see the old version of that file (I’m ssh’d in and can see the the version on disk in dust is the new version and different from what I see in maiden)

What am I doing wrong???

edit - this utterly doing my head in - if I rename the file on disk I can see the new content, if I rename it back old content. I’ve deleted anything that looks like a cache in my local dir - can’t see anything in the usual places - /var or /opt.

started digging in the code for gin which is the web service…

oh FFS - tried with chrome and CAN see the new content - it’s caching it somewhere in the react app.

“Empty caches” on the develop menu solved it!


#70

maiden is not immediately aware of changes made on the device via ssh, sftp, USB sync etc.

The first time a file clicked in maiden's browser the contents of that file is loaded into an edit buffer in the web browser. At the moment there aren’t any controls to refresh files on a file by file basis but that could be added. The heavy mallet is refreshing the entire browser window which effectively throws away anything in the edit buffers.

Expanding directories in the file browser is more forgiving - each time the directory is expanded (with the little triangle) it is re-read so seeing changes to the directories does not require refreshing the entire browser window.

Which browser are you using? Any of the above should have worked since they all are more substantial than simply refreshing the browser window.

I believe most of the folks that have been involved with the development/testing of maiden thus far use Chrome. Some amount of testing has been done with Safari, Firefox, and Opera.

Outside of the edit buffers for files maiden isn’t explicitly doing any for of caching.


One thing which might be worth us verifying on the development end of things is whether or not the HTTP server being used is setting ETags which tell a browser how long is it valid to cache data client side.

UPDATE: I’ve confirmed that the HTTP responses don’t contain ETag data and that Last-Modified headers are correctly returning the modification time of the underlying file so and browser level caching should be working correctly.



#71

In safari. (edit now I’m not on my phone) - yeah only tested Safari but it would not go away - forced reload, restart browser - basically only the developer tool empty cache (once I’d worked out browser/react caching was the issue).

I’ll test a bit more tomorrow and see if I can replicate and confirm that chrome doesn’t work the same way.

Are you intending to support Safari? - At work our product is pretty much Chrome only because of this kind of thing. It’s easier that way :wink:


#72

Is anyone using a Windows PC for maiden/matron? I can edit scripts in Maiden but cannot run them or do Matron command line stuff - I always have a “not connected to matron” message on any windows browser I try - Firefox Edge and Chrome. Refresh doesn’t help.
But I can do Matron command line stuff from Safari on my iPad. Do I have to get a Mac to code on Norns with a normal experience?


#73

When you access maiden are you connected via wifi/router or hotspot? Does using http://norns.local/ (on the PC) work or do you have to use the IP address of the device (as shown in the SYSTEM > WIFI menu) to connect?

maiden was tested prior to release back in June using Chrome/Firefox on a Windows 10 VM.


#74

Thanks. I’ve tried all the permutations. Wifi and Hotspot. The local name and the IP. Maiden works. It’s the Matron window that refuses to connect. I can connect on iPad and Safari tho. I’m sure as usual I’m missing something obvious :slightly_frowning_face:


#75

Sorry - forgot to ask. Which version of Windows are you using, which browser, and what version of the browser.

Does the Windows machine have a firewall turned on which prevents outgoing network connections on non-standard port numbers?

The way the command line connection stuff works is a little unusual. It looks at the location where maiden was loaded from and then it tries to contact matron/crone via websockets on specific ports…


#76

Windows 10, and all browser versions are current. But might have a sw firewall blocking ports. In fact that would be totally be like me! Do you know which ports it’s trying to hit?
At any rate I’ll take a look when I get home - thanks so much for the lead, it sounds like a good one.


#77

By default maiden is trying to connect back to the device on ports 5555 (for matron) and 5556 (for crone / supercollider).


#78

So this was weird. Tried everything without changing anything: same result.
Turned off windows defender firewall and tried. Chrome worked for matron/sc, edge and firefox did not.
Turned Firewall back on. Chrome still worked. Ok… Restarted Surface and Norms just in case. Chrome still worked. So not sure what to make of that.
Did a complete reinstall of Firefox, and now it’s also working with the firewall on. Edge still won’t connect to matron/sc.

Anyhow I’m set even though I don’t have the warm fuzzy feeling of fixing it since it’s not really making sense.

Thanks for you help - I’m good now regardless!


#79

quick question: how much work is it to customize maiden’s keyboard shortcuts?

context:
my laptop is doubling the size of my gear corner, which is actually just “half of my dinner table”. if i were able to just use my ipad + bluetooth keyboard to use maiden i could reclaim enough space to seat a third person.

it totally works except for two things:
1-text scrolling/highlighting doesn’t work as it would in other websites
2-ios stupidly has non customizable keybindings for bluetooth, one of which is cmd+p for print.

i can work around 1, but 2 drives me crazy enough to give up.

so i’m poking around the git at work and i found this:

would modifying the keybindings to this on my local norns help me resolve issue 2?

i don’t want to take away any bandwidth away from any of the other backend issues with norns, just looking to see if this is as simple as changing this file or if i’m looking at learning how develope for the web to be able to conceptualize the changes i want to make?