Norns: maiden

norns

#81

I too run into this fairly often and have found that refreshing the browser seems to fix it.


#82

The primary browsers which were tested during development were:

  • Chrome (macOS, Windows 10, Linux)
  • Firefox Quantum (macOS, Windows 10)
  • Safari (macOS)

There have been various references to file rename operations not working here on lines, enough that a GH issue was opened up: https://github.com/monome/maiden/issues/127. Until that issue gets addressed the best bet is to save the file and refresh the browser window.


#83

If I happen to generate 3 or 4 untitled .lua scripts and need to do a refresh I often lose them.


#84

Did you either save the untitled scripts or ran them (which also saves them)?


#85

Doh! that’s it :disappointed_relieved::disappointed_relieved: thanks!


#86

I just started using Coda. Local/remote fie management is indeed a breeze.

Question though: I can’t seem to get the remote path set quite right. The remote pane always opens to the /home/we/ directory.

I’ve tried various combinations of the following:

/home/we/dust
/home/we/dust/
/dust
/dust/

In all cases it opens to the /home/we/ directory and Lua scripts I upload always end up in /home/we/ .

I’m sure I have configured it incorrectly. Any cure?

Thanks.

BTW: I was using IntelliJ’s PHPStorm (used it in a past life). Worked fine, but I could not get the code highlighting settled. Also tried Visual Studio Code, but could not get SFTP configured. Lovely code highlighting though.

Coda seems to have it all for norns script dev.


#87

As we transitioned into 2.0 I suddenly felt very out of my league and backed up out of the room while the adults figured out the adult problems.

This was the face I was making --> :grimacing:

That said, I’m only now realizing I’ve missed the giant beta 2.0 thread, so I have designs of taking the beta plunge tonight and I’ll report back asap!


#88

come in
the waters warm :blush:

same happened to me (for slightly different reasons)


#89

Aw! That makes me feel better. You were real busy in the beginning!

I had so many aspirations and so little skills, but I’ve at least skimmed EVERY single git commit to stay somewhat informed (and to further validate my decision to stay quiet and listen).

It certainly didn’t help that my lines visits started heading in the i2c/modular/er301 camp instead of norns.


#90

Wait for the new beta that should be ready for tomorrow, so you won’t have to pull the corrections since the start of the beta!


#91

is there a way to update maiden without rebuilding?


#92

get one of the releases and unzip it to your home folder (it should live in /home/we/maiden): https://github.com/monome/maiden/releases


#93

many thanks will do now


#94

Good looking out. Been lurking in the shadows this long… what’s a few more days?

:blush:


#95

FINALLY getting around to updating tonight.

For Coda 2 as my IDE, I’m just using /home/we/dust in the ‘site’ settings here:

Connecting with SFTP:

And here’s the slick ssh settings:

I’ve never had a ton of luck with the source control (git) stuff, but I’m more comfortable with the command line with git.


#96

Yes. Coda’s Terminal window makes it pretty convenient.


#97

Did you ever get it to resolve correctly to the appropriate root folder? My answer may have been overkill for your initial question. I just got excited to help!


#98

Thanks. Yes, got it all sorted. :metal: