Norns: mlr

I just updated my norns to 181008 and I’m still experiencing crashes with mlr. Sometimes it freezes completely, often freezing a short buffer of audio (like a held note) and other times one or both of the audio channels will cut out. All of this tends to happen within 15 minutes of reboot (wherein I’m going right to mlr and making music).

Tonight, I’ve had no more than two loops happening at once. I’m using the master reverb and compressor. The reverb, I dialed back to 3s instead of the 6s that I had started with, but crashes continue regardless.

I know there’s an error log that I could share, but I’m not sure where to find it. Let me know if there’s anything else I can share to help.

I’m not an expert in what’s going on, but I think this issue is flagged here and that there’s a lot of work going into looking at it.

Oh wow, thanks for the heads up. That’s helpful to see. And thanks to all those debugging and solution-finding.

update is coming together today.


@tehn is it possible to add buttons for stopping playback to the 2nd (cutting) grid page?


stop is ALT + (row)

check out the RECALL feature: Norns: update 181008

which allows you to make four custom buttons mapped to a feature you want (ie, stop) which will work on any page

ps… i’m about to change mlr to 4 mute groups (same as mlrv)


First time i open mlr since the last update and something isn’t working anymore in the clip page. Key2 doesn’t do anything and i receive that message matron:


/home/we/norns/lua/fileselect.lua:30: attempt to call a nil value (field ‘init’)

stack traceback:

/home/we/norns/lua/fileselect.lua:30: in function ‘fileselect.enter’

/home/we/dust/scripts/tehn/mlr.lua:778: in global ‘_key’

/home/we/dust/scripts/tehn/mlr.lua:302: in function ‘fileselect.key_restore’

/home/we/norns/lua/menu.lua:281: in function </home/we/norns/lua/menu.lua:258>

I tried with the last mlr version of the github and the same problem happens.

Other thing moving Enc3 doesn’t works anymore once i touch anything else. :neutral_face:

this sounds like you only updated to 181002. you need 181008. can you confirm this?

Yes, upgrading the firmware to last update fixed it (i inadvertently skipped 181008…).

just updated to the newest. mlr is stable but i found that you can’t record into a buffer if you set it to “follow”. it causes loud clicks and harsh aliasing.

@kin.sventa you mean “tempo following”? this is really just playback at a modulated rate. recording with rate !=1 is pretty broken and is a known issue. i don’t think this has changed in the update. it’s also on my list of things to fix ASAP (sorry)


yes i meant tempo following. good to know, thank you for all your hard work. had a really great session with mlr today. had it running for hours with no problem.


omg fuck yes mute groups!!!
i performed with this for years and it’s fun as hell.


mute groups didn’t make it into the last update but i’m most of the way there implementing it.


Looking for some instructions to connect touchosc like ports etc… ? Thanks

you can find the IP address of norns box in the system > wifi menu, osc input port is 10111 (in touchosc set port (outgoing) to 10111). touchosc should also detect norns under “found hosts”, but this might not always work.


The Base32 conversion of 10111 is N. :exploding_head:


Thanks, which layout should I load on touchosc?

Layouts bundled with touchosc will not work out of the box. You either have to create a layout targeted to a specific script or adapt a script to accept OSC events coming from a particular layout.

1 Like

What’s the max rec time per track ?