Norns: mlr

norns
#202

the voices are mono, by default L+R inputs are summed for each voice but you can easily change the per-voice input mix in the script.

for 2.0 i am experimenting with a couple different methods for syncing voices and handling stereo files in the engine. (UI options in the MLR script are another matter.) also i think there will be 2 large buffers instead of 1.

which is to say, one way or another you should be able to use pairs of voices as stereo pairs, for live recording and/or buffer playback.

15 Likes

#203

Hey that’s great, thanks for the update/insight :slight_smile:

1 Like

#204

Hi, new here and experiencing some feedback issues while learning the layout of mlr. I’m able to do a few cuts and splices but the deeper I get into arranging patterns I get a really harsh white noise and feedback. Just running a quiet piano loop from op 1 into mlr. Any ideas as to how to prevent this?

0 Likes

#205

Is this from mlr on norns? I also got very harsh, loud noise the last time I attempted use.

1 Like

#206

It is from Norns…

0 Likes

#207

Do you have the norns reverb turned on? Have you tried it with the reverb off?

0 Likes

#208

Reverb is off. It’s only in clip mode. When I press keys on the top center row the sequence gets really loud and feeds back.

0 Likes

#209

are you feeding the norns through a mixer / effects that might be causing the issue?

0 Likes

#210

No effects. Going straight into abelton.

2 Likes

#211

Have you tried reseting the audio? I’m not sure that I’ve had these precise symptoms, but if it’s ever misbehaving resetting the audio fixes it for me.

0 Likes

#212

I have. Gonna let it sleep and come back to it.

1 Like

#213

can you describe more precisely what’s connected and then the process to replicate the loud noise?

certainly the reverb needs to be off— this is a know CPU overutilization issue that is fixed in the new update).

0 Likes

#214

Me too - 20 chrs……

0 Likes

#215

I have an OP-1 running a sequence of sampled piano notes into Norns which is running MLR and being controlled by Grid. While running the sequence I’m making cuts on the cuts page and switching back the the first page (playback page). When I make keys presses on the section to the left of tempo control I get a high frequency and or feedback. I’m actually not sure what this particular parameter section is doing or supposed to be doing…( reverse?) but as I said it’s not doing anything except creating this feedback. The same thing happens in the pattern page. I can load clips but once I get to about clip 9 or 10 (far right top row on grids in pattern mode) the same feedback occurs. I’m still getting a feel for the layout of MLR on grids. I’m wondering is it possible I’m playing back on a channel that is also recording when layering clips? Also all internal effects from Norns are disabled and I’m running direct via hi-z input into an Apollo Twin MKII with abelton as DAW.

0 Likes

#216

I really need to try this out on my 64 next week.

0 Likes

#217

Hm. Getting some weird bugs when I try to run the mlr64.lua. Seems to have something to do with lua itself(or is this because I am running Maiden 0.12 on Norns 1.xx?).

error code:

# script init

### SCRIPT ERROR: init

/home/we/norns/lua/params/option.lua:17: bad argument #1 to 'pairs' (table expected, got nil)

stack traceback:

/home/we/norns/lua/norns.lua:179: in function </home/we/norns/lua/norns.lua:179>

[C]: in function 'pairs'

/home/we/norns/lua/params/option.lua:17: in function 'params/option.new'

/home/we/norns/lua/paramset.lua:96: in function 'paramset.add_option'

/home/we/dust/scripts/custom64/mlr64.lua:318: in function 'init'

/home/we/norns/lua/script.lua:70: in function 'script.init'

[C]: in function 'xpcall'

/home/we/norns/lua/norns.lua:180: in field 'try'

/home/we/norns/lua/engine.lua:85: in function </home/we/norns/lua/engine.lua:84>

READING PMAP
0 Likes

#218

@noiserock

looks to me like the gist is out of date, it’s using an function signature for param:add_option:
[ https://github.com/monome/norns/blame/44ebdb1f036fc8e71c133310107019f64c49bed5/lua/paramset.lua#L58 ]

vs
[ https://github.com/monome/dust/blob/master/scripts/tehn/mlr.lua#L341 ]

(i think this extra “id” vs “name” was added so that “name” can contain spaces, or something)

@pinkslater hard to understand exactly what is the matter but seems likely it’s one of several bugs in the 1.x softcut engine. for example, you could be recording with modulated rate which makes gross noises. this is fixed in 2.0

1 Like

#219

thanks. I got it semi-working with just updating the newest mlr code based on the changes @okyeron made. Still need to fine tune it, as the grid does not draw correctly based on button presses in the cut menu.
But at least it’s some progress :slight_smile:

Might also be worth waiting until 2.0 mlr is out and about.

mlr64.lua (20.6 KB)

0 Likes

#220

any update on potential stereo capabilities? my favorite thing to do with MLR is piano mangling, and summing my L-R mic pair to mono makes things sound not so great.

5 Likes

#221

I pray for stereo mlr too

4 Likes