Norns: mlr

norns

#101

So, I’m trying to figure out MLR, and I can make channels 1 & 2 work, but I can’t record to 3-6. I’m running 181008. Am I missing something?


#102

hm, one thing to check is the record levels per channel.
press the REC key (upper left corner) to see the record page
press a FOCUS key (2nd/3rd column) to select a channel on the current page
use encoders to change record / overdub levels for selected channel


#103

All same settings on all channels. I am recording tape playback… Is that maybe the problem? But I can’t record a clip of channels 1 & 2 playing.


#104

try restarting the script.

follow the exact same procedure for each channel:

  • set a loop point (in CUT)
  • start recording (in REC) then stop
  • proceed for each channel

you’re saying this works for the first two and not the others? what doesn’t work? audio just doesn’t get in the clip?


#105

Ok fresh start today. Seems to work if I use external audio coming into the Norns, but not if I try capture from the Norns Tape. I’m not getting any audio in the clip on channels 3-6 when trying to record from the Norns’ tape.


#106

you’re actually not supposed to be able to capture the tape output. this is a bug. i thought it was fixed with an aug 14 commit but you’re right, apparently not.

notice that you are only able to capture the output after loading MLR, then a different script, then MLR again.


#107

apologies, i still don’t understand what you’re trying to achieve.

currently norns tape isn’t designed to be routed as an input to mlr. you can load a TAPE file as a clip, but the tape output will not feed into the mlr input.

tape is designed for accompaniment playback, or recording of the output of a script.

or perhaps i’m still unclear about what you’re trying to achieve?


#108

Hahah well I guess I’m exploiting a bug then. I recorded something in Earthsea to TAPE and am trying to record clips from that recording in MLR. It worked for the first two channels so I assumed it was something I should be able to do. I guess I’ll have to look into loading TAPE as a clip. I didn’t see anywhere how I could accomplish that.


#109

can do this in the CLIPs page, like loading any other sample

closed the loophole


#110

thanks, will investigate tonight.


#111

I just updated my norns to 181008 and I’m still experiencing crashes with mlr. Sometimes it freezes completely, often freezing a short buffer of audio (like a held note) and other times one or both of the audio channels will cut out. All of this tends to happen within 15 minutes of reboot (wherein I’m going right to mlr and making music).

Tonight, I’ve had no more than two loops happening at once. I’m using the master reverb and compressor. The reverb, I dialed back to 3s instead of the 6s that I had started with, but crashes continue regardless.

I know there’s an error log that I could share, but I’m not sure where to find it. Let me know if there’s anything else I can share to help.


#112

I’m not an expert in what’s going on, but I think this issue is flagged here and that there’s a lot of work going into looking at it.


#113

Oh wow, thanks for the heads up. That’s helpful to see. And thanks to all those debugging and solution-finding.


#114

update is coming together today.


#115

@tehn is it possible to add buttons for stopping playback to the 2nd (cutting) grid page?


#116

stop is ALT + (row)

check out the RECALL feature: Norns: update 181008

which allows you to make four custom buttons mapped to a feature you want (ie, stop) which will work on any page


ps… i’m about to change mlr to 4 mute groups (same as mlrv)


#117

First time i open mlr since the last update and something isn’t working anymore in the clip page. Key2 doesn’t do anything and i receive that message matron:

lua:

/home/we/norns/lua/fileselect.lua:30: attempt to call a nil value (field ‘init’)

stack traceback:

/home/we/norns/lua/fileselect.lua:30: in function ‘fileselect.enter’

/home/we/dust/scripts/tehn/mlr.lua:778: in global ‘_key’

/home/we/dust/scripts/tehn/mlr.lua:302: in function ‘fileselect.key_restore’

/home/we/norns/lua/menu.lua:281: in function </home/we/norns/lua/menu.lua:258>

I tried with the last mlr version of the github and the same problem happens.

Other thing moving Enc3 doesn’t works anymore once i touch anything else. :neutral_face:


#118

this sounds like you only updated to 181002. you need 181008. can you confirm this?


#119

Yes, upgrading the firmware to last update fixed it (i inadvertently skipped 181008…).


#120

just updated to the newest. mlr is stable but i found that you can’t record into a buffer if you set it to “follow”. it causes loud clicks and harsh aliasing.