Norns: mlr

norns

#121

@kin.sventa you mean “tempo following”? this is really just playback at a modulated rate. recording with rate !=1 is pretty broken and is a known issue. i don’t think this has changed in the update. it’s also on my list of things to fix ASAP (sorry)


#122

yes i meant tempo following. good to know, thank you for all your hard work. had a really great session with mlr today. had it running for hours with no problem.


#123

omg fuck yes mute groups!!!
i performed with this for years and it’s fun as hell.
yes.


#124

mute groups didn’t make it into the last update but i’m most of the way there implementing it.


#125

Looking for some instructions to connect touchosc like ports etc… ? Thanks


#126

you can find the IP address of norns box in the system > wifi menu, osc input port is 10111 (in touchosc set port (outgoing) to 10111). touchosc should also detect norns under “found hosts”, but this might not always work.


#127

The Base32 conversion of 10111 is N. :exploding_head:


#128

Thanks, which layout should I load on touchosc?


#129

Layouts bundled with touchosc will not work out of the box. You either have to create a layout targeted to a specific script or adapt a script to accept OSC events coming from a particular layout.


#130

What’s the max rec time per track ?


#131

i’ve increased it to two minutes per track.

the buffer sizing is pretty opaque in the current version. i’d like to implement a start/stop rec then autosize buffer function (like any normal looper).


#132

how do I achieve this time? So far I’ve managed to record max 40 secs at the lowest speed, 16 steps full cycle.


#133

preparing the update today, which includes several other fixes


#134

Went digging around for an answer but…no luck…so apologies if I’m pushing the dead horse into a meat grinder.
:stuck_out_tongue:

Was working with mlr in norns last night and was trying to get MIDI sync happening.
I saw somewhere at some point that it only SENDS MIDI sync so I tried working with that.
Nothing would start to play either sending through an iConnect box or directly into a BeatStep Pro.
Also…what is supposed to send a PLAY command from norns to start everybody anyhow?

By the way…the AWAKE program is AWESOME when it comes to slaving the norns to sync. That thing is locked on like a mother fracker. I even sent drifting MIDI clock from my E-RM MULTICLOCK box and it NEVER lost time.

Whatever is going on there needs to be implemented in mlr if possible!
:grinning::boom:


#135

It appears that awake uses the beatclock library while mlr does not.

mlr would need some hacking to get beatclock implemented.


#136

so…other than that…does mlr send clock?


#137

It looks like it should send clock when midi_sync is enabled in parameters. Trying to test that right now, but I can’t seem to make mlr go at the moment :expressionless:

EDIT - yes it sends clock when midi_sync is enabled. changing the bpm in parameters makes my TR-09 change tempo.


#138

hmm…ok.
THANKS for testing!
How are you getting the clock out of norns into your TR-09?
via USB or some sort of convertor?
oh yeah…what OS are you using on norns?
forgot one more…what are you hitting in mlr to send a play command? Is it just by activating a track?


#139

USBmidi.

Newest version 181101 - so mlr has had an update here I think.

I get clock from mlr as soon as I enable midi_sync in the parameters. In my current case, it is sending clock while mlr is not playing.

FWIW - I don’t think it’s sending a MIDI start command at any point.


#140

Ran the update.
Thank you @tehn! (It worked off of the USB just perfectly but I think you need to tell peeps to REMOVE the USB after putting it to sleep…it wouldn’t run the update if it’s still attached)
:slight_smile:

Anyhow…
mlr is still not sending clock to the Arturia BeatStep Pro over USB.
At least as far as I can tell.

Trying something else now…just a min…



ok…my LXR drum machine is reactng to USB clock from mlr!
It receives a START message when MIDI clock is turned ON in the norns and the LXR will CONTINUE if I turn clock OFF and then back ON again. It does NOT send a restart. NEATO…but…looks like mlr still runs the grid at it’s own speed.

I even tried figuring out the BPM on the grid by watching the CUT page leds and it’s around 120bpm…oh fracken hell…just made a perfect 2 bar loop with that!

Now I’m able to layer rhythmic motifs that were playing at different speeds while monitoring the LXR through the norns and THAT is starting to sound evil!

So I think the next thing would be to have mlr slave to it’s own clock or am I missing something?
:stuck_out_tongue: