norns: new image 220306

Aaaaand you’re right! Retrospectively, I totally misread my board number, and that should be crazy embarrassing except I’m too excited to see it up and running. Thanks so much!

1 Like

Great news! Glad you got it up and running. Enjoy!

1 Like

Did you expand the disk? These instructions are from shield but should apply to stock Norns:

that seems about right.

the norns samba configuration is set to serve the contents of /home/we/dust (where scripts and user data live,) but there is a lot more on the norns filesystem (e.g. the entire linux OS.)

i don’t think expanding the filesystem will net you much if anything on a 4gb disk, but it won’t hurt either.

Thanks, @jonny and @zebra. I went ahead with expanding the filesystem and had no change in storage availability on the 4 GB CM3+. Just noting that here in case any others come through with a similar question

3 Likes

It’s bizzare, I try to run an update (it says it’s available), then it throws this out


new script

checking for update
releases = {
  stable = {
    version="220306",
    url="https://github.com/monome/norns/releases/download/v2.7.0/norns220306.tgz",
    sha="https://github.com/monome/norns/releases/download/v2.7.0/norns220306.sha256"
  },
  beta = {
    version="220321",
    url="https://github.com/monome/norns/releases/download/v2.7.1/norns220321.tgz",
    sha="https://github.com/monome/norns/releases/download/v2.7.1/norns220321.sha256"
  }
}
# script clear
shutting down audio...
clearing old updates...
starting download...
> wget -T 180 -q -P /home/we/update/ https://github.com/monome/norns/releases/download/v2.7.0/norns220306.tgz https://github.com/monome/norns/releases/download/v2.7.0/norns220306.sha256
checksum validation...
sha256sum: 
'/home/we/update/*.sha256'
: No such file or directory
update failed.

you need to flash the new image for version 2.7.0. this is a flul disk wipe. details and installation instructions are in the forum post.

the beta update you’re seeing in the menu is for the (as-yet-unannounced) v2.7.1 hotfix. you need to run the 229306 update first, which requires downloading the image and re-flashing your disk; it can’t be done from the norns menu.

(the fact that the “stable” update is showing 220306 is a limitation of our update system, which doesn’t know that the 220306 release doesn’t actually contain an update script. this is an unusual circumstance though.)

2 Likes

Done, but after the first reboot the screen only says “jack fail.” What’s going on?

sorry to hear about the continued trouble!

most typically, this points to a version of the software being installed which your hardware does not support.

i’m going to migrate these posts to the update thread for further troubleshooting :sparkles:

@St0rMl0rD, it all depends on which version of the shield + which pi you have:

hardware version pi software version to download
211028 revision shield raspberry pi 3 norns220306-shield-pi3-cs4271.tgz
211028 revision shield raspberry pi 4 norns220306-shield-pi4-cs4271.tgz
pre-211028 shield raspberry pi 3 norns220306-shield-pi3-cs4270.tgz
pre-211028 shield raspberry pi 4 norns220306-shield-pi4-cs4270.tgz
machined aluminum norns (aka ‘standard’ norns) cm3 or cm3+ norns220306-standard.tgz
2 Likes

I have norns shield 191106 and 3.1 (I think, if that’s the number next to the logo on the raspberry pi)

rad, that’ll land you with this file https://github.com/monome/norns-image/releases/download/220306/norns220306-shield-pi3-cs4270.tgz !
please give it a quick reflash with this one and let us know if trouble persists!

Now it worked, thanks! Got the supercollider fail after the first restart, but not after the second, so all good (for) now. Thanks a ton!

3 Likes

After finally updating as well, I have a couple of documentation improvement suggestions:

  1. on https://monome.org/docs/norns/help/#fresh-install under “Shield”/4. it says “Advanced”, the entry is “Advanced Options”
  2. more important: for those using Etcher under Windows. My flashing failed multiple times, because the UAC (user account control) pop up interfered with it. You need to run Etcher as administrator so that doesn’t happen.
  3. on https://monome.org/docs/norns/shield/#flashing-microsd-card:
    a: I would replace “in lieu” with “instead of”, much simpler
    b: under 3. it says unzip, but this is not a traditional zip file, it is a tgz. I use 7zip on windows and this needed 2 steps, first to .tar and then to .img
  4. strangely enough my Windows10 did not include an ssh client (which it should have), so I used WSL/Ubuntu, but that didn’t find the bonjour name, so I had to use the IP address
2 Likes

ooooOOOooo weee…

just updated all three factory norns and a shield.

only thing that was a bump in the road was DUPLICATE ENGINES problem.

once those were cleared out…i ran into one more glitch…
if i sent a ;RESTART from maiden…after the duplicate warning…
it would display jack fail in the lower left hand corner.

and it would completely lock up.
had to use the white button of DOOM.
yikes!

however…if you use the norns menu and use SLEEP it doesn’t crash or display that error.

Weird, after turning it on again today I had the jack fail error again. I unplugged and replugged the power cable in, and it booted normally. What the heck :slight_smile:

Is this jack fair error issue going to be fixed in an update ?

same here. getting a jack fail with esi midimate plugged in. norns shield 191106, pi 3b+

Jack fail on shield here too. PCB Version just before the latest board running a pi 3b+. Right after a fresh image install.

everyone, please post details. it’s likely these are not all the same problem and it’s hard to debug without more context.

  • is the fail consistent? how often does it happen? what are the conditions?
  • is it failing only with external USB devices, or always?
  • did it ever work? (ie, with previous image, or with same image? are you 100% certain you installed the right image?)
2 Likes

I have 2 USB devices connected to mine, fail was random at startup, used the shield pi3 cs 4270 version. Did not try without the USB devices connected yet. Previous images worked fine.