norns: new image 220306

Not to be snarky, but have you

Add correct host key in /Users/alexvillanueva1920/.ssh/known_hosts to get rid of this message.

?

You should just need to copy the key (SHA256:zj/HDDTQUHLUkO7ftaU6f44l/e9E9m64qDXa/3R4X9w.) to the specified file.

edit: The person I was responding to deleted their message. But for future travelers, this was the “HOST KEY VERIFICATION FAILED” error.

2 Likes

The last time I used etcher on my standard norns I had to try five different USB cables until I found one that worked (MBP 2014). I find this “pickyness” of norns to be quite strange, as all of these cables worked with my other USB devices. Anyway, I marked the one cable that worked with a sticker for future reference.

strange- im using the cable that shipped with the norns. ive now tried 2 computers too. to no avail. frustrating aftenroon.

remove first line of the /Users/alexvillanueva1920/.ssh/known_hosts file on your local computer (not norns).

basically, it sees a new device w/ same domain name as before and is not happy for security reasons.

EDIT: didn’t catch you got it fixed.

we’ve all found the rpiboot connection to be frustratingly fiddly esp with macs. just try flipping the disk mode switch. maybe a lot

2 Likes

just tried a second cable and flipping the switch a dozen times. same thing. still stuck on “initializing device” in etcher.

okay so… i dont actually use etcher so idk… (it has rpiboot built in or something>? strange)

this guide is closer to what i would do and may be worth a shot (esp if it seems to be etcher itself that is the trouble, as post below indicates is possible)

[ norns-image/readme-usbdisk.md at main · monome/norns-image · GitHub ]

(please be advised that this is deep in the weeds. in particular the macos isntructions assume you have a working development environment with homebrew/xcode/pkg-config and so on.)

1 Like

fwiw, i did the update with a 2021 mbp yesterday, using the stock norns cable. i had troubles at first, it would start and hang, or start and then stop immediately without actually doing anything. i ended up deleting and reinstalling etcher and it worked first try afterwords :man_shrugging:

1 Like

Anyone else having Wifi issues? My new Shield with Pi4 won’t connect to my wifi, stuck on “activating” status. I have a Shield with Pi3 that is connecting just fine to the Wifi. Any tips on how to resolve this issue?

SOLVED - turned off WPA3 on my EERO mesh router and it’s connecting just fine.

1 Like

got it finally! third macbook (my trusty 2013) was the charm i guess?

1 Like

i’d be curious to know the mac models / OS versions of the failed cases… (i’m wondering about a permissions issue with etcher/rpiboot)

this is always a pain, but forunately we don’t require this for updates very often

failures were with

2021 mbp / monterey
2020 mbp / big sur

both failed to display norns in disk utility/about this mac in addition to hanging up infinitely in etcher. i tried all usb ports on both computers and 3 usb adaptors + restarting the mbps and flicking the norns switch back and forth. very curious!

1 Like

sorry to spam the thread, but what about os version in the successful attempt?

late to the debug, apologies.

we flashed all the silvers directly via ubuntu to make sure the disk mode worked. i am sorry that macos is so unpredictable.

1 Like

mbp 2013 / el capitan

really this affair just reinforces my contention that’s all been downhill from 2013 for the mbp :wink:

oh one other thing possibly worth mentioning: the 2013 is the only option i had to not use a usb adaptor

2 Likes

I was successful with macOS Monterey (12.2.1)

1 Like

I use the official raspberry pi flasher and never had luck with etcher on my Mac mini 2018.

I updated successfully on the first attempt on a MBP 14" m1 running Monterey (12.2.1) and Etcher v1.7.7 using a USB-C/USB-A adapter. Strange it didn’t work for @hawksquill

edit: Norns standard using stock cable

thanks, i did not actually know this existed now.

it is called “raspberry pi imager” and can be downloaded here

2 Likes

Successfully updated my standard norns using my MBP 2014 running 10.14.6 / Mojave

norns doc website bug

When trying to connect to my WiFi after the installation, I noticed that the description how to connect to an existing WiFi differs from the video and norns’s reality. Not sure if this is the right place to post it, please move or let me know where to put it.

Description says:

  • enter the password (E2 toggles between top and bottom row, E3 scrolls character, K3 selects character)

But according to the video and norns’s reality the encoder numbers should be exchanged like so:

  • enter the password (E3 toggles between top and bottom row, E2 scrolls character, K3 selects character)

Which is still not completely clear in my book, as E2 and K3 do different things depending which row is highlighted. One could say:

  • enter the password. E3 toggles between the character selector and the controls at the bottom of the screen. When in the character selector, E2 scrolls character and K3 selects it. When in the controls row, E2 toggles what K3 does: deleting the last character with DEL (if you made a mistake) or submitting your password with OK (when complete).

Or it could be split up in single steps:

  • enter the password. E3 toggles between the character selector and the controls at the bottom of the screen. When in the character selector, E2 scrolls character and K3 selects it.
  • made a mistake? turn E3 to highlight the controls row, turn E2 to highlight DEL, and press K3 to delete the last character.
  • password complete? turn E3 to highlight the controls row, turn E2 to highlight OK, and press K3 to submit the password.

Both proposals would require removal of the line “select OK when complete”.

But ultimately I have to admit that I find it more natural to exchange the functionality of E2 and E3: As K3 selects character/function, E3 should scroll character/function. and E2 should toggle between character and function mode.

I guess I need to learn how to file a bug report.

Ah…I never get tired of hearing awake.