norns: new image 220306

Pressing K2 in norns’s home screen brings up battery usage and CPU load. Since norns 220306, there are three exclamation marks after the CPU load value, like
18% !!!
when pressing K2 for the first time in a script. The three exclamation marks slowly vanish after a few seconds. What does this and what do these mean?


they indicate that the audio system has recently detected the occurrence of xruns

this visual behavior might get some tweaks. as might whatever behaviors are regularly causing xruns when switching scripts/engines. (i have a pretty good notion.)

but the indicator is useful if, for example: you notice some audio glitches when running a script/engine, and want to know if it is due to CPU overload (in which case xruns are the typical symptom) or something else (algorithmic.)


Thanks much!

I just tried to load the acrostic script by @infinitedigits after I installed norns 220306. Whenever I load this script, I get an enormous loud, constant noise which does not go away until I restart (loading a different script does not fix it).

Please TURN DOWN YOUR SPEAKER and TAKE OFF HEADPHONES before trying to replicate this.

acrostic worked fine for me with norns 220129.
The CPU meter is at 44%, the exclamation marks vanish after a few seconds.
The noise is so loud that I wonder if the SafetyNet quark is no longer installed with norns 220306.

Please, can somebody try to confirm this while being careful?

1 Like

Yes, I’have experienced this as well.

1 Like

are you on factory norns?

does issuing softcut.clear_buffer() affect the noise? (i guess not)

did you install acrostic using the extra steps to switch to zack’s rec_once softcut branch?
(referered to near end of long initial post:)
[ acrostic ]

do you experience it with other softcut scripts? (otis, cheat codes, etc)

for the record, we’ve never installed or relied on SafetyNet, which offers no protection against most causes of audio glitches one is likely to experience on norns. (it is not a bad idea to install it if you are developing stuff in supercollider and need to be extra careful about volume/impulses/NaN/inf originating in your actual supercollider code)

1 Like

It’s the same on both shield(191106/rpi3) and factory norns.

Acrostic was installed through the maiden catalogue, so no extra steps.

I can test clearing the buffer and other scripts tomorrow.

1 Like

I have a factory norns and get this behaviour - clear_buffer doesn’t affect things

1 Like

factory norns here as well,
softcut.buffer_clear() didn’t help,
standard install of acrostic via maiden project manager.

Thanks for clearing my confusion reg. SafetyNet.

EDIT: The noise issue does not happen with Cheatcodes2 and Otis. But after having loaded first Cheatcodes2, then Otis, and finally awake again, the echo effect on awake is gone. Restart didn’t bring the echo back, softcut.reset ()didn’t help either. Need to go to bed now nevertheless. Looks like loading either Cheatcodes2 or Otis turned softcut’s input engine parameter completely down.

1 Like

oookay, i will see whats up.

(there have been no functional changes to softcut code. but there is a theory that will take some time to investigate.)

i suspect the thing with otis and awake is a different issue.

[ed] yes exactly, suspect changes made by otis are (incorrectly) propagated/saved at the system level; that would be a different problem and more related to lua system

1 Like

@wolfgangschaltung @ploubus @nattog when using acrostic are you hearing something akin to the noise at the end of the video in this link? if so, is it a noise that happens consistently whenever you start acrostic? or does only happen sometimes when you restart it (like in the video in that link)? what devices are plugged into the norns (if any)?

I’ve just loaded up acrostic on my 200323 shield with the newest image installed and could not get anything similar to what you describe and what is shown in that video. however I did get some large spikes when restarting the script, which never happened before:

(each spike corresponds to restarting acrostic).

however I pinpointed the problematic line of code and just pushed a fix for it just now. could you all try updating and see if you still get noise?


Hassle free update here, standard norns with upgraded compute module. I had to use a different usb-c dongle to the hub I was using to get the screen connection to work for expanding the filesystem. I’m running mac OS 12.2 on an Arm macbook air. (I do have most of the system integrity & security things turned off though).

Mainly wanted to say… PSA: don’t forget to backup your .ssh keys if you have any on norns and you don’t want to regen them.


I can confirm the issue with acrostic in Norns Shield/RPi3. The noise (really loud!) goes away after a while. I think it goes away after you start recording.

Sorry I replied before reading the post by @infinitedigits. Will try the fix and report back.

I can confirm though that the noise sounds exactly like in the video and that it occurs every time I start the script. There were 2 devices plugged into USB: a Novation Circuit and a Launchpad Mini.

1 Like

Yes the noise example sounds similar. It also happened consistently when starting acrostic.

However the update you pushed fixed it for me on the shield and factory norns. Thank you!

with nothing connected to standard norns except headphones,
I hear the same noise as at the end of the video you linked to.

I updated to the latest version via maiden project manager,
the 2 lines you changed did the trick for me: the noise is gone!

thank you very much for this very fast fix!

1 Like

Okay, I’m going in - see y’all on the other side…


Flash complete - 1 Successful target!


Hmm, I’ll be the judge of that, thank you very much.

Later edit: jack fail error after trying to install mx.samples via maiden.
No external devices connected, Norns Shield 200323
Unplugged (ouch, hate doing that), restarted, all seems fine…

[later still] Downloaded a handful of instruments to mx.samples and I think I’m going to leave it there for this evening. Will finish downloading/installing other scripts tomorrow.


Successful install here on a 210330 shield with a pi 3b. Thanks for the clear instructions!


After several days of following this thread intently (and somewhat panicked), I can report that the flash was a success on my 191106 shield using Etcher on a mid 2012 MacBook Pro running High Sierra. I only had a few modified scripts & midi mappings, so installing fresh scripts is not an issue. Only thing was I had to restart three times before my 128 grid was recognized. whew

Thanks so much for the detailed instructions, and all the bug reports along the way!!


Flash successful on standard Norns updated with CM3+ from MBP running macOS 12.2.1.

I get the !!! xrun warning from stock awake script after boot…
I also get the xrun after booting with “none” script running (happens after a crash-shutdown). Maybe it’s the “spooky” startup sound causing it?

there are a few xruns everytime a script is changed.

[ xruns on script change; parameter handling performance · Issue #1525 · monome/norns · GitHub ]

this isn’t new behavior, it just has a visual indicator now

… ah, there is a little bug in the indicator also.

it will indicate xruns if any have occured since the last time the stats screen was shown. (i dont know, maybe that’s a feature.)

will push the fix (?) or maybe turn this off entirely by default.

the menu display is really just to demonstrate the underlying API, which is new, and primarily itended for programmatic use.


Update went smoothly on my original Shield. I had to put the blank “reverse.txt” file in the /we/ folder to get the L/R channels working correctly. That aside, no problems at all.

1 Like