norns: new image 220306

Maybe it is helpful, I also thought that there was something not working anymore. However it turned out that I had changed the wifi password. If it is wrong there is no hint about it.

Definitely cable related quirks on macOS. Tried a few and eventually it worked so if you are having troubles with “initializing” on Compute Device in etcher then that was my solution.

1 Like

I never have issues with the official raspberry pi imager. I’d recommend people ditch balena etcher on Macs at least.

2 Likes

Updated without* problems on my factory norns / mac m1 !

*

had trouble with the screws on the back of the unit. all 4 were really tight and I wasn’t able to remove them with a screwdriver. after some frustration I got out the old black & decker (probably a bad idea folks!), and managed to remove 3. the last one however, i completely damaged with the drill. Luckily, I was still able to open the back cover and reach the switch. looking forward to new adventures little buddy (I’ll take better care of you) :heart:

3 Likes

You may be able to get it out with one of these. I stripped a Macbook Pro Screw and was able to get it out using a screw extractor tool.

4 Likes

I also have this - is this happening to everyone post update, or just a handful of us? I’m on the newly shipped Pi4+2022 shield combo. @barksten is this the same sound?

the startup sound is normal (and nice!) and has been there since the very first version.

the xrun report is a little misleading in this startup case, everything is fine.

7 Likes

Yeah. Except, it doesn’t stick on “activating”.
It proceeds to “activated”, but with no ip.
Not visible on the network either.
Alas, Babylon…

Did you scroll and choose add to add the network? Activated just means that the WiFi antenna is on, I think.

yes…

the behavior i was noting was during/after connecting.

I am going to hold my breath and try updating my 2020 Norns Shield this weekend. I have added Midigrid successfully (with the help of many people here) to numerous scripts. Based upon these instructions, am I correct that because I cannot copy and reinstall the “code” folder from dust following the update, I will need to reinstall all of the scripts I currently have and then add the Midigrid line of code back in to each script? Or, can I also copy the “code” folder from dust and then just paste the three folders back into dust following the update?

With the caveat that I haven’t yet tried all the scripts I had installed before the update, this is what I did and after a few false starts due to duplicate Supercollider engines (I think), the scripts I have tried so far seem to work OK now (and for now).

I did back up the pre-update micro SD card first though.

oh, excellent question!

copying the entire code folder to another computer is fine (and encouraged, alongside data and audio!) – it’s the blanket restoring of that entire code folder back to a freshly-flashed unit that’s cautioned against:

for the midigrid question, my path would be:

  • make sure your midigrid additions are built on the latest version of the scripts
  • copy existing dust folders (including code) to your computer
  • flash + boot norns
  • bring your data and audio folders back in
  • download fresh copies of the scripts you want on your device and run them so their dependencies (if any) are all installed
  • after you go through 'em, drop your midigrid-modified files back into those specific script folders, overwriting the script’s files where your changes were made

or, you could totally try as @DoS suggests and just be mindful of errors that pop up with each script – many will likely work with the blanket copy/paste, but some will have trouble. the errors that print to matron should be descriptive enough to sort out if something just needs a clean slate.

6 Likes

I’m fully expecting that there will be some scripts that might have problems, which I currently intend to re-install at that point and replace any existing midigrid tweaks if required as you suggest.

1 Like

Excellent - thank you both!!

1 Like

4 posts were merged into an existing topic: DIY: norns shield

had a somewhat painful 3.5 hours trying this on my stock norns(add 1 more hour to create this post, but then again the venting here actually turned out kinda fun)… some of it, though was fiddling with dongles going from the old usb to my newer 2021 MBP USB-3.1 ports… til i gave up and bust out an old MBP so i could just use the standard cable that shipped with my norns(didn’t realize the regular USB ports wouldn’t work for this, only the power-supply one; had to redownload the norns image and “baleen whale etcher flashing thingamagig” or whatev-t-f it’s called onto that older comp, too), finally got through it all(this older comp that finally worked running MacOS Monterey 12.2.1 and I DO find the baleen etcher thing pretty easy once it worked, btw… not to mention how beautiful baleen whales are… arighty then…)… so i just need to make a small :pinching_hand: request:

PLEASE don’t have us do this often for future updates(i’d rather not have to open up my norns frequently - and i was hoping to recycle this old comp and stick with just the newer USB connections…)

ALSO: i took the instructions quite literally so after reflashing, i’m glad that even though i tried running “SYSTEM>UPDATE” (as it reads here under step8:
https://monome.org/docs/norns/help/#fresh-install )
it simply told me it’s up-to-date(apparently that step8 not needed this time)…

BUT! then i tried step 9 and the hotspot password remains ‘nnnnnnnn’ no matter what. what am i doing wrong? (why does the universe hate me so much?)

so then i figured i’d check to see how to change the samba password anyways…
BY THE WAY, under that ‘change Samba password’ section where it says, “log in to the norns via [ssh] and execute:…”
the link for that [ssh] text leads here:
https://monome.org/docs/norns/wifi-files/#ssh
looping back to the same page… but i think it should link to the advanced section here instead:
https://monome.org/docs/norns/advanced-access/#ssh

unfortunately, though i’d figured out all that so far, because i’m on the older computer, i no longer remembered how to fix the error message which popped up for me in terminal when i DID finally try to connect via SSH, which read something to the point of:

“@@@@@@@@@@@@@@@@@@@@@@@@@@
@@ HEY RAJA THE RESIDENT DUMBASS! THIS ECDSA KEY AIN’T WHAT YA HAD BEFORE IN THE “known_hosts” file AND you set me for ‘strict EFFING checking’ BRUH! SO CONTACT YOUR ADMINISTRATOR… OH WAIT! THAT’S YOU! HAHAHAHA! LOOKS LIKE YOUR F_KD EITHER WAY! MUAHAHAHAHAHA!!!
@@@@@@@@@@@@@@@@@@@@@@@@@@”

i even saw the /Users/me/.ssh/known_hosts file (luckily had set this OS to reveal all normally hidden files)… but i didn’t understand “Offending ECDSA key in /Users/me/.ssh/known_hosts:2” …looking for that, was hoping to swap the two, but no! bad idea… can’t hack keys into other keys since it all looks like gibberish to me(also can’t remember how to disable strict checking) OH! I know: delete the known_hosts file altogether… HAHA: Living On The Edge! YES, that actually worked! so then it asked me if i’m sure if i want to go ahead without a verified key and i say ‘YES GO RIGHT AHEAD I DON’T CARE ABOUT ANYTHING ANYMORE’ at which point it prompted me to please type ‘yes’ or ‘no’ so i comply with ‘yes’ and then i get to the password part… OH! that’s the change in password i made earlier… so now i realize on this page:
https://monome.org/docs/norns/wifi-files/#ssh
where it says, under ‘via SYSTEM menu’ subsection:
“This will be the password you use to connect to your norns via SSH and hotspot.”
No! that’s not quite clear enough… it’s ONLY the password i use to connect via SSH, but NOT the hotspot password… so i’d recommend a change to that language there, too… stating something more like:

This will be the password you use to connect to your norns via SSH. ONLY. NOTHING ELSE. YOU CAN NEVER CHANGE YOUR HOTSPOT PASSWORD FROM ANYTHING BUT “nnnnnnnn” MUAHAHAHAHAHA!

… and that should be clear enough :stuck_out_tongue_winking_eye:

(ok then… no worries, i love you all, just hate human life on this planet in general… all this goddamned technology where everyone needs to always be THINKING THINKING THINKING THINKING… got no time for FEELING FEELING FEELING… i could go ON AND ON AND ON… oh wait, i HAVE gone ON AND ON AND ON AND ON AND ON AND ON… so sorry… it’s all good… and would it kill everyone who develops all these Norns apps to COMMENT THERE CODE A BIT MORE???.. oh sorry, slight tangents here, please don’t flag me… Discourse holds no recourse for the broken-hearted :broken_heart: by the way, since i’m on a rant-roll here, might as well mention, all y’all complaining about EPIC buying Bandcamp: F–K ALL that noise! Did you forget about the more important issue of the Ukraine right now?? (hey now: i’ve also bought a shit-ton of music on bandcamp from many folks here and very few of them seem to have bought the same amount in their collections… i think you’re all just as greedy as the people you berate… myself included, as i berate you here, too… now please excuse me while i go crave after money for the rest of my life same as i’ve always done) …one last thing: ‘berate’ is a strange word… but i think i like it as an MC name… yea yea, i think i’ll call myself “MC B-RATE” or maybe just “MC B-R8” whenever i begin my hiphop career…)

MUCH LOVE, ANYWAYS… I’M BASICALLY KIDDING ABOUT ALL THE RANTING, JUST VENTING IN MY OWN WAY HERE. OK THEN. sorry, left my boomer-capslock on; I’mma jus step away from all this for a few weeks now, gettin too old for this sh!t… SO YOU KIDS GET OFFA MY LAWN! :crazy_face: :older_man:
(oh, and in case i forget, i’ll just write it here in public, my new password for everything that does allow the change on my stock norns is now:
“OMFG@JustWorkAlready!!” :older_man: :crutch:)

BUT JUST TO BE CLEAR: It does work now, updated fully(and i even remembered to save the backup beforehand)… except for that hotspot password… but s’ok :person_shrugging:

:heart:

8 Likes

IIRC, we’ve only had to do this once (twice?) before, in 2018(/2019?), for a similar change in underlying hardware (CM3+). yes it totally sucks and i had to try at least 10 times to flash it from a usb-c macbook (for research purposes…)


we should add something to the docs for that error on macos after reflashing. i’d just go and delete the specific norns-related lines from ~/.ssh/known_hosts; nuking the whole file works too (but i guess it could have other consequences so would hesitate to generally recommend.)

3 Likes

oh, that reminds me, not as important, but i wonder also if step 7 was necessary this time?
step7 here for expanding file-storage:
https://monome.org/docs/norns/help/#fresh-install
is that an ongoing thing we’d have to do(i guess maybe so since some people will still have the older chip?)

:point_up: HA! ok, glad i wasn’t the only one :sweat_smile:
THANK YOU! :hugs: :heart:

2 Likes

yes, you want to expand the filesystem if your disk is bigger than the image (which i guess is build for CM3, so 4GB disk, so most people will need to, so its listed as a default step. wont hurt and will only take a couple seconds if it doesn;t need to do anything.)

not sure what you mean by “ongoing.” expanding the disk only necessary when preparing a new disk/sdcard. pi/shield users might want to do this frequently, but it’s a pain to do with the metal box, and almost never necessary (unless the filesystem has become really hosed for some reason.)

1 Like