norns: new image 220306

For those running into issues, I’m on an M1 Mac and was having a problem where Balena was hanging while initializing or crashing at around 3/4s of the way through.

Turned out it may have been my USB hub. I connected directly to my computer and the steps in the installation guide worked fine.


like many technophobes (a role i have come to embrace in the last year or so) i’ve been dreading this one. so in case i wasn’t the last one to run this update and you’re reading this looking for a sign…i ran into zero of the issues above.

my info:
—“standard” norns
—2019 macbook pro
—apple-made USB A to USB C adapter
—not the “standard” norns charger cable (zero recollection of which cable that was)
—balenaEtcher on macos 11.6.2

the process was exactly as described in the guide. my one issue was when i screwed the plate back on i didn’t immediately notice that i screwed it on upside down.

(if this wasn’t the case for you reader—sorry to gloat!)


Same boat here :slight_smile: Shield has been sitting in front of me for days, waiting for me to take it apart and get the SD card out :slight_smile:

I dont even have any files I care about losing :slight_smile:

EDIT: Doing it now… And its all good. First reboot gave me a supercollider fail. Second reboot and everything is working just fine. Excellent stuff.


Can any one confirm how much space the new disk image should be taking up?

I have a 2021 B-Stock Standard Norns with a 4 GB CM3+. I successfully installed the new image (norns220306-standard.tgz) but noticed when attempting to reconstitute my ‘audio’ folder that there was no longer sufficient space.

Pulling up the info for Dust, shows 1.35 GB of space remaining on the disk, and 2.2 GB used, though calculating the size of all three folders within dust comes out to only 24.4 MB.

Just want to see if that is normal and appreciate any insight into the discrepancy in sizes just for my own continued education.

If this is normal behavior, any insider info on getting a CM3+ 32 GB for a reasonable price is also greatly appreciated :sweat_smile:

Screen Shot 2022-03-21 at 11.23.33 PM

1 Like

Hi everybody, just setting up my v210330 shield on my raspberry pi 3b+ using the cs4271 from github and when powering on I am getting the error message jack fail. on the bottom left of the display. Doing a string search brought me to this thread but I noticed everybody was getting the jack fail. error when plugging devices into the usb ports which differs from my repro as I haven’t plugged in anything. Any help would be amazing!

Your shield PCB sounds like it’s one which uses the cs4270 codec, so you should use:
instead of the one which you’re using.

1 Like

Aaaaand you’re right! Retrospectively, I totally misread my board number, and that should be crazy embarrassing except I’m too excited to see it up and running. Thanks so much!

1 Like

Great news! Glad you got it up and running. Enjoy!

1 Like

Did you expand the disk? These instructions are from shield but should apply to stock Norns:

that seems about right.

the norns samba configuration is set to serve the contents of /home/we/dust (where scripts and user data live,) but there is a lot more on the norns filesystem (e.g. the entire linux OS.)

i don’t think expanding the filesystem will net you much if anything on a 4gb disk, but it won’t hurt either.

Thanks, @jonny and @zebra. I went ahead with expanding the filesystem and had no change in storage availability on the 4 GB CM3+. Just noting that here in case any others come through with a similar question


It’s bizzare, I try to run an update (it says it’s available), then it throws this out

new script

checking for update
releases = {
  stable = {
  beta = {
# script clear
shutting down audio...
clearing old updates...
starting download...
> wget -T 180 -q -P /home/we/update/
checksum validation...
: No such file or directory
update failed.

you need to flash the new image for version 2.7.0. this is a flul disk wipe. details and installation instructions are in the forum post.

the beta update you’re seeing in the menu is for the (as-yet-unannounced) v2.7.1 hotfix. you need to run the 229306 update first, which requires downloading the image and re-flashing your disk; it can’t be done from the norns menu.

(the fact that the “stable” update is showing 220306 is a limitation of our update system, which doesn’t know that the 220306 release doesn’t actually contain an update script. this is an unusual circumstance though.)


Done, but after the first reboot the screen only says “jack fail.” What’s going on?

sorry to hear about the continued trouble!

most typically, this points to a version of the software being installed which your hardware does not support.

i’m going to migrate these posts to the update thread for further troubleshooting :sparkles:

@St0rMl0rD, it all depends on which version of the shield + which pi you have:

hardware version pi software version to download
211028 revision shield raspberry pi 3 norns220306-shield-pi3-cs4271.tgz
211028 revision shield raspberry pi 4 norns220306-shield-pi4-cs4271.tgz
pre-211028 shield raspberry pi 3 norns220306-shield-pi3-cs4270.tgz
pre-211028 shield raspberry pi 4 norns220306-shield-pi4-cs4270.tgz
machined aluminum norns (aka ‘standard’ norns) cm3 or cm3+ norns220306-standard.tgz

I have norns shield 191106 and 3.1 (I think, if that’s the number next to the logo on the raspberry pi)

rad, that’ll land you with this file !
please give it a quick reflash with this one and let us know if trouble persists!

Now it worked, thanks! Got the supercollider fail after the first restart, but not after the second, so all good (for) now. Thanks a ton!


After finally updating as well, I have a couple of documentation improvement suggestions:

  1. on under “Shield”/4. it says “Advanced”, the entry is “Advanced Options”
  2. more important: for those using Etcher under Windows. My flashing failed multiple times, because the UAC (user account control) pop up interfered with it. You need to run Etcher as administrator so that doesn’t happen.
  3. on
    a: I would replace “in lieu” with “instead of”, much simpler
    b: under 3. it says unzip, but this is not a traditional zip file, it is a tgz. I use 7zip on windows and this needed 2 steps, first to .tar and then to .img
  4. strangely enough my Windows10 did not include an ssh client (which it should have), so I used WSL/Ubuntu, but that didn’t find the bonjour name, so I had to use the IP address

ooooOOOooo weee…

just updated all three factory norns and a shield.

only thing that was a bump in the road was DUPLICATE ENGINES problem.

once those were cleared out…i ran into one more glitch…
if i sent a ;RESTART from maiden…after the duplicate warning…
it would display jack fail in the lower left hand corner.

and it would completely lock up.
had to use the white button of DOOM.

however…if you use the norns menu and use SLEEP it doesn’t crash or display that error.