Norns not recognized in disk mode

Trying to get back into norns, latest update worked, but experienced some odd things like supercollider errors I never had before, so I wanted to do a fresh install as described here.

But although it is in DISK mode, and connected to norns’s USB power port, the norns is not recognized by my MacBook 10.14.6. No light lights up on its back when connected to the computer.

Tried all of the computer’s USB ports, swapped USB cables, nothing works. Putting it back to RUN mode, norns starts up. I can charge it via its USB power port. But in DISK mode, it won’t be recognized by the computer using the very same cable that worked for charging.

Please, what else can I try? It is quite disconcerning that it doesn’t seem to work in DISK mode.

sorry to hear about the trouble!

just to confirm:

  • you’re connecting norns to your computer and then flipping to disk mode?
  • the switch is kind of hard to pull all the way down, is it clicking audibly?
  • how are you verifying that it’s not recognized? does Compute Module just not appear as a target in etcher? it should also show up as boot in Finder.

No light lights up on its back when connected to the computer.

fwiw, the light only stays on for a few seconds as it mounts, but it turns off after.

Thanks for your answer, looks like I found the culprit (=me):

No, I first had the switch flipped to disk mode, then connected norns.
When I first connected norns, then flipped to disk mode, norns was recognized.

But the connection was quite fragile, it was lost when I moved norns (I was holding it in one hand and moved the switch with the other using a plastic toothpick). So unplug, back to run mode, replug, put norns on its side, then moved the switch while holding norns’s top side.

During flashing and verification I almost did not dare to breathe due to fear that any vibration might cause a lost connection…

It did click audibly.

When norns was not found, the light on its back did not light up at all, it did not show up in etcher, and did not show up in Finder.

Phew…I am so glad that this worked, but still sort of scared that the connection seems to be so fragile. Is this expected?

Update to 200604 also worked fine after the fresh install, no error messages, and now all scripts show up (not just a limited set, which was the case after I updated from 190405 to 200604 the other day).

Thanks much again!