Norns screen goes blank after boot up

so…
this started happening after the update to OS 201115

one of my norns will boot up as normal and after the digital dust moves through…the screen just goes blank and any button pushing doesn’t bring up a menu.
:frowning:
i usually have the WiFi dongle powered off so it’s out of the equation.

i will send power to the WiFi dongle and wait a bit and then connect via maiden.

send a ;RESTART message and then it will boot up just fine and go to the SELECT/SYSTEM/SLEEP screen menu.

thought it was a one off hiccup but…this has happened three times now over a period of a few days.

any ideas what could be going on?

thanks for any help!
:slight_smile:

1 Like

Revisiting this, for me at least this happens when a grid is plugged in to the farthest right usb slot. When I turn norms on the top two lights of the grid light up and then after the dust, blank screen and the buttons do nothing. If I unplug the grid the screen appears. Not sure if this the same as spikes issue.

2 Likes

can you narrow this down to startup lock when you’re booting into a particular script?

(i had this happen yesterday with a glut-based script (angl) and it’s the old supercollider timeshift bug.)

hmmm…
i generally always clear all scripts before SLEEP.

but…i think when i ran into this the other day i had forgot to clear and it had booted up into Cheat Codes 2.

i haven’t run into it again yet.

Mine was running the new cheat codes. Will test tonight with others.

1 Like

@ngwese @tehn any possibility this could be related to pesky urb status...?

(if it really is specifically with USB device connected on boot… on a particular port…)

same unit seems to also show libmonome errors…

Hard to tell. I can do some testing. If this was related to the USB bus having one of its urb freak outs there would be ample output in dmesg

I thought I was running into this screen goes blank after the dust animation finishes problem just the other day but it turned out that the power adapter had been unplugged and the battery was at 0%. There was just enough to boot the device then —— poof.

ah yeah that’s a really good point.

it should be in big letters somewhere:

always perform updates on wall power
reproduce issue on wall power before reporting

(esp. with hungry USB devices)

2 Likes

for updating we can actually programmatically require power, as i just put in a pr which allows distinguishing shield from norns

side note, cc is poll heavy so this is likely a timesync issue

Tested on abacus, animator, and arcologies. Getting Blank screen on after dust animation still. Device is plugged in. Same as above, responds after port 1 is unplugged and replugged.

2 Likes

apologies if you already did this - can you shell into norns, run dmesg, and post the last 20-30 lines or so?

also just to confirm - only an issue with grid plugged on boot?

ted - version: 0.36
[ 6.751870] random: crng init done
[ 6.751880] random: 7 urandom warning(s) missed due to ratelimiting
[ 6.774059] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 7.159938] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 9.763599] wlan0: authenticate with 48:5d:36:8f:54:d8
[ 9.796137] wlan0: send auth to 48:5d:36:8f:54:d8 (try 1/3)
[ 9.797749] wlan0: authenticated
[ 9.813141] wlan0: associate with 48:5d:36:8f:54:d8 (try 1/3)
[ 9.816682] wlan0: RX AssocResp from 48:5d:36:8f:54:d8 (capab=0x1431 status=0 aid=2)
[ 9.824524] wlan0: associated
[ 9.824646] wlan0: Limiting TX power to 30 (30 - 0) dBm as advertised by 48:5d:36:8f:54:d8
[ 9.888750] cryptd: max_cpu_qlen set to 1000
[ 9.917058] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 377.180358] ftdi_sio ttyUSB0: usb_serial_generic_write_bulk_callback - urb stopped: -32
[ 377.180472] ftdi_sio ttyUSB0: usb_serial_generic_write_bulk_callback - urb stopped: -32
[ 377.180598] ftdi_sio ttyUSB0: usb_serial_generic_read_bulk_callback - urb stopped: -32
[ 377.180716] ftdi_sio ttyUSB0: usb_serial_generic_read_bulk_callback - urb stopped: -32
[ 377.280500] ftdi_sio ttyUSB0: usb_serial_generic_write_bulk_callback - urb stopped: -32
[ 377.280744] ftdi_sio ttyUSB0: usb_serial_generic_write_bulk_callback - urb stopped: -32
[ 377.387624] usb 1-1.2: USB disconnect, device number 4
[ 377.387797] ftdi_sio ttyUSB0: error from flowcontrol urb
[ 377.388002] ftdi_sio ttyUSB0: FTDI USB Serial Device converter now disconnected from ttyUSB0
[ 377.388039] ftdi_sio 1-1.2:1.0: device disconnected
[ 381.783521] usb 1-1.2: new full-speed USB device number 5 using dwc_otg
[ 381.937115] usb 1-1.2: New USB device found, idVendor=0403, idProduct=6001, bcdDevice= 6.00
[ 381.937124] usb 1-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 381.937129] usb 1-1.2: Product: monome
[ 381.937133] usb 1-1.2: Manufacturer: monome
[ 381.937137] usb 1-1.2: SerialNumber: m1000582
[ 381.941264] ftdi_sio 1-1.2:1.0: FTDI USB Serial Device converter detected
[ 381.941351] usb 1-1.2: Detected FT232RL
[ 381.942368] usb 1-1.2: FTDI USB Serial Device converter now attached to ttyUSB1
yes. Only seeing it with the grid plugged in.

yeah that looks pretty fishy.

@tehn, AFAIK, the time-sync issue should only emerge with supercollider, not with softcut polls

3 Likes

@zebra good point, thanks

yes I was having similar issues with a host/host adapter. unplug… all is good In the hood.

1 Like

was running into this blank screen problem with one of the norns.
it’s the one i have the MIDI Fighter Twister connected to for @dan_derks Cheat Codes 2.

after reading a bit above i killed the connection to the Twister with the USB hub and gave it the Vulcan Death Grip (K3-K2-K1) and it started back up.
it seems fine now.
:slight_smile:
is there a fix for this or is it just something to be wary of?

some sort of error must be occurring at startup that is in the system state.

are you able to replicate this fail state?

if so, open maiden, type ;restart into the repl and maybe we can get the error

1 Like

tried to replicate…
of course…now that i am looking for it to happen…it behaves.
ugh…ok…i will report if i can catch it!
:slight_smile:

ok…
i made sure everything was powered up on the USB hub at startup with the problem norns and it did it again from a cold wake up.

since the WiFi dongle had juice i was able to send it a ;restart.
it booted up again and now it seems to behaving.

not sure if there anything helpful in here…but this is what maiden says:

Summary

Binary file (standard input) matches
fonts:
0: 04B_03__.TTF
1: liquid.ttf
2: Roboto-Thin.ttf
3: Roboto-Light.ttf
4: Roboto-Regular.ttf
5: Roboto-Medium.ttf
6: Roboto-Bold.ttf
7: Roboto-Black.ttf
8: Roboto-ThinItalic.ttf
9: Roboto-LightItalic.ttf
10: Roboto-Italic.ttf
11: Roboto-MediumItalic.ttf
12: Roboto-BoldItalic.ttf
13: Roboto-BlackItalic.ttf
14: VeraBd.ttf
15: VeraBI.ttf
16: VeraIt.ttf
17: VeraMoBd.ttf
18: VeraMoBI.ttf
19: VeraMoIt.ttf
20: VeraMono.ttf
21: VeraSeBd.ttf
22: VeraSe.ttf
23: Vera.ttf
24: bmp/tom-thumb.bdf
25: bmp/creep.bdf
26: bmp/ctrld-fixed-10b.bdf
27: bmp/ctrld-fixed-10r.bdf
28: bmp/ctrld-fixed-13b.bdf
29: bmp/ctrld-fixed-13b-i.bdf
30: bmp/ctrld-fixed-13r.bdf
31: bmp/ctrld-fixed-13r-i.bdf
32: bmp/ctrld-fixed-16b.bdf
33: bmp/ctrld-fixed-16b-i.bdf
34: bmp/ctrld-fixed-16r.bdf
35: bmp/ctrld-fixed-16r-i.bdf
36: bmp/scientifica-11.bdf
37: bmp/scientificaBold-11.bdf
38: bmp/scientificaItalic-11.bdf
39: bmp/ter-u12b.bdf
40: bmp/ter-u12n.bdf
41: bmp/ter-u14b.bdf
42: bmp/ter-u14n.bdf
43: bmp/ter-u14v.bdf
44: bmp/ter-u16b.bdf
45: bmp/ter-u16n.bdf
46: bmp/ter-u16v.bdf
47: bmp/ter-u18b.bdf
48: bmp/ter-u18n.bdf
49: bmp/ter-u20b.bdf
50: bmp/ter-u20n.bdf
51: bmp/ter-u22b.bdf
52: bmp/ter-u22n.bdf
53: bmp/ter-u24b.bdf
54: bmp/ter-u24n.bdf
55: bmp/ter-u28b.bdf
56: bmp/ter-u28n.bdf
57: bmp/ter-u32b.bdf
58: bmp/ter-u32n.bdf
59: bmp/unscii-16-full.pcf
60: bmp/unscii-16.pcf
61: bmp/unscii-8-alt.pcf
62: bmp/unscii-8-fantasy.pcf
63: bmp/unscii-8-mcr.pcf
64: bmp/unscii-8.pcf
65: bmp/unscii-8-tall.pcf
66: bmp/unscii-8-thin.pcf
*** WARNING *** The program ‘matron’ uses the Apple Bonjour compatibility layer of Avahi.
*** WARNING *** Please fix your application to use the native API of Avahi!
*** WARNING *** For more information see http://0pointer.de/avahi-compat?s=libdns_sd&e=matron
OSC rx port: 8888
OSC crone port: 9999
OSC ext port: 57120
starting lua vm
running lua config file: dofile(’/home/we/norns/lua/core/config.lua’)
MATRON
norns version: 0.0.0
git hash: 3b4d7da
platform: 2
running startup
start_audio():
arc added: 2 monome arc m1100119 m1100119
grid added: 3 monome 128 m1000648 m1000648
norns.startup_status.ok

script clear

SCRIPT ERROR: NO SCRIPT

network connections:

1 DEATHNOTE
available engines (35):
Glut
Sway
Showers
Rudiments
Warb
Shepard
Grendy
SimpleDelay
Sines
Pixelbangs
Greyhole
Ack
Phyllis
MGlut
Decimatec
Dronecaster
MollyThePoly
Decimator
R
PolyPerc
Hachi
YggdrasilSynth
Benjolis
Timber
Passersby
Pools
Timber_Takt
Stack
SCgazer
Manifold
PrimitiveString
None
HereThere
Haven
Lissadron

Unrelated but how do you do that cool drop down magic? I can’t seem to figure it out