norns shield 2022


Pretty sure this has to do with rfi - seems to disappear when I turn off wifi (on norns), move my phone farther away, and turn off bluetooth on my computer. Possible not all these are necessary, but good to try all when troubleshooting.

1 Like

yeah, shield/rpi are pretty susceptible to RF noise. easily picks up my cellphone within ~1ft?, and i have a baby monitor that really blasts it.

both these recordings sound pretty typical.

but! i don’t know what gain was involved or what dynamic range we are talking about. there is some noise floor of course, and it is full of digital signals leaking from elsewhere in the pi.

1 Like

Could DIYing some sort of shielding (no pun intended) for the inside of the case help at all here? Copper tape or that sort of thing…

i guess? sounds hard? i just move the thing away from the phone. (this actually applies to greater or lesser degree to every piece of audio equipment i own, including e.g. cables, laptops, guitars microphones, amplifiers etc.)

but yeah the metal case designs might help, where there is metal above/surrounding the 40-pin header connection, over the codec, everywhere

or sure, tape all over inside of 3d printed case, why not, worth a try

but emphasizing my edit above, there is also always going to be some noise floor and i cant actually tell what level these recordings are capturing. the thing to do of course is to also record a full scale signal and compare that with the noise.

so, if these artifacts are super audible at normal listening levels then RF would be my first guess diagnosis. if they are down below, say, -40dBu i’d wonder. (first rev shields might get that much leakage - only on ADC, not DAC - and latest is better, tho ive not measured noise floor on one myself.)

1 Like

I have similar noise issues if I’m too close to my wireless router.

Also, I’d be interested in a metal case if somebody has made one with a screen protector.

regarding the case:

upon investigating more closely, the misalignment of the top plate and enclosure is a result of the USB/ethernet ports of the pi4 being pushed further out just slightly. with the port separations cut out, it’s much easier to position these ports to rest slightly on the bottom lip, rather than behind the bottom lip of the case.

here’s the cut guide for modifying:

here’s a video of me doing an incredibly fast chop of a case. please take your time, be careful. there are numerous other ways to modify the case with other tools— this plastic cuts pretty easily, but again, be careful.

once remounting everything sits nicely (as posted earlier)

18 Likes

thank you for your support!

shields started shipping on March 8th (oldest orders to newest) and we’ll continue to ship as we receive stock from our assembler – we expect all queued preorders to be out by March 24th. you’ll get a tracking number as soon as yours goes out. but please let us know if we can assist directly with anything else in the meantime via help@monome.org :gem:

6 Likes

Thank you so much for the info! Looking forward to it :package:

Hi there! waiting patiently for my norns shield to arrive :slight_smile:

Question : are the recommandations for AWG and cable specs of the power supply applies also to the Raspberry 4 (USB-C) ?

My RB4 was delivered with an unofficial power supply. I guess I will see once plugged if it’s ok, but just to be sure

1 Like

The above cutting guide worked perfectly for me (using only an x-acto). Thank you!

Before:

After:

6 Likes

I just got my new Norns Shield. I installed cs4271 but it produced a JACK FAIL error. So I installed OS version cs4270. Install worked but now the input jack doesn’t work.

It shipped March 8 so I think it’s a 2022. But the circuit board says 221028.

I’m a newb. You all have a lot more experience than I do. Any ideas what I’m doing wrong?

I just got the 2022 shield and that’s the revision printed on the PCB.

Which Raspberry Pi are you using it with? The OS is specific to the hardware + shield combination. Either way, the 4270 variation is the correct one, not 4271.

I am confused by the above post - @dan_derks has supplied this info in another thread. Isn’t 4271 the correct disk image for the newly shipped shield + rp4 combo?

1 Like

I’m using a Raspberry Pi 4. Shield has 221028 on the PCB.

There may be conflicting instructions out there. Monome instructions say March 8th shipments should use cs4271, but others directions say “version number 220101 or greater printed on the circuit board) use the cs4271”.

apologies! the docs had a typo, corrected now.

the new shields are 211028, which have a cs4271 codec. all earlier versions have cs4720.


also, regarding top plate alignment. there is substantial play due to the hole size in the plexi plate. for perfect alignment, i might suggest loosening all screws in the plate and then re-tightening after centering around the enclosure.

4 Likes

I was looking at this page:

1 Like

9 posts were merged into an existing topic: Building the world you want to live in

Hi everyone, my norns shield just arrive and after following all the instructions (flashing microsd card with 211028 revision shield, Raspberry Pi4 and then assembly. After that my device doesnt start, it stay with a red light and nothing on display. Sorry if is a dumb question but im totally new in this world.

i’d suggest re-flashing the image again, potentially trying another card as well. do you get any green blinking at all?

1 Like

There is like 2 blinking of the green light at the start, then only a red light. I already tried with a 3 different microSD cards and nothing.