norns shield 2022

apologies! the docs had a typo, corrected now.

the new shields are 211028, which have a cs4271 codec. all earlier versions have cs4720.


also, regarding top plate alignment. there is substantial play due to the hole size in the plexi plate. for perfect alignment, i might suggest loosening all screws in the plate and then re-tightening after centering around the enclosure.

4 Likes

I was looking at this page:

1 Like

9 posts were merged into an existing topic: Building the world you want to live in

Hi everyone, my norns shield just arrive and after following all the instructions (flashing microsd card with 211028 revision shield, Raspberry Pi4 and then assembly. After that my device doesnt start, it stay with a red light and nothing on display. Sorry if is a dumb question but im totally new in this world.

i’d suggest re-flashing the image again, potentially trying another card as well. do you get any green blinking at all?

1 Like

There is like 2 blinking of the green light at the start, then only a red light. I already tried with a 3 different microSD cards and nothing.

I’ve had this behavior before when I flashed the wrong image for the hardware, are you sure you have the right one? Maybe try another even if you think you do?

1 Like

8 posts were merged into an existing topic: Norns shield glitches in recordings when recording with tape

I got my norns shield today, very excited! The setup was a breeze, and the case mod for the Raspberry Pi 4 went pretty smooth too. The left channel input seems to have a lot of noise coming in and nothing is connected. Could someone please give me a little guidance on how to troubleshoot this issue? Thanks :pray:t4:

Edit:
Forgot to mention, I’m using the included (from monome) official Raspberry Pi power supply, and also tried with a different official one that I use for my NAS, and I still kept hearing all the noise on the left channel.

4 Likes

I had the same issue, and in my case, it occurred because I removed the white sticker on the shield circuit that prevents part of the circuit from touching the pi. Replacing that solved the problem.

3 Likes

I haven’t touched the sticker but now that you made me notice it I saw that the capacitors and the IC under it were touching the top of USB ports housing, just some Scotch tape and the noise appears to be all gone. Thank you so much!

10 Likes

Just set up my norns shield today and I noticed that the way I had it assembled had the pi 3B+ at an angle, which blocked off one of the usb ports, but everything else worked fine. I took it apart and straightened everything out, but now when I turn the shield on the screen doesn’t turn on, even though I can see that the pi itself is on. Any tips?

Have you flashed the SD card? Does the not-red led light up when you power on the Pi?

Yeah I’ve already flashed it and everything was working until I reassembled the shield. The green light also flashes when I turn it on.

First, try turning it on with the output connected to some speakers or headphones. About ten seconds after you turn it on, you should hear the startup drone/tone play. If not, you can then at least isolate it to the connection between the shield and the Pi. To be honest, I’m pretty sure the issue will be found there anyway. Try seperating the pi from the shield and carefully reconnecting it, making sure all the pins are connected correctly.

1 Like

Has anyone else had issues with insanely loud static/hiss? I’m encountering it often when trying to load/play samples, but it seems to be occurring almost randomly. I think it’s happened when I’ve just been changing parameters. Happens across different scripts, too—I’ve had the issue with Barcode, Buoys, MLR (I think) and maybe a couple more I’m forgetting. I don’t believe it’s a ground loop problem. It also doesn’t seem to matter whether the norns is receiving audio/midi, and I’ve tested multiple outlets and speakers. It just comes out of nowhere. Any ideas?

Have you ruled out interference from wireless devices like phones or routers?

I’m pretty sure, but it could be something I’m missing. I’ll try a greater radius of distance and see if it still happens.

probably this issue

5 Likes

This sounds exactly like it. Thank you! Will give this a try.